extra/thunderbird to 60.6.1-1

This commit is contained in:
Kevin Mihelich 2019-04-06 05:19:32 +00:00
parent e773f19ffe
commit a0b280cc47
2 changed files with 81 additions and 5 deletions

View file

@ -13,7 +13,7 @@ buildarch=12
highmem=1
pkgname=thunderbird
pkgver=60.5.3
pkgver=60.6.1
pkgrel=1
pkgdesc='Standalone mail and news reader from mozilla.org'
url='https://www.mozilla.org/thunderbird/'
@ -26,10 +26,11 @@ makedepends=(unzip zip diffutils python2 yasm mesa imake gconf libpulse inetutil
optdepends=('libcanberra: sound support')
options=(!emptydirs !makeflags)
source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz
rust-1.33.patch
$pkgname.desktop
Bug-1238661---fix-mozillaSignalTrampoline-to-work-.patch)
sha256sums=('83c91c4dc9b537aca99db45f99ccf2258cd830c704fb4aa994df18272c8a5211'
'e44c55501f650a4e80b9c353b81f33e07ca65808db831eff6ca616aded233827'
sha256sums=('17aef9232a76bdc812422883c02b01b4ecb7633c3ee9870da5e4ec0e20ba5f67'
'97bdb978d59cf5f0f967750e9d8dfbc8fc73367b08437838c44a308fe2ee5442'
'36a655ce3987159990d46a13d9955305a72a8a737e6af983eb170c4f652eb39a')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
@ -47,6 +48,9 @@ _mozilla_api_key=16674381-f021-49de-8622-3021c5942aff
prepare() {
cd $pkgname-$pkgver
# https://bugzilla.mozilla.org/show_bug.cgi?id=1539901 (Patch from Fedora)
patch -Np1 -i ../rust-1.33.patch
echo -n "$_google_api_key" >google-api-key
echo -n "$_mozilla_api_key" >mozilla-api-key
@ -59,7 +63,8 @@ ac_add_options --enable-release
#ac_add_options --enable-linker=gold
#ac_add_options --enable-hardening
#ac_add_options --enable-optimize
ac_add_options --enable-rust-simd
# https://bugzilla.mozilla.org/show_bug.cgi?id=1521249
#ac_add_options --enable-rust-simd
# Branding
ac_add_options --enable-official-branding
@ -67,7 +72,8 @@ ac_add_options --enable-update-channel=release
ac_add_options --with-distribution-id=org.archlinux
# Keys
ac_add_options --with-google-api-keyfile=${PWD@Q}/google-api-key
ac_add_options --with-google-location-service-api-keyfile=${PWD@Q}/google-api-key
ac_add_options --with-google-safebrowsing-api-keyfile=${PWD@Q}/google-api-key
ac_add_options --with-mozilla-api-keyfile=${PWD@Q}/mozilla-api-key
# ALARM

View file

@ -0,0 +1,70 @@
diff -up thunderbird-60.5.3/servo/components/style/gecko/regen_atoms.py.rust-1.33-build thunderbird-60.5.3/servo/components/style/gecko/regen_atoms.py
--- thunderbird-60.5.3/servo/components/style/gecko/regen_atoms.py.rust-1.33-build 2019-03-04 19:17:31.000000000 +0100
+++ thunderbird-60.5.3/servo/components/style/gecko/regen_atoms.py 2019-03-13 15:05:58.965726109 +0100
@@ -202,6 +202,7 @@ RULE_TEMPLATE = ('("{atom}") =>\n '
' }}}};')
MACRO = '''
+/// Returns a static atom by passing the literal string it represents.
#[macro_export]
macro_rules! atom {{
{}
diff -up thunderbird-60.5.3/servo/components/style/gecko_string_cache/namespace.rs.rust-1.33-build thunderbird-60.5.3/servo/components/style/gecko_string_cache/namespace.rs
--- thunderbird-60.5.3/servo/components/style/gecko_string_cache/namespace.rs.rust-1.33-build 2019-03-04 19:17:27.000000000 +0100
+++ thunderbird-60.5.3/servo/components/style/gecko_string_cache/namespace.rs 2019-03-13 15:05:58.966726107 +0100
@@ -11,6 +11,7 @@ use std::fmt;
use std::ops::Deref;
use string_cache::{Atom, WeakAtom};
+/// Macro text
#[macro_export]
macro_rules! ns {
() => { $crate::string_cache::Namespace(atom!("")) };
diff -up thunderbird-60.5.3/servo/components/style/properties/properties.mako.rs.rust-1.33-build thunderbird-60.5.3/servo/components/style/properties/properties.mako.rs
--- thunderbird-60.5.3/servo/components/style/properties/properties.mako.rs.rust-1.33-build 2019-03-04 19:17:30.000000000 +0100
+++ thunderbird-60.5.3/servo/components/style/properties/properties.mako.rs 2019-03-13 15:05:58.966726107 +0100
@@ -55,6 +55,7 @@ use style_adjuster::StyleAdjuster;
pub use self::declaration_block::*;
+/// Generated
#[cfg(feature = "gecko")]
#[macro_export]
macro_rules! property_name {
@@ -3852,7 +3853,7 @@ impl fmt::Debug for AliasId {
}
}
-// NOTE(emilio): Callers are responsible to deal with prefs.
+/// Callers are responsible to deal with prefs.
#[macro_export]
macro_rules! css_properties_accessors {
($macro_name: ident) => {
@@ -3875,6 +3876,7 @@ macro_rules! css_properties_accessors {
}
}
+/// Neco
#[macro_export]
macro_rules! longhand_properties_idents {
($macro_name: ident) => {
diff -up thunderbird-60.5.3/servo/components/style_traits/values.rs.rust-1.33-build thunderbird-60.5.3/servo/components/style_traits/values.rs
--- thunderbird-60.5.3/servo/components/style_traits/values.rs.rust-1.33-build 2019-03-04 19:17:27.000000000 +0100
+++ thunderbird-60.5.3/servo/components/style_traits/values.rs 2019-03-13 15:37:34.077560034 +0100
@@ -135,6 +135,7 @@ where
}
}
+/// Neco
#[macro_export]
macro_rules! serialize_function {
($dest: expr, $name: ident($( $arg: expr, )+)) => {
@@ -404,7 +405,7 @@ impl_to_css_for_predefined_type!(::csspa
impl_to_css_for_predefined_type!(::cssparser::Color);
impl_to_css_for_predefined_type!(::cssparser::UnicodeRange);
-#[macro_export]
+/// Define an enum type with unit variants that each correspond to a CSS keyword.
macro_rules! define_css_keyword_enum {
(pub enum $name:ident { $($variant:ident = $css:expr,)+ }) => {
#[allow(missing_docs)]