mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/java8-openjdk-aarch64 to 8.u242-1.1
This commit is contained in:
parent
99d7938ced
commit
a0b645b980
5 changed files with 256 additions and 95 deletions
147
extra/java8-openjdk-aarch64/8143245-pr3548.patch
Normal file
147
extra/java8-openjdk-aarch64/8143245-pr3548.patch
Normal file
|
@ -0,0 +1,147 @@
|
|||
# HG changeset patch
|
||||
# User sgehwolf
|
||||
# Date 1525714161 -3600
|
||||
# Mon May 07 18:29:21 2018 +0100
|
||||
# Node ID afb31413c73cbc06420fdb447aa90a7a38258904
|
||||
# Parent bcbc64dfb629c5f188bbf59b8f986ad95963ed60
|
||||
8143245, PR3548: Zero build requires disabled warnings
|
||||
Reviewed-by: dholmes, coleenp
|
||||
|
||||
diff --git openjdk.orig/hotspot/make/linux/makefiles/zeroshark.make openjdk/hotspot/make/linux/makefiles/zeroshark.make
|
||||
--- openjdk.orig/hotspot/make/linux/makefiles/zeroshark.make
|
||||
+++ openjdk/hotspot/make/linux/makefiles/zeroshark.make
|
||||
@@ -1,5 +1,5 @@
|
||||
#
|
||||
-# Copyright (c) 2003, 2015, Oracle and/or its affiliates. All rights reserved.
|
||||
+# Copyright (c) 2003, 2016, Oracle and/or its affiliates. All rights reserved.
|
||||
# Copyright 2007, 2008 Red Hat, Inc.
|
||||
# DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
|
||||
#
|
||||
@@ -29,12 +29,6 @@
|
||||
ifeq ($(JVM_VARIANT_ZEROSHARK), true)
|
||||
WARNING_FLAGS += -Wno-undef
|
||||
endif
|
||||
-# Suppress some warning flags that are normally turned on for hotspot,
|
||||
-# because some of the zero code has not been updated accordingly.
|
||||
-WARNING_FLAGS += -Wno-return-type \
|
||||
- -Wno-format-nonliteral -Wno-format-security \
|
||||
- -Wno-maybe-uninitialized
|
||||
-
|
||||
|
||||
# If FDLIBM_CFLAGS is non-empty it holds CFLAGS needed to be passed to
|
||||
# the compiler so as to be able to produce optimized objects
|
||||
diff --git openjdk.orig/hotspot/src/cpu/zero/vm/cppInterpreter_zero.cpp openjdk/hotspot/src/cpu/zero/vm/cppInterpreter_zero.cpp
|
||||
--- openjdk.orig/hotspot/src/cpu/zero/vm/cppInterpreter_zero.cpp
|
||||
+++ openjdk/hotspot/src/cpu/zero/vm/cppInterpreter_zero.cpp
|
||||
@@ -100,7 +100,7 @@
|
||||
case T_DOUBLE:
|
||||
case T_VOID:
|
||||
return result;
|
||||
- default : ShouldNotReachHere();
|
||||
+ default : ShouldNotReachHere(); return NULL_WORD;
|
||||
}
|
||||
}
|
||||
|
||||
diff --git openjdk.orig/hotspot/src/cpu/zero/vm/interpreterRT_zero.cpp openjdk/hotspot/src/cpu/zero/vm/interpreterRT_zero.cpp
|
||||
--- openjdk.orig/hotspot/src/cpu/zero/vm/interpreterRT_zero.cpp
|
||||
+++ openjdk/hotspot/src/cpu/zero/vm/interpreterRT_zero.cpp
|
||||
@@ -1,5 +1,5 @@
|
||||
/*
|
||||
- * Copyright (c) 2003, 2012, Oracle and/or its affiliates. All rights reserved.
|
||||
+ * Copyright (c) 2003, 2016, Oracle and/or its affiliates. All rights reserved.
|
||||
* Copyright 2007, 2008, 2010 Red Hat, Inc.
|
||||
* DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
|
||||
*
|
||||
@@ -62,7 +62,7 @@
|
||||
}
|
||||
|
||||
void InterpreterRuntime::SignatureHandlerGeneratorBase::push(BasicType type) {
|
||||
- ffi_type *ftype;
|
||||
+ ffi_type *ftype = NULL;
|
||||
switch (type) {
|
||||
case T_VOID:
|
||||
ftype = &ffi_type_void;
|
||||
diff --git openjdk.orig/hotspot/src/os_cpu/linux_zero/vm/os_linux_zero.cpp openjdk/hotspot/src/os_cpu/linux_zero/vm/os_linux_zero.cpp
|
||||
--- openjdk.orig/hotspot/src/os_cpu/linux_zero/vm/os_linux_zero.cpp
|
||||
+++ openjdk/hotspot/src/os_cpu/linux_zero/vm/os_linux_zero.cpp
|
||||
@@ -1,6 +1,6 @@
|
||||
/*
|
||||
* Copyright (c) 2003, 2018, Oracle and/or its affiliates. All rights reserved.
|
||||
- * Copyright 2007, 2008, 2009, 2010 Red Hat, Inc.
|
||||
+ * Copyright 2016 Red Hat, Inc.
|
||||
* DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
|
||||
*
|
||||
* This code is free software; you can redistribute it and/or modify it
|
||||
@@ -61,6 +61,7 @@
|
||||
|
||||
frame os::get_sender_for_C_frame(frame* fr) {
|
||||
ShouldNotCallThis();
|
||||
+ return frame(NULL, NULL); // silence compile warning.
|
||||
}
|
||||
|
||||
frame os::current_frame() {
|
||||
@@ -98,16 +99,19 @@
|
||||
|
||||
address os::Linux::ucontext_get_pc(ucontext_t* uc) {
|
||||
ShouldNotCallThis();
|
||||
+ return NULL; // silence compile warnings
|
||||
}
|
||||
|
||||
ExtendedPC os::fetch_frame_from_context(void* ucVoid,
|
||||
intptr_t** ret_sp,
|
||||
intptr_t** ret_fp) {
|
||||
ShouldNotCallThis();
|
||||
+ return NULL; // silence compile warnings
|
||||
}
|
||||
|
||||
frame os::fetch_frame_from_context(void* ucVoid) {
|
||||
ShouldNotCallThis();
|
||||
+ return frame(NULL, NULL); // silence compile warnings
|
||||
}
|
||||
|
||||
extern "C" JNIEXPORT int
|
||||
@@ -247,11 +251,16 @@
|
||||
}
|
||||
#endif // !PRODUCT
|
||||
|
||||
- const char *fmt = "caught unhandled signal %d";
|
||||
char buf[64];
|
||||
|
||||
- sprintf(buf, fmt, sig);
|
||||
+ sprintf(buf, "caught unhandled signal %d", sig);
|
||||
+
|
||||
+// Silence -Wformat-security warning for fatal()
|
||||
+PRAGMA_DIAG_PUSH
|
||||
+PRAGMA_FORMAT_NONLITERAL_IGNORED
|
||||
fatal(buf);
|
||||
+PRAGMA_DIAG_POP
|
||||
+ return true; // silence compiler warnings
|
||||
}
|
||||
|
||||
void os::Linux::init_thread_fpu_state(void) {
|
||||
@@ -260,6 +269,7 @@
|
||||
|
||||
int os::Linux::get_fpu_control_word() {
|
||||
ShouldNotCallThis();
|
||||
+ return -1; // silence compile warnings
|
||||
}
|
||||
|
||||
void os::Linux::set_fpu_control_word(int fpu) {
|
||||
diff --git openjdk.orig/hotspot/src/os_cpu/linux_zero/vm/thread_linux_zero.hpp openjdk/hotspot/src/os_cpu/linux_zero/vm/thread_linux_zero.hpp
|
||||
--- openjdk.orig/hotspot/src/os_cpu/linux_zero/vm/thread_linux_zero.hpp
|
||||
+++ openjdk/hotspot/src/os_cpu/linux_zero/vm/thread_linux_zero.hpp
|
||||
@@ -1,5 +1,5 @@
|
||||
/*
|
||||
- * Copyright (c) 2000, 2010, Oracle and/or its affiliates. All rights reserved.
|
||||
+ * Copyright (c) 2000, 2016, Oracle and/or its affiliates. All rights reserved.
|
||||
* Copyright 2007, 2008, 2009, 2010 Red Hat, Inc.
|
||||
* DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
|
||||
*
|
||||
@@ -110,6 +110,7 @@
|
||||
void* ucontext,
|
||||
bool isInJava) {
|
||||
ShouldNotCallThis();
|
||||
+ return false; // silence compile warning
|
||||
}
|
||||
|
||||
// These routines are only used on cpu architectures that
|
32
extra/java8-openjdk-aarch64/8197981-pr3548.patch
Normal file
32
extra/java8-openjdk-aarch64/8197981-pr3548.patch
Normal file
|
@ -0,0 +1,32 @@
|
|||
# HG changeset patch
|
||||
# User andrew
|
||||
# Date 1518667645 0
|
||||
# Thu Feb 15 04:07:25 2018 +0000
|
||||
# Node ID 1d35411eb7bdf16191e220ffe3b1dc4d5d0c6041
|
||||
# Parent 999983606f5c61b093c6f6316a7b26c4cd4ca79e
|
||||
8197981, PR3548: Missing return statement in __sync_val_compare_and_swap_8
|
||||
Summary: Fix issue discovered by -Wreturn-type on systems without LP64.
|
||||
Reviewed-by: aph
|
||||
|
||||
diff --git openjdk.orig/hotspot/src/os_cpu/bsd_zero/vm/os_bsd_zero.cpp openjdk/hotspot/src/os_cpu/bsd_zero/vm/os_bsd_zero.cpp
|
||||
--- openjdk.orig/hotspot/src/os_cpu/bsd_zero/vm/os_bsd_zero.cpp
|
||||
+++ openjdk/hotspot/src/os_cpu/bsd_zero/vm/os_bsd_zero.cpp
|
||||
@@ -457,6 +457,7 @@
|
||||
long long unsigned int oldval,
|
||||
long long unsigned int newval) {
|
||||
ShouldNotCallThis();
|
||||
+ return 0;
|
||||
}
|
||||
};
|
||||
#endif // !_LP64
|
||||
diff --git openjdk.orig/hotspot/src/os_cpu/linux_zero/vm/os_linux_zero.cpp openjdk/hotspot/src/os_cpu/linux_zero/vm/os_linux_zero.cpp
|
||||
--- openjdk.orig/hotspot/src/os_cpu/linux_zero/vm/os_linux_zero.cpp
|
||||
+++ openjdk/hotspot/src/os_cpu/linux_zero/vm/os_linux_zero.cpp
|
||||
@@ -498,6 +498,7 @@
|
||||
long long unsigned int oldval,
|
||||
long long unsigned int newval) {
|
||||
ShouldNotCallThis();
|
||||
+ return 0;
|
||||
}
|
||||
};
|
||||
#endif // !_LP64
|
|
@ -1,39 +1,32 @@
|
|||
# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
|
||||
# Maintainer: Guillaume ALAUX <guillaume@archlinux.org>
|
||||
# Contributor: Boyan Ding <stu_dby@126.com>
|
||||
|
||||
# TODO
|
||||
# once icedtea:
|
||||
# pulse
|
||||
# add policytool desktop files
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - disable distcc
|
||||
# - add arm to _JARCH and _DOC_ARCH
|
||||
# - configure with --with-jvm-variants=zero
|
||||
# - adjust doc package to use linux-${_DOC_ARCH}-normal-zero-release instead of normal-server-release
|
||||
# - prevent downgrading hotspot optimization with CFLAGS
|
||||
# - drop building docs and its package; takes forever to build
|
||||
# - patches to fix zero build with up to date GCC and glibc
|
||||
|
||||
buildarch=8
|
||||
buildarch=22
|
||||
|
||||
# Package 'openjfx' must be updated when this one is
|
||||
pkgname=('jre8-openjdk-headless' 'jre8-openjdk' 'jdk8-openjdk' 'openjdk8-src')
|
||||
pkgbase=java8-openjdk-aarch64
|
||||
_java_ver=8
|
||||
# Found @ http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html
|
||||
_jdk_update=171
|
||||
# Found @ http://hg.openjdk.java.net/aarch64-port/jdk8u/
|
||||
_jdk_build=10
|
||||
_jdk_update=242
|
||||
_jdk_build=08
|
||||
pkgver=${_java_ver}.u${_jdk_update}
|
||||
_repo_ver=aarch64-jdk${_java_ver}u${_jdk_update}-b${_jdk_build}
|
||||
_repo_ver=aarch64-shenandoah-jdk${_java_ver}u${_jdk_update}-b${_jdk_build}
|
||||
_jdk8u_repo_ver=shenandoah-aarch64-shenandoah-jdk${_java_ver}u${_jdk_update}-b${_jdk_build}
|
||||
pkgrel=1.1
|
||||
arch=('x86_64')
|
||||
url='http://openjdk.java.net/'
|
||||
url='https://openjdk.java.net/'
|
||||
license=('custom')
|
||||
options=('!distcc')
|
||||
makedepends=('jdk7-openjdk' 'ccache' 'cpio' 'unzip' 'zip'
|
||||
makedepends=('java-environment=8' 'ccache' 'cpio' 'unzip' 'zip'
|
||||
'libxrender' 'libxtst' 'fontconfig' 'libcups' 'alsa-lib')
|
||||
_url_src=http://hg.openjdk.java.net/aarch64-port/jdk8u
|
||||
_url_src=http://hg.openjdk.java.net/aarch64-port/jdk8u-shenandoah
|
||||
source=(jdk8u-${_repo_ver}.tar.gz::${_url_src}/archive/${_repo_ver}.tar.gz
|
||||
corba-${_repo_ver}.tar.gz::${_url_src}/corba/archive/${_repo_ver}.tar.gz
|
||||
hotspot-${_repo_ver}.tar.gz::${_url_src}/hotspot/archive/${_repo_ver}.tar.gz
|
||||
|
@ -41,27 +34,31 @@ source=(jdk8u-${_repo_ver}.tar.gz::${_url_src}/archive/${_repo_ver}.tar.gz
|
|||
jaxws-${_repo_ver}.tar.gz::${_url_src}/jaxws/archive/${_repo_ver}.tar.gz
|
||||
jaxp-${_repo_ver}.tar.gz::${_url_src}/jaxp/archive/${_repo_ver}.tar.gz
|
||||
langtools-${_repo_ver}.tar.gz::${_url_src}/langtools/archive/${_repo_ver}.tar.gz
|
||||
nashorn-${_repo_ver}.tar.gz::${_url_src}/nashorn/archive/${_repo_ver}.tar.gz)
|
||||
nashorn-${_repo_ver}.tar.gz::${_url_src}/nashorn/archive/${_repo_ver}.tar.gz
|
||||
8143245-pr3548.patch
|
||||
8197981-pr3548.patch)
|
||||
|
||||
sha256sums=('ab7f0135ddcdc357d9794a7b960b303abe895f828f4a3eb5fa6ed03277349aae'
|
||||
'a21919e07fa8047fab6135ce21a54a96b5958591fd520d3c9dfc7440ac264fda'
|
||||
'c5a544fc5743da233cbb5914c95ebec027de98a862144f5ee3707816bdeb3782'
|
||||
'd4aee5d56e4f093d3b438ccb5c4e5ff759b7b2f3e4b2375f6deaae64bd74573b'
|
||||
'0f2fee40e1fb23447deb9912a86f6e419c23a45a928d1851d3d3e4009143b1db'
|
||||
'dfc6f3ef3d60d96cabdb7837d5eea70f8c9f44f5d618a656797b65a43227b6df'
|
||||
'2838beb4aa4d4ec6151fa33191f000e16f1c738669576686b7fa62c9b477421d'
|
||||
'90a9593f0397b55544cf6599db88df9e51ef9897322bc429adadaae250160652')
|
||||
sha256sums=('20c173c179bb55daa90cdf413289ed3e98d0ba0a747d9406afb0337c8cc8f562'
|
||||
'6fc31c6b039635335174254cbfd2508aec407496a41b65016840906d4cd900a2'
|
||||
'3116ff4e5b6e807390df964dc81868af38bc44d3041e3829366d2b8a25ccf052'
|
||||
'002bf4ce86e5c57648a5d1b344478fb844d5d2aba4cd6fed30022a24673ebe77'
|
||||
'252be3feb058dfb3f7cf5090d18cc237a5ba6ea3846ea2cb53859797a8a8582a'
|
||||
'61204d558dc41d597d333653e40eb08937db131732b5f4fb5205a8bfbb81f20f'
|
||||
'44b8767c3edc954c43a52b256e4b94fe1f1b2e02e0161607f576f7fa268910e6'
|
||||
'b766bb024bb4f72e8e0ba7f0230c43cf6b172ae801b1a4b69ebd5962044f0059'
|
||||
'305c779ab087853a0eba3532355225be52a779c38b5652fc7485794533d8cf8d'
|
||||
'c0bb1ae19f08c221156df15d7d8c5a4168c55179a186f3054dd4ac0591ec8501')
|
||||
|
||||
case "${CARCH}" in
|
||||
'x86_64') _JARCH=amd64 ; _DOC_ARCH=x86_64 ;;
|
||||
'i686' ) _JARCH=i386 ; _DOC_ARCH=x86 ;;
|
||||
arm* ) _JARCH=arm ; _DOC_ARCH=arm ;;
|
||||
'x86_64') _JARCH=amd64 ; _DOC_ARCH=x86_64 ;;
|
||||
'i686' ) _JARCH=i386 ; _DOC_ARCH=x86 ;;
|
||||
arm* ) _JARCH=arm ; _DOC_ARCH=arm ;;
|
||||
aarch64 ) _JARCH=aarch64 ; _DOC_ARCH=aarch64 ;;
|
||||
esac
|
||||
|
||||
_jdkname=openjdk8
|
||||
_jvmdir=/usr/lib/jvm/java-8-openjdk
|
||||
_prefix="jdk8u-${_repo_ver}/image"
|
||||
_prefix="jdk8u-${_jdk8u_repo_ver}/image"
|
||||
_imgdir="${_prefix}/jvm/openjdk-1.8.0_$(printf '%.2d' ${_jdk_update})"
|
||||
_nonheadless=(bin/policytool
|
||||
lib/${_JARCH}/libjsound.so
|
||||
|
@ -69,25 +66,27 @@ _nonheadless=(bin/policytool
|
|||
lib/${_JARCH}/libsplashscreen.so)
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/jdk8u-${_repo_ver}"
|
||||
|
||||
for subrepo in corba hotspot jdk jaxws jaxp langtools nashorn
|
||||
do
|
||||
cd jdk8u-${_jdk8u_repo_ver}
|
||||
for subrepo in corba hotspot jdk jaxws jaxp langtools nashorn; do
|
||||
ln -s ../${subrepo}-${_repo_ver} ${subrepo}
|
||||
done
|
||||
|
||||
# Fix zero with up to date GCC and glibc
|
||||
cd ../hotspot-${_repo_ver}
|
||||
patch -p2 -i ../8143245-pr3548.patch
|
||||
patch -p2 -i ../8197981-pr3548.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/jdk8u-${_repo_ver}"
|
||||
cd jdk8u-${_jdk8u_repo_ver}
|
||||
|
||||
unset JAVA_HOME
|
||||
# http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=1346
|
||||
export MAKEFLAGS=${MAKEFLAGS/-j*}
|
||||
# https://hydra.nixos.org/build/41230444/log
|
||||
export CFLAGS+=" -Wno-error=deprecated-declarations -fno-lifetime-dse -fno-delete-null-pointer-checks"
|
||||
|
||||
# prevent downgrading hotspot optimization
|
||||
CFLAGS=`echo $CFLAGS | sed -e 's/-O2//'` && CXXFLAGS="$CFLAGS"
|
||||
# Avoid optimization of HotSpot being lowered from O3 to O2
|
||||
export CFLAGS="${CFLAGS//-O2/-O3} ${CPPFLAGS} -Wno-error=deprecated-declarations -Wno-error=stringop-overflow= -Wno-error=return-type -Wno-error=cpp -fno-lifetime-dse -fno-delete-null-pointer-checks"
|
||||
export CXXFLAGS="${CXXFLAGS} ${CPPFLAGS}"
|
||||
|
||||
install -d -m 755 "${srcdir}/${_prefix}/"
|
||||
sh configure \
|
||||
|
@ -97,24 +96,23 @@ build() {
|
|||
--with-milestone="fcs" \
|
||||
--enable-unlimited-crypto \
|
||||
--with-zlib=system \
|
||||
--with-jvm-variants=zero
|
||||
--with-jvm-variants=zero \
|
||||
--with-extra-cflags="${CFLAGS}" \
|
||||
--with-extra-cxxflags="${CXXFLAGS}" \
|
||||
--with-extra-ldflags="${LDFLAGS}"
|
||||
|
||||
# TODO OpenJDK does not want last version of giflib (add 'giflib' as dependency once fixed)
|
||||
#--with-giflib=system \
|
||||
|
||||
# Without 'DEBUG_BINARIES', i686 won't build
|
||||
# http://mail.openjdk.java.net/pipermail/core-libs-dev/2013-July/019203.html
|
||||
make \
|
||||
DEBUG_BINARIES=true
|
||||
# These help to debug builds:
|
||||
#LOG=trace HOTSPOT_BUILD_JOBS=1
|
||||
# TODO OpenJDK does not want last version of giflib (add 'giflib' as dependency once fixed)
|
||||
#--with-giflib=system \
|
||||
|
||||
# These help to debug builds: LOG=trace HOTSPOT_BUILD_JOBS=1
|
||||
# Without 'DEBUG_BINARIES', i686 won't build: http://mail.openjdk.java.net/pipermail/core-libs-dev/2013-July/019203.html
|
||||
make DEBUG_BINARIES=true
|
||||
#make docs
|
||||
|
||||
# FIXME sadly 'DESTDIR' is not used here!
|
||||
make install
|
||||
|
||||
cd "${srcdir}/${_imgdir}"
|
||||
cd ../${_imgdir}
|
||||
|
||||
# A lot of build stuff were directly taken from
|
||||
# http://pkgs.fedoraproject.org/cgit/java-1.8.0-openjdk.git/tree/java-1.8.0-openjdk.spec
|
||||
|
@ -128,10 +126,10 @@ build() {
|
|||
find . -iname '*.debuginfo' -exec rm {} \;
|
||||
}
|
||||
|
||||
#check() {
|
||||
# cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
# make -k check
|
||||
#}
|
||||
check() {
|
||||
cd jdk8u-${_jdk8u_repo_ver}
|
||||
#make -k test
|
||||
}
|
||||
|
||||
package_jre8-openjdk-headless() {
|
||||
pkgdesc='OpenJDK Java 8 headless runtime environment'
|
||||
|
@ -159,7 +157,7 @@ package_jre8-openjdk-headless() {
|
|||
backup=(${_backup_etc[@]})
|
||||
install=install_jre8-openjdk-headless.sh
|
||||
|
||||
cd "${srcdir}/${_imgdir}/jre"
|
||||
cd ${_imgdir}/jre
|
||||
|
||||
install -d -m 755 "${pkgdir}${_jvmdir}/jre/"
|
||||
cp -a bin lib "${pkgdir}${_jvmdir}/jre"
|
||||
|
@ -169,7 +167,7 @@ package_jre8-openjdk-headless() {
|
|||
mv "${pkgdir}${_jvmdir}"/jre/lib/management/snmp.acl{.template,}
|
||||
|
||||
# Remove 'non-headless' lib files
|
||||
for f in ${_nonheadless[@]}; do
|
||||
for f in "${_nonheadless[@]}"; do
|
||||
rm "${pkgdir}${_jvmdir}/jre/${f}"
|
||||
done
|
||||
|
||||
|
@ -177,10 +175,14 @@ package_jre8-openjdk-headless() {
|
|||
pushd "${pkgdir}${_jvmdir}/jre/bin"
|
||||
install -d -m 755 "${pkgdir}"/usr/share/man/{,ja/}man1/
|
||||
for file in *; do
|
||||
install -m 644 "${srcdir}/${_imgdir}/man/man1/${file}.1" \
|
||||
"${pkgdir}/usr/share/man/man1/${file}-${_jdkname}.1"
|
||||
install -m 644 "${srcdir}/${_imgdir}/man/ja/man1/${file}.1" \
|
||||
"${pkgdir}/usr/share/man/ja/man1/${file}-${_jdkname}.1"
|
||||
if [ -f "${srcdir}/${_imgdir}/man/man1/${file}.1" ]; then
|
||||
install -m 644 "${srcdir}/${_imgdir}/man/man1/${file}.1" \
|
||||
"${pkgdir}/usr/share/man/man1/${file}-${_jdkname}.1"
|
||||
fi
|
||||
if [ -f "${srcdir}/${_imgdir}/man/ja/man1/${file}.1" ]; then
|
||||
install -m 644 "${srcdir}/${_imgdir}/man/ja/man1/${file}.1" \
|
||||
"${pkgdir}/usr/share/man/ja/man1/${file}-${_jdkname}.1"
|
||||
fi
|
||||
done
|
||||
popd
|
||||
|
||||
|
@ -195,7 +197,7 @@ package_jre8-openjdk-headless() {
|
|||
ln -sf /usr/share/licenses/${pkgbase} "${pkgdir}/usr/share/licenses/${pkgname}"
|
||||
|
||||
# Move config files that were set in _backup_etc from ./lib to /etc
|
||||
for file in ${_backup_etc[@]}; do
|
||||
for file in "${_backup_etc[@]}"; do
|
||||
_filepkgpath=${_jvmdir}/jre/lib/${file#etc/java-8-openjdk/}
|
||||
install -D -m 644 "${pkgdir}${_filepkgpath}" "${pkgdir}/${file}"
|
||||
ln -sf /${file} "${pkgdir}${_filepkgpath}"
|
||||
|
@ -208,17 +210,14 @@ package_jre8-openjdk() {
|
|||
optdepends=('icedtea-web: web browser plugin + Java Web Start'
|
||||
'alsa-lib: for basic sound support'
|
||||
'gtk2: for the Gtk+ look and feel - desktop usage'
|
||||
'java-openjfx: for JavaFX GUI components support')
|
||||
# TODO when adding IcedTea: 'giflib: for gif format support'
|
||||
# TODO when adding IcedTea: 'libpulse: for advanced sound support'
|
||||
'java8-openjfx: for JavaFX GUI components support')
|
||||
provides=('java-runtime=8' 'java-runtime-openjdk=8')
|
||||
install=install_jre8-openjdk.sh
|
||||
replaces=('jre8-openjdk-wm')
|
||||
|
||||
cd "${srcdir}/${_imgdir}/jre"
|
||||
cd ${_imgdir}/jre
|
||||
|
||||
# TODO? Should /usr/lib/jvm/java-8-openjdk/jre/lib/sound.properties belong to jre?
|
||||
for f in ${_nonheadless[@]}; do
|
||||
for f in "${_nonheadless[@]}"; do
|
||||
install -D ${f} "${pkgdir}${_jvmdir}/jre/${f}"
|
||||
done
|
||||
|
||||
|
@ -233,11 +232,6 @@ package_jre8-openjdk() {
|
|||
done
|
||||
popd
|
||||
|
||||
# Desktop files
|
||||
# TODO add these when switching to IcedTea
|
||||
#install -D -m 644 "${srcdir}/icedtea-${_icedtea_ver}/policytool.desktop" \
|
||||
# "${pkgdir}/usr/share/applications/policytool.desktop"
|
||||
|
||||
# Install license
|
||||
install -d -m 755 "${pkgdir}/usr/share/licenses/${pkgbase}/"
|
||||
ln -sf /usr/share/licenses/${pkgbase} "${pkgdir}/usr/share/licenses/${pkgname}"
|
||||
|
@ -250,7 +244,7 @@ package_jdk8-openjdk() {
|
|||
replaces=('jdk8-openjdk-wm')
|
||||
install=install_jdk8-openjdk.sh
|
||||
|
||||
cd "${srcdir}/${_imgdir}"
|
||||
cd ${_imgdir}
|
||||
|
||||
# Main files
|
||||
install -d -m 755 "${pkgdir}${_jvmdir}"
|
||||
|
@ -269,8 +263,12 @@ package_jdk8-openjdk() {
|
|||
# Copy binary to jdk/bin/
|
||||
install -D -m 755 ${b} "${pkgdir}${_jvmdir}/bin/${b}"
|
||||
# Copy man page
|
||||
install -D -m 644 ../man/man1/${b}.1 "${pkgdir}/usr/share/man/man1/${b}-${_jdkname}.1"
|
||||
install -D -m 644 ../man/ja/man1/${b}.1 "${pkgdir}/usr/share/man/ja/man1/${b}-${_jdkname}.1"
|
||||
if [ -f ../man/man1/${b}.1 ]; then
|
||||
install -D -m 644 ../man/man1/${b}.1 "${pkgdir}/usr/share/man/man1/${b}-${_jdkname}.1"
|
||||
fi
|
||||
if [ -f ../man/ja/man1/${b}.1 ]; then
|
||||
install -D -m 644 ../man/ja/man1/${b}.1 "${pkgdir}/usr/share/man/ja/man1/${b}-${_jdkname}.1"
|
||||
fi
|
||||
fi
|
||||
done
|
||||
popd
|
||||
|
@ -278,11 +276,6 @@ package_jdk8-openjdk() {
|
|||
# Handling 'java-rmi.cgi' separately
|
||||
install -D -m 755 bin/java-rmi.cgi "${pkgdir}${_jvmdir}/bin/java-rmi.cgi"
|
||||
|
||||
# Desktop files.
|
||||
# TODO add these when switching to IcedTea
|
||||
#install -m 644 "${srcdir}/icedtea-${_icedtea_ver}/jconsole.desktop" \
|
||||
# "${pkgdir}/usr/share/applications"
|
||||
|
||||
# link license
|
||||
install -d -m 755 "${pkgdir}/usr/share/licenses/"
|
||||
ln -sf /usr/share/licenses/${pkgbase} "${pkgdir}/usr/share/licenses/${pkgname}"
|
||||
|
@ -293,3 +286,5 @@ package_openjdk8-src() {
|
|||
|
||||
install -D "${srcdir}/${_imgdir}/src.zip" "${pkgdir}${_jvmdir}/src.zip"
|
||||
}
|
||||
|
||||
# vim: ts=2 sw=2 et:
|
||||
|
|
|
@ -25,7 +25,7 @@ post_install() {
|
|||
esac
|
||||
|
||||
if [ ! -f /etc/ssl/certs/java/cacerts ]; then
|
||||
/usr/bin/update-ca-trust
|
||||
/usr/bin/update-ca-trust
|
||||
fi
|
||||
}
|
||||
|
||||
|
|
|
@ -24,21 +24,14 @@ post_install() {
|
|||
;;
|
||||
esac
|
||||
|
||||
xdg-icon-resource forceupdate --theme hicolor 2> /dev/null
|
||||
echo "when you use a non-reparenting window manager,"
|
||||
echo "set _JAVA_AWT_WM_NONREPARENTING=1 in /etc/profile.d/jre.sh"
|
||||
|
||||
# update-desktop-database -q
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
if [ -z $(fix_default) ]; then
|
||||
if [ -z "$(fix_default)" ]; then
|
||||
/usr/bin/archlinux-java set ${THIS_JRE}
|
||||
fi
|
||||
|
||||
xdg-icon-resource forceupdate --theme hicolor 2> /dev/null
|
||||
|
||||
# update-desktop-database -q
|
||||
}
|
||||
|
||||
pre_remove() {
|
||||
|
@ -47,9 +40,3 @@ pre_remove() {
|
|||
echo "No Java environment is set as default anymore"
|
||||
fi
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
xdg-icon-resource forceupdate --theme hicolor 2> /dev/null
|
||||
|
||||
# update-desktop-database -q
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue