mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/qemu to 4.0.0-2
This commit is contained in:
parent
35eaa52549
commit
a14787efe6
2 changed files with 7 additions and 36 deletions
|
@ -11,24 +11,22 @@ pkgbase=qemu
|
|||
pkgname=(qemu qemu-headless qemu-arch-extra qemu-headless-arch-extra
|
||||
qemu-block-{iscsi,rbd,gluster} qemu-guest-agent)
|
||||
pkgdesc="A generic and open source machine emulator and virtualizer"
|
||||
pkgver=3.1.0
|
||||
pkgver=4.0.0
|
||||
pkgrel=2
|
||||
arch=(x86_64)
|
||||
license=(GPL2 LGPL2.1)
|
||||
url="http://wiki.qemu.org/"
|
||||
url="https://wiki.qemu.org/"
|
||||
_headlessdeps=(gnutls libpng libaio jemalloc xfsprogs libnfs
|
||||
lzo snappy curl vde2 libcap-ng spice libcacard usbredir)
|
||||
depends=(virglrenderer sdl2 vte3 libpulse "${_headlessdeps[@]}")
|
||||
makedepends=(spice-protocol python2 ceph libiscsi glusterfs)
|
||||
makedepends=(spice-protocol python2 ceph libiscsi glusterfs python-sphinx)
|
||||
source=(https://download.qemu.org/qemu-$pkgver.tar.xz{,.sig}
|
||||
qemu-ga.service
|
||||
65-kvm.rules
|
||||
allow_elf64.patch)
|
||||
sha512sums=('7e8dae823937cfac2f0c60406bd3bdcb89df40313dab2a4bed327d5198f7fcc68ac8b31e44692caa09299cc71256ee0b8c17e4f49f78ada8043d424f5daf82fe'
|
||||
65-kvm.rules)
|
||||
sha512sums=('952e94194ce9e64c15388c59035cb31fb9f761d30095c2fb9441012b609c18c9976285727b93bf37b95e15675802d73f8e1c4619ebecd23606675bb503646b13'
|
||||
'SKIP'
|
||||
'269c0f0bacbd06a3d817fde02dce26c99d9f55c9e3b74bb710bd7e5cdde7a66b904d2eb794c8a605bf9305e4e3dee261a6e7d4ec9d9134144754914039f176e4'
|
||||
'bdf05f99407491e27a03aaf845b7cc8acfa2e0e59968236f10ffc905e5e3d5e8569df496fd71c887da2b5b8d1902494520c7da2d3a8258f7fd93a881dd610c99'
|
||||
'b450625ff1e705f8c7eed9e2c0c4fe2179ca061df88a1a777c861c11d543c151cd0160f7f7227babdfe8b36000de084cbcb6fd7bf0f93d2f936c2e65082c82bf')
|
||||
'bdf05f99407491e27a03aaf845b7cc8acfa2e0e59968236f10ffc905e5e3d5e8569df496fd71c887da2b5b8d1902494520c7da2d3a8258f7fd93a881dd610c99')
|
||||
validpgpkeys=('CEACC9E15534EBABB82D3FA03353C9CEF108B584')
|
||||
|
||||
case $CARCH in
|
||||
|
@ -44,8 +42,6 @@ prepare() {
|
|||
|
||||
cd ${pkgname}-${pkgver}
|
||||
sed -i 's/vte-2\.90/vte-2.91/g' configure
|
||||
|
||||
patch -p1 < ../allow_elf64.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -78,8 +74,8 @@ _build() (
|
|||
--libexecdir=/usr/lib/qemu \
|
||||
--python=/usr/bin/python2 \
|
||||
--smbd=/usr/bin/smbd \
|
||||
--with-sdlabi=2.0 \
|
||||
--enable-modules \
|
||||
--enable-sdl \
|
||||
--enable-jemalloc \
|
||||
"${@:2}"
|
||||
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
commit cb61bc8a42da1a971079767e63df4503b6ab2efb
|
||||
Author: Anatol Pomozov <anatol.pomozov@gmail.com>
|
||||
Date: Mon Jan 29 10:08:53 2018 -0800
|
||||
|
||||
multiboot: Make elf64 loading functionality compatible with GRUB
|
||||
|
||||
GRUB is a reference multiboot implementation and supports loading elf64
|
||||
binaries. Make QEMU to work similar was as GRUB.
|
||||
|
||||
diff --git a/hw/i386/multiboot.c b/hw/i386/multiboot.c
|
||||
index 5bc0a2cddb..0907e42a39 100644
|
||||
--- a/hw/i386/multiboot.c
|
||||
+++ b/hw/i386/multiboot.c
|
||||
@@ -193,11 +193,6 @@ int load_multiboot(FWCfgState *fw_cfg,
|
||||
int kernel_size;
|
||||
fclose(f);
|
||||
|
||||
- if (((struct elf64_hdr*)header)->e_machine == EM_X86_64) {
|
||||
- error_report("Cannot load x86-64 image, give a 32bit one.");
|
||||
- exit(1);
|
||||
- }
|
||||
-
|
||||
kernel_size = load_elf(kernel_filename, NULL, NULL, &elf_entry,
|
||||
&elf_low, &elf_high, 0, I386_ELF_MACHINE,
|
||||
0, 0);
|
Loading…
Reference in a new issue