mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
community/openimageio: remove arm.patch
This commit is contained in:
parent
67becb4c64
commit
a177a33212
2 changed files with 2 additions and 36 deletions
|
@ -4,7 +4,6 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - removed intel-tbb from deps, set -DUSE_TBB=0
|
||||
# - patch to block out x86 asm (https://github.com/OpenImageIO/oiio/pull/546)
|
||||
|
||||
pkgname=openimageio
|
||||
pkgver=1.2.1
|
||||
|
@ -17,16 +16,12 @@ depends=('openexr' 'boost-libs' 'jasper' 'glew' 'libtiff' 'opencolorio')
|
|||
makedepends=('cmake' 'qt4' 'python2' 'boost' 'mesa')
|
||||
optdepends=('qt4: iv image viewer'
|
||||
'python2: bindings support')
|
||||
source=(https://github.com/OpenImageIO/oiio/tarball/Release-$pkgver
|
||||
arm.patch)
|
||||
md5sums=('c98d002c9ec843b7cc35d7aec5f03326'
|
||||
'd3a81f05892a747e922aed541059aade')
|
||||
source=(https://github.com/OpenImageIO/oiio/tarball/Release-$pkgver)
|
||||
md5sums=('c98d002c9ec843b7cc35d7aec5f03326')
|
||||
|
||||
build() {
|
||||
cd "$srcdir"/$_pkgname*
|
||||
|
||||
patch -p1 -i "$srcdir"/arm.patch
|
||||
|
||||
cd src
|
||||
|
||||
[[ -d build ]] && rm -r build
|
||||
|
|
|
@ -1,29 +0,0 @@
|
|||
diff -urN a/src/include/thread.h b/src/include/thread.h
|
||||
--- a/src/include/thread.h 2013-07-08 13:47:25.000000000 -0600
|
||||
+++ b/src/include/thread.h 2013-07-13 14:30:25.709073357 -0600
|
||||
@@ -323,8 +323,12 @@
|
||||
#if defined __arm__ || defined __s390__
|
||||
__asm__ __volatile__("NOP;");
|
||||
#else
|
||||
+#if defined __arm__
|
||||
+ __asm__ __volatile__("NOP;");
|
||||
+#else
|
||||
__asm__ __volatile__("pause;");
|
||||
#endif
|
||||
+#endif
|
||||
}
|
||||
#elif USE_TBB
|
||||
__TBB_Pause(delay);
|
||||
@@ -447,7 +451,12 @@
|
||||
|
||||
// Disallow copy construction by making private and unimplemented.
|
||||
atomic (atomic const &);
|
||||
+
|
||||
+#if defined __arm__
|
||||
+} __attribute__((aligned(8)));
|
||||
+#else
|
||||
};
|
||||
+#endif
|
||||
|
||||
|
||||
#endif /* ! USE_TBB_ATOMIC */
|
Loading…
Reference in a new issue