extra/chromium to 92.0.4515.131-1

This commit is contained in:
Kevin Mihelich 2021-08-03 12:31:06 +00:00
parent cb11c19d27
commit a195fd0a53
2 changed files with 5 additions and 57 deletions

View file

@ -16,9 +16,9 @@ buildarch=12
highmem=1
pkgname=chromium
pkgver=92.0.4515.107
pkgrel=3
_launcher_ver=7
pkgver=92.0.4515.131
pkgrel=1
_launcher_ver=8
_gcc_patchset=7
pkgdesc="A web browser built for speed, simplicity, and security"
arch=('x86_64')
@ -39,19 +39,17 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
extend-enable-accelerated-video-decode-flag.patch
linux-sandbox-syscall-broker-use-struct-kernel_stat.patch
linux-sandbox-fix-fstatat-crash.patch
make-GetUsableSize-handle-nullptr-gracefully.patch
sql-make-VirtualCursor-standard-layout-type.patch
use-oauth2-client-switches-as-default.patch
0001-widevine-support-for-arm.patch
0002-Run-blink-bindings-generation-single-threaded.patch
0003-Fix-eu-strip-build-for-newer-GCC.patch)
sha256sums=('6e51ac6512a4e95018eefc9fef1d2e7597f28a1c45c763b3a8eb7dde5f557012'
'86859c11cfc8ba106a3826479c0bc759324a62150b271dd35d1a0f96e890f52f'
sha256sums=('b6ac840ed5390de69f962e922649bf1df895ff0f5db8e5f656b5191e0cf4ce3a'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
'53a2cbb1b58d652d5424ff9040b6a51b9dc6348ce3edc68344cd0d25f1f4beb2'
'66db9132d6f5e06aa26e5de0924f814224a76a9bdf4b61afce161fb1d7643b22'
'268e18ad56e5970157b51ec9fc8eb58ba93e313ea1e49c842a1ed0820d9c1fa3'
'253348550d54b8ae317fd250f772f506d2bae49fb5dc75fe15d872ea3d0e04a5'
'4489e5e7854a7dcd9464133eb4664250ce7149ac1714a0bf10ca0d82d8806568'
'dd317f85e5abfdcfc89c6f23f4c8edbcdebdd5e083dcec770e5da49ee647d150'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711'
'1e6675897762250dd96054d13e35939e7d9e93a812c909ba95966c86d5a3a284'
@ -126,7 +124,6 @@ prepare() {
patch -Np1 -i ../extend-enable-accelerated-video-decode-flag.patch
patch -Np1 -i ../linux-sandbox-syscall-broker-use-struct-kernel_stat.patch
patch -Np1 -i ../linux-sandbox-fix-fstatat-crash.patch
patch -Np1 -i ../make-GetUsableSize-handle-nullptr-gracefully.patch
# https://chromium-review.googlesource.com/c/chromium/src/+/2862724
patch -Np1 -i ../sql-make-VirtualCursor-standard-layout-type.patch

View file

@ -1,49 +0,0 @@
From 61e16c92ff24bb71b9b7309a9d6d470ee91738bc Mon Sep 17 00:00:00 2001
From: Bartek Nowierski <bartekn@chromium.org>
Date: Wed, 21 Jul 2021 15:01:38 +0000
Subject: [PATCH] [PA] Make GetUsableSize() handle nullptr gracefully
malloc_usable_size() is expected to not crush on NULL and return 0.
Bug: 1221442
Change-Id: I6a3b90dcf3a8ad18114c206d87b98f60d5f50eb1
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/3042177
Commit-Queue: Bartek Nowierski <bartekn@chromium.org>
Commit-Queue: Kentaro Hara <haraken@chromium.org>
Auto-Submit: Bartek Nowierski <bartekn@chromium.org>
Reviewed-by: Kentaro Hara <haraken@chromium.org>
Cr-Commit-Position: refs/heads/master@{#903900}
---
.../allocator/partition_allocator/partition_alloc_unittest.cc | 4 ++++
base/allocator/partition_allocator/partition_root.h | 3 +++
2 files changed, 7 insertions(+)
diff --git a/base/allocator/partition_allocator/partition_alloc_unittest.cc b/base/allocator/partition_allocator/partition_alloc_unittest.cc
index c12120114aa7..8863984cd805 100644
--- a/base/allocator/partition_allocator/partition_alloc_unittest.cc
+++ b/base/allocator/partition_allocator/partition_alloc_unittest.cc
@@ -2838,6 +2838,10 @@ TEST_F(PartitionAllocTest, OptimizedGetSlotNumber) {
}
}
+TEST_F(PartitionAllocTest, GetUsableSizeNull) {
+ EXPECT_EQ(0ULL, PartitionRoot<ThreadSafe>::GetUsableSize(nullptr));
+}
+
TEST_F(PartitionAllocTest, GetUsableSize) {
size_t delta = SystemPageSize() + 1;
for (size_t size = 1; size <= kMinDirectMappedDownsize; size += delta) {
diff --git a/base/allocator/partition_allocator/partition_root.h b/base/allocator/partition_allocator/partition_root.h
index b72a1d94a4e4..baac952597d1 100644
--- a/base/allocator/partition_allocator/partition_root.h
+++ b/base/allocator/partition_allocator/partition_root.h
@@ -1220,6 +1220,9 @@ ALWAYS_INLINE bool PartitionRoot<thread_safe>::TryRecommitSystemPagesForData(
// PartitionAlloc's internal data. Used as malloc_usable_size.
template <bool thread_safe>
ALWAYS_INLINE size_t PartitionRoot<thread_safe>::GetUsableSize(void* ptr) {
+ // malloc_usable_size() is expected to handle NULL gracefully and return 0.
+ if (!ptr)
+ return 0;
auto* slot_span = SlotSpan::FromSlotInnerPtr(ptr);
auto* root = FromSlotSpan(slot_span);
return slot_span->GetUsableSize(root);