extra/boost: add patch

This commit is contained in:
Kevin Mihelich 2013-08-18 17:16:13 +00:00
parent 72236ac048
commit a1a2404106

View file

@ -0,0 +1,14 @@
Index: /trunk/boost/cstdint.hpp
===================================================================
--- /trunk/boost/cstdint.hpp (revision 84805)
+++ /trunk/boost/cstdint.hpp (revision 84950)
@@ -42,5 +42,8 @@
// See https://svn.boost.org/trac/boost/ticket/3548 and http://sources.redhat.com/bugzilla/show_bug.cgi?id=10990
//
-#if defined(BOOST_HAS_STDINT_H) && (!defined(__GLIBC__) || defined(__GLIBC_HAVE_LONG_LONG))
+#if defined(BOOST_HAS_STDINT_H) \
+ && (!defined(__GLIBC__) \
+ || defined(__GLIBC_HAVE_LONG_LONG) \
+ || (defined(__GLIBC__) && ((__GLIBC__ > 2) || ((__GLIBC__ == 2) && (__GLIBC_MINOR__ >= 17)))))
// The following #include is an implementation artifact; not part of interface.