extra/webkitgtk to 2.4.3-2

This commit is contained in:
Kevin Mihelich 2014-07-04 19:46:13 +00:00
parent 0865492f30
commit a1a607c38a
2 changed files with 19 additions and 3 deletions

View file

@ -8,7 +8,7 @@
pkgbase=webkitgtk
pkgname=(webkitgtk webkitgtk2)
pkgver=2.4.3
pkgrel=1
pkgrel=2
pkgdesc="GTK+ Web content engine library"
arch=(i686 x86_64)
url="http://webkitgtk.org/"
@ -21,9 +21,11 @@ optdepends=('gst-plugins-base: free media decoding'
'gst-libav: nonfree media decoding')
options=(!emptydirs)
source=(http://webkitgtk.org/releases/$pkgbase-${pkgver}.tar.xz
fix-pretty-quotes.patch)
fix-pretty-quotes.patch
webkitgtk-2.4.3-angle_symbol_table.patch)
sha256sums=('9862c3eac1d12cc6e52cc39060a1284163950b304d534529a0dbcc5958a8ceac'
'56316228bbbf0b7ebcbe210a35120f4e72cb9c1b680dd82cc2bde0f4549245e6')
'56316228bbbf0b7ebcbe210a35120f4e72cb9c1b680dd82cc2bde0f4549245e6'
'a2c0b96a1671d43c18baf3cbe53c84738181aa08c3ac448c423b50722953a50b')
prepare() {
mkdir build-gtk{,2} path
@ -32,6 +34,7 @@ prepare() {
cd $pkgbase-$pkgver
patch -Np0 -i ../fix-pretty-quotes.patch
patch -Np1 -i ../webkitgtk-2.4.3-angle_symbol_table.patch
}
_build() (

View file

@ -0,0 +1,13 @@
--- a/Source/ThirdParty/ANGLE/src/compiler/SymbolTable.cpp
+++ b/Source/ThirdParty/ANGLE/src/compiler/SymbolTable.cpp
@@ -171,7 +171,8 @@ TFunction::~TFunction()
TSymbolTableLevel::~TSymbolTableLevel()
{
for (tLevel::iterator it = level.begin(); it != level.end(); ++it)
- delete (*it).second;
+ if ((*it).first == (*it).second->getMangledName())
+ delete (*it).second;
}
//