community/kitty to 0.19.0-1

This commit is contained in:
Kevin Mihelich 2020-10-05 01:11:29 +00:00
parent 473415cfa4
commit a1e4d6e8d2
2 changed files with 7 additions and 39 deletions

View file

@ -1,27 +0,0 @@
From 522b7543db3075eb5d6c1d4d3d65e0d2b516eda8 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 10 Jul 2018 12:50:51 -0600
Subject: [PATCH] remove lto
---
setup.py | 4 ----
1 file changed, 4 deletions(-)
diff --git a/setup.py b/setup.py
index 917d29e6..a9897a29 100755
--- a/setup.py
+++ b/setup.py
@@ -277,10 +277,6 @@ def init_env(
cppflags += shlex.split(os.environ.get('CPPFLAGS', ''))
cflags += shlex.split(os.environ.get('CFLAGS', ''))
ldflags += shlex.split(os.environ.get('LDFLAGS', ''))
- if not debug and not sanitize:
- # See https://github.com/google/sanitizers/issues/647
- cflags.append('-flto')
- ldflags.append('-flto')
if profile:
cppflags.append('-DWITH_PROFILER')
--
2.24.1

View file

@ -4,30 +4,25 @@
# Contributor: Maximilian Kindshofer <maximilian@kindshofer.net>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to remove lto from hardcoded cflags
# - run setup.py with --disable-link-time-optimization
pkgbase=kitty
pkgname=(kitty kitty-terminfo)
pkgver=0.18.3
pkgver=0.19.0
pkgrel=1
pkgdesc="A modern, hackable, featureful, OpenGL-based terminal emulator"
arch=('x86_64')
url="https://github.com/kovidgoyal/kitty"
license=('GPL3')
depends=('python3' 'freetype2' 'fontconfig' 'wayland' 'libx11' 'libxkbcommon-x11' 'libxi' 'hicolor-icon-theme' 'libgl' 'libcanberra' 'dbus')
depends=('python3' 'freetype2' 'fontconfig' 'wayland' 'libx11' 'libxkbcommon-x11' 'libxi'
'hicolor-icon-theme' 'libgl' 'libcanberra' 'dbus' 'lcms2')
makedepends=('libxinerama' 'libxcursor' 'libxrandr' 'wayland-protocols' 'python-sphinx')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/kovidgoyal/$pkgname/archive/v$pkgver.tar.gz"
'0001-remove-lto.patch')
sha512sums=('dee04572905f735ac098e8406ec3f36c2eb4d21ff0c6ff1b94216fab2b861c4d72a865b36cc18be1d9ed77235c33cc01a207e1992260da47679ff8b83f62f6e8'
'1c0290a42552cbe5b3bb120965bcd2dc20b9236dba43e43ff086adc14dc25417323bf9b750bf1cb06ecb65267d6d479f79daf14f64eac697c06a138fa7baa601')
prepare() {
patch -Np1 -i "$srcdir/0001-remove-lto.patch" -d "$srcdir/$pkgname-$pkgver"
}
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/kovidgoyal/$pkgname/archive/v$pkgver.tar.gz")
sha512sums=('1c75c9534aa27122d2bfd19f3e2b38d90da6e74e7c97a114b36436b4db6c6c6e254e57e1f26d656ab4501e20d91f8c14ca929bc1b01ecee14c5b6241afaf8d8f')
build() {
cd "$srcdir/$pkgname-$pkgver"
python3 setup.py linux-package --update-check-interval=0
python3 setup.py linux-package --update-check-interval=0 --disable-link-time-optimization
}
package_kitty() {