mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
removed community/scribus
This commit is contained in:
parent
2cfc30e2be
commit
a23cb0fc2a
2 changed files with 0 additions and 67 deletions
|
@ -1,55 +0,0 @@
|
|||
# $Id$
|
||||
# Maintainer: Gaetan Bisson <bisson@archlinux.org>
|
||||
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
|
||||
# Contributor: Ronald van Haren <ronald.archlinux.org>
|
||||
# Contributor: tobias <tobias@archlinux.org>
|
||||
# Contributor: Ben <ben@benmazer.net>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch for qreal on ARM
|
||||
|
||||
pkgname=scribus
|
||||
pkgver=1.4.7
|
||||
pkgrel=2
|
||||
pkgdesc='Desktop publishing software'
|
||||
url="http://www.scribus.net/"
|
||||
license=('GPL')
|
||||
arch=('x86_64')
|
||||
makedepends=('cmake' 'boost' 'mesa')
|
||||
depends=('qt4' 'cairo' 'lcms2' 'libcups' 'libxml2' 'hyphen'
|
||||
'ghostscript' 'python2' 'podofo' 'boost-libs'
|
||||
'desktop-file-utils' 'shared-mime-info')
|
||||
validpgpkeys=('5086B8D68E70FDDF4C40045AEF7B95E7F60166DA')
|
||||
source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.xz"{,.asc}
|
||||
'arm.patch')
|
||||
sha1sums=('fc679fc0a0bc3e2f6be9689ea00116b0f59ff785'
|
||||
'SKIP'
|
||||
'3a7b787f1b998d6af05d2f920dcecdc0b215cc26')
|
||||
|
||||
options=('!libtool')
|
||||
prepare() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
patch -p1 -i "${srcdir}"/arm.patch
|
||||
sed \
|
||||
-e 's|#!/usr/bin/python|#!/usr/bin/python2|' \
|
||||
-e 's|#!/usr/bin/env python|#!/usr/bin/env python2|' \
|
||||
-i scribus/plugins/scriptplugin/{samples,scripts}/*
|
||||
install -d build
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}/build"
|
||||
cmake .. \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DCMAKE_SKIP_RPATH=ON \
|
||||
-DLIB_SUFFIX=""
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}/build"
|
||||
make DESTDIR="${pkgdir}" install
|
||||
install -Dm644 ../scribus.desktop "${pkgdir}/usr/share/applications/scribus.desktop"
|
||||
install -Dm644 ../resources/icons/AppIcon.png "${pkgdir}/usr/share/icons/hicolor/32x32/apps/scribus.png"
|
||||
}
|
|
@ -1,12 +0,0 @@
|
|||
diff -urN a/scribus/scribus.cpp b/scribus/scribus.cpp
|
||||
--- a/scribus/scribus.cpp 2014-12-21 04:31:54.000000000 -0700
|
||||
+++ b/scribus/scribus.cpp 2015-01-31 01:03:34.411160428 -0700
|
||||
@@ -6704,7 +6704,7 @@
|
||||
if (mode == modeDrawShapes)
|
||||
{
|
||||
doc->SubMode = modeToolBar->SubMode;
|
||||
- doc->ShapeValues = modeToolBar->ShapeVals;
|
||||
+ doc->ShapeValues = (double*)modeToolBar->ShapeVals;
|
||||
doc->ValCount = modeToolBar->ValCount;
|
||||
propertiesPalette->SCustom->setIcon(propertiesPalette->SCustom->getIconPixmap(doc->SubMode));
|
||||
}
|
Loading…
Reference in a new issue