Merge remote-tracking branch 'upstream/master'

Conflicts:
	alarm/uboot-sunxi/PKGBUILD
This commit is contained in:
William Christensen 2014-06-09 16:04:06 -04:00
commit a24cd74adc
7 changed files with 185 additions and 85 deletions

View file

@ -7,7 +7,7 @@ pkgbase=uboot-sunxi
pkgname=('uboot-cubieboard2' 'uboot-cubietruck' 'uboot-iteaduino_plus_a10' 'uboot-iteaduino_plus_a20'
'uboot-hackberry')
pkgver=2014.04
pkgrel=2
pkgrel=3
arch=('armv7h')
url="https://github.com/linux-sunxi/u-boot-sunxi/tree/sunxi-current"
license=('GPL')
@ -24,7 +24,7 @@ source=("https://github.com/linux-sunxi/u-boot-sunxi/archive/${_commit}.tar.gz"
'a20-olinuxino_micro.fex' 'a20-olinuxino_micro.env')
md5sums=('8e4f2a2c1384f31eca5d3864b86e8351'
'9e9f1cb9c1b069b8ad9c0e522fb139aa'
'e1a60073a996b95f3e3f3fd07239e2e6'
'36c04988cecd53151f3f5ff5c48d76a9'
'd41d8cd98f00b204e9800998ecf8427e'
'c898ab1b57f474d620f5704b2a53d87c'
@ -38,7 +38,6 @@ md5sums=('8e4f2a2c1384f31eca5d3864b86e8351'
'2cac23939b761d1ea668faa2c68b3688'
'd41d8cd98f00b204e9800998ecf8427e' )
prepare() {
cd u-boot-sunxi-${_commit}
patch -p1 -i "${srcdir}"/alarm.patch
@ -55,7 +54,7 @@ build() {
mkdir ../bin_${i}
make distclean
make ${i}_config
make -j5
make
mv u-boot-sunxi-with-spl.bin ../bin_${i}
done
}

View file

@ -1,67 +1,6 @@
diff --git a/include/configs/sunxi-common.h b/include/configs/sunxi-common.h
index a0c41ac..e9a94f6 100644
--- a/include/configs/sunxi-common.h
+++ b/include/configs/sunxi-common.h
@@ -157,7 +157,7 @@
#define CONFIG_SYS_NO_FLASH
#define CONFIG_SYS_MONITOR_LEN (512 << 10) /* 512 KiB */
-#define CONFIG_IDENT_STRING " Allwinner Technology"
+#define CONFIG_IDENT_STRING " Arch Linux ARM"
#define CONFIG_ENV_OFFSET (544 << 10) /* (8 + 24 + 512) KiB */
#define CONFIG_ENV_SIZE (128 << 10) /* 128 KiB */
@@ -215,38 +215,28 @@
"bootscr=boot.scr\0" \
"script=script.bin\0" \
"loadbootscr=" \
- "fatload $device $partition $scriptaddr ${bootscr}" \
- " || " \
- "ext2load $device $partition $scriptaddr boot/${bootscr}" \
+ "load $device $partition $scriptaddr boot/${bootscr}" \
" ||" \
- "ext2load $device $partition $scriptaddr ${bootscr}" \
+ "load $device $partition $scriptaddr ${bootscr}" \
"\0" \
"loadbootenv=" \
- "fatload $device $partition $scriptaddr ${bootenv}" \
- " || " \
- "ext2load $device $partition $scriptaddr boot/${bootenv}" \
+ "load $device $partition $scriptaddr boot/${bootenv}" \
" || " \
- "ext2load $device $partition $scriptaddr ${bootenv}" \
+ "load $device $partition $scriptaddr ${bootenv}" \
"\0" \
"loadkernel=" \
"if "\
"bootpath=/boot/" \
" && " \
- "ext2load $device $partition 0x43000000 ${bootpath}${script}" \
- " && " \
- "ext2load $device $partition 0x48000000 ${bootpath}${kernel}" \
- ";then true; elif " \
- "bootpath=/" \
- " && " \
- "fatload $device $partition 0x43000000 ${script}" \
+ "load $device $partition 0x43000000 ${bootpath}${script}" \
" && " \
- "fatload $device $partition 0x48000000 ${kernel}" \
+ "load $device $partition 0x48000000 ${bootpath}${kernel}" \
";then true; elif " \
"bootpath=/" \
" && " \
- "ext2load $device $partition 0x43000000 ${bootpath}${script}" \
+ "load $device $partition 0x43000000 ${bootpath}${script}" \
" && " \
- "ext2load $device $partition 0x48000000 ${bootpath}${kernel}" \
+ "load $device $partition 0x48000000 ${bootpath}${kernel}" \
";then true; else "\
"false" \
";fi" \
diff --git a/include/config_distro_defaults.h b/include/config_distro_defaults.h
index 5d18a4b..11e655c 100644
--- a/include/config_distro_defaults.h
+++ b/include/config_distro_defaults.h
diff -urN a/include/config_distro_defaults.h b/include/config_distro_defaults.h
--- a/include/config_distro_defaults.h 2014-06-03 11:30:04.000000000 -0600
+++ b/include/config_distro_defaults.h 2014-06-08 19:19:11.970699422 -0600
@@ -45,7 +45,7 @@
#define CONFIG_CMDLINE_EDITING
@ -71,3 +10,166 @@ index 5d18a4b..11e655c 100644
#define CONFIG_SYS_LONGHELP
#define CONFIG_MENU
#define CONFIG_DOS_PARTITION
diff -urN a/include/configs/sunxi-common.h b/include/configs/sunxi-common.h
--- a/include/configs/sunxi-common.h 2014-06-03 11:30:04.000000000 -0600
+++ b/include/configs/sunxi-common.h 2014-06-08 20:29:05.034915060 -0600
@@ -126,7 +126,7 @@
#define CONFIG_SYS_NO_FLASH
#define CONFIG_SYS_MONITOR_LEN (512 << 10) /* 512 KiB */
-#define CONFIG_IDENT_STRING " Allwinner Technology"
+#define CONFIG_IDENT_STRING " Arch Linux ARM"
#define CONFIG_ENV_OFFSET (544 << 10) /* (8 + 24 + 512) KiB */
#define CONFIG_ENV_SIZE (128 << 10) /* 128 KiB */
@@ -137,23 +137,6 @@
#define RUN_BOOT_RAM ""
#endif
-#define CONFIG_BOOTCOMMAND \
- RUN_BOOT_RAM \
- "if run loadbootenv; then " \
- "echo Loaded environment from ${bootenv};" \
- "env import -t ${scriptaddr} ${filesize};" \
- "fi;" \
- "if test -n \\\"${uenvcmd}\\\"; then " \
- "echo Running uenvcmd ...;" \
- "run uenvcmd;" \
- "fi;" \
- "if run loadbootscr; then "\
- "echo Jumping to ${bootscr};" \
- "source ${scriptaddr};" \
- "fi;" \
- "run autoboot;" \
- ""
-
#ifdef CONFIG_CMD_WATCHDOG
#define RESET_WATCHDOG "watchdog 0"
#else
@@ -162,74 +145,27 @@
#define CONFIG_EXTRA_ENV_SETTINGS \
"bootm_size=0x10000000\0" \
- "console=ttyS0,115200\0" \
- "panicarg=panic=10\0" \
- "extraargs=\0" \
- "loglevel=8\0" \
- "scriptaddr=0x44000000\0" \
- "device=mmc\0" \
- "partition=0:1\0" \
- "setargs=" \
- "if test -z \\\\\"$root\\\\\"; then"\
- " if test \\\\\"$bootpath\\\\\" = \"/boot/\"; then"\
- " root=\"/dev/mmcblk0p1 rootwait\";"\
- " else" \
- " root=\"/dev/mmcblk0p2 rootwait\";"\
- " fi;"\
- " fi;"\
- " setenv bootargs console=${console} root=${root}" \
- " loglevel=${loglevel} ${panicarg} ${extraargs}" \
- "\0" \
- "kernel=uImage\0" \
- "bootenv=uEnv.txt\0" \
- "bootscr=boot.scr\0" \
- "script=script.bin\0" \
- "loadbootscr=" \
- "fatload $device $partition $scriptaddr ${bootscr}" \
- " || " \
- "ext2load $device $partition $scriptaddr boot/${bootscr}" \
- " ||" \
- "ext2load $device $partition $scriptaddr ${bootscr}" \
- "\0" \
- "loadbootenv=" \
- "fatload $device $partition $scriptaddr ${bootenv}" \
- " || " \
- "ext2load $device $partition $scriptaddr boot/${bootenv}" \
- " || " \
- "ext2load $device $partition $scriptaddr ${bootenv}" \
- "\0" \
- "loadkernel=" \
- "if "\
- "bootpath=/boot/" \
- " && " \
- "ext2load $device $partition 0x43000000 ${bootpath}${script}" \
- " && " \
- "ext2load $device $partition 0x48000000 ${bootpath}${kernel}" \
- ";then true; elif " \
- "bootpath=/" \
- " && " \
- "fatload $device $partition 0x43000000 ${script}" \
- " && " \
- "fatload $device $partition 0x48000000 ${kernel}" \
- ";then true; elif " \
- "bootpath=/" \
- " && " \
- "ext2load $device $partition 0x43000000 ${bootpath}${script}" \
- " && " \
- "ext2load $device $partition 0x48000000 ${bootpath}${kernel}" \
- ";then true; else "\
- "false" \
- ";fi" \
- "\0" \
- "autoboot=" \
- "run loadkernel" \
- " && " \
- "run setargs" \
- " && " \
- RESET_WATCHDOG \
- " && " \
- "bootm 0x48000000" \
- "\0" \
+ "console=ttyS0\0" \
+ "loadaddr=0x48000000\0" \
+ "scriptaddr=0x43000000\0" \
+ "optargs=\0" \
+ "video=\0" \
+ "mmcdev=0\0" \
+ "mmcpart=1\0" \
+ "mmcroot=/dev/mmcblk0p1 rw rootwait\0" \
+ "mmcargs=setenv bootargs console=${console},${baudrate} " \
+ "${optargs} " \
+ "root=${mmcroot} " \
+ "video=${video}\0" \
+ "loadbootenv=load mmc ${mmcdev}:${mmcpart} ${loadaddr} /boot/uEnv.txt\0" \
+ "importbootenv=echo Importing environment from mmc (uEnv.txt)...; " \
+ "env import -t $loadaddr $filesize\0" \
+ "loadscript=load mmc ${mmcdev}:${mmcpart} ${scriptaddr} /boot/script.bin\0" \
+ "loaduimage=load mmc ${mmcdev}:${mmcpart} ${loadaddr} /boot/uImage\0" \
+ "mmcbootm=echo Booting from mmc ...; " \
+ "run mmcargs; " \
+ RESET_WATCHDOG ";" \
+ "bootm ${loadaddr};\0" \
"boot_ram=" \
"saved_stdout=$stdout;setenv stdout nc;"\
"if iminfo 0x41000000; then" \
@@ -238,9 +174,27 @@
" source 0x41000000;" \
"else" \
" setenv stdout $saved_stdout;" \
- "fi" \
- "\0" \
- ""
+ "fi;\0"
+
+#define CONFIG_BOOTCOMMAND \
+ "run boot_ram;" \
+ "mmc dev ${mmcdev};" \
+ "if mmc rescan; then " \
+ "echo SD/MMC found on device ${mmcdev};" \
+ "if run loadbootenv; then " \
+ "run importbootenv;" \
+ "fi;" \
+ "echo Checking if uenvcmd is set ...;" \
+ "if test -n $uenvcmd; then " \
+ "echo Running uenvcmd ...;" \
+ "run uenvcmd;" \
+ "fi;" \
+ "echo Running default loaduimage ...;" \
+ "if run loaduimage; then " \
+ "run loadscript;" \
+ "run mmcbootm;" \
+ "fi;" \
+ "fi;"
#define CONFIG_SYS_BOOT_GET_CMDLINE

View file

@ -3,8 +3,8 @@
buildarch=16
pkgname=arm-mem-git
pkgver=10.8a1fbee
pkgrel=2
pkgver=11.2e6f275
pkgrel=1
pkgdesc="ARM-accelerated versions of selected functions from string.h"
arch=('armv6h')
url="https://github.com/bavison/arm-mem"

View file

@ -11,9 +11,9 @@
buildarch=2
pkgname=plexmediaserver
pkgver=0.9.9.7.429
pkgrel=2
_subver=f80a8d6
pkgver=0.9.9.10.458
pkgrel=1
_subver=008ea34
pkgdesc="Plex Media Server for Linux"
url='http://www.plexapp.com'
arch=('arm')
@ -27,10 +27,10 @@ source=("http://downloads.plexapp.com/plex-media-server/${pkgver}-${_subver}/Ple
"${pkgname}.service"
"start_pms")
md5sums=('68eaa3a1bcfe7285ff66d9d30941a444'
md5sums=('45c40719e74225364f336e1694215103'
'32cdd9f9de446f6646616a0077151726'
'6601ebe6607cfb7dda9f3d77c1d043a9'
'c4d158ae6f9a186e4553551d062febe3')
'6601ebe6607cfb7dda9f3d77c1d043a9'
'c4d158ae6f9a186e4553551d062febe3')
build() {
mkdir ${srcdir}/plex
cd ${srcdir}/plex

View file

@ -5,11 +5,11 @@
buildarch=18
pkgbase=linux-raspberrypi-latest
_commit=39a4966c3c068ad9157a66c77502365f849f32cc
_commit=d5ee4bc61b3bb513f12d153ed0c2c7eb24f2e5d4
_srcname=linux-${_commit}
_kernelname=${pkgbase#linux}
_desc="Raspberry Pi"
pkgver=3.14.5
pkgver=3.14.6
pkgrel=1
bfqver=v7r4
@ -31,7 +31,7 @@ source=("https://github.com/raspberrypi/linux/archive/${_commit}.tar.gz"
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${pkgver:0:4}.0-${bfqver}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-${pkgver:0:4}.patch"
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${pkgver:0:4}.0-${bfqver}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for-${pkgver:0:4}.0.patch")
md5sums=('b9aad328e98201c89726f5d6f9a3deae'
md5sums=('d941dc0ec8c872e5f48d0303c3f91033'
'80c873e144d52071b7a981bed014c8e5'
'1b276abe16d14e133f3f28d9c9e6bd68'
'c0d63f4d42fd334bf31e4f749d4694f3'

View file

@ -9,7 +9,7 @@
pkgname=ffmpeg
pkgver=2.2.3
pkgrel=1
pkgrel=2
epoch=1
pkgdesc='Complete and free Internet live audio and video broadcasting solution'
arch=('i686' 'x86_64')
@ -19,9 +19,8 @@ depends=(
'alsa-lib' 'bzip2' 'fontconfig' 'gnutls' 'gsm' 'lame' 'libass' 'libvdpau'
'libbluray' 'libmodplug' 'libpulse' 'libtheora' 'libva' 'libvorbis' 'libvpx'
'opencore-amr' 'openjpeg' 'opus' 'rtmpdump' 'schroedinger' 'sdl' 'speex'
'v4l-utils' 'x264' 'xvidcore' 'zlib'
)
makedepends=('libvdpau' 'yasm')
'v4l-utils' 'libx264' 'xvidcore' 'zlib')
makedepends=('libvdpau' 'yasm' 'x264')
source=(http://ffmpeg.org/releases/$pkgname-$pkgver.tar.bz2{,.asc})
md5sums=('dbb5b6b69bd010916f17df0ae596e0b1'
'SKIP')

View file

@ -6,7 +6,7 @@
# - patch to attempt fixing ARM hackery by bandwagoning developers
pkgname=x265
pkgver=1.0
pkgver=1.1
pkgrel=1
pkgdesc='Open Source H265/HEVC video encoder'
arch=('i686' 'x86_64')
@ -16,7 +16,7 @@ makedepends=('yasm' 'cmake')
url='https://bitbucket.org/multicoreware/x265'
source=($url/get/$pkgver.tar.bz2
arm.patch)
md5sums=('80efe963d3460caa051fe0b10d36bc10'
md5sums=('e6d33d31abdab1f7bd9c240641933472'
'b34f36b81f351061fa83ef7ef1a30956')
prepare() {