extra/firefox: fix

This commit is contained in:
Kevin Mihelich 2021-09-08 14:08:12 +00:00
parent 42543165f0
commit a25e712ee9
2 changed files with 0 additions and 18 deletions

View file

@ -28,13 +28,11 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
'xdg-desktop-portal: Screensharing with Wayland')
options=(!emptydirs !makeflags !strip)
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
arm.patch
build-arm-libopus.patch
0001-Use-remoting-name-for-GDK-application-names.patch
$pkgname.desktop identity-icons-brand.svg)
sha256sums=('299a472373021cc9194449c9f4bb962d5f74ef05e8af0448c589761ea34fbc84'
'SKIP'
'bc00516032330760444939c516a60c78f868631e1b37f075f0fe71a53737b966'
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9'
'd7c7a65c4b7ec9ea40df129724ffb369d3f775b0514e3c267c52eec6d284b5e6'
'298eae9de76ec53182f38d5c549d0379569916eebf62149f9d7f4a7edef36abf'
@ -122,7 +120,6 @@ END
export CXXFLAGS+=" -g0"
export LDFLAGS+=" -Wl,--no-keep-memory"
export RUSTFLAGS="-Cdebuginfo=0"
patch -p1 -i ../arm.patch
patch -p1 -i ../build-arm-libopus.patch
}

View file

@ -1,15 +0,0 @@
https://bugzilla.mozilla.org/show_bug.cgi?id=1526653
diff --git a/js/src/wasm/WasmSignalHandlers.cpp.orig b/js/src/wasm/WasmSignalHandlers.cpp
index 636537f..0f3461a 100644
--- a/js/src/wasm/WasmSignalHandlers.cpp.orig
+++ b/js/src/wasm/WasmSignalHandlers.cpp
@@ -244,7 +244,7 @@ using mozilla::DebugOnly;
// emulation here.
#if defined(__linux__) && defined(__arm__)
-# define WASM_EMULATE_ARM_UNALIGNED_FP_ACCESS
+//# define WASM_EMULATE_ARM_UNALIGNED_FP_ACCESS
#endif
#ifdef WASM_EMULATE_ARM_UNALIGNED_FP_ACCESS