mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
community/xine-ui: update
This commit is contained in:
parent
7ccf930c3c
commit
a2bbc284d1
2 changed files with 3 additions and 66 deletions
|
@ -1,54 +0,0 @@
|
||||||
From: Torsten Jager <t.jager@gmx.de>
|
|
||||||
Date: Thu, 16 Dec 2021 23:43:10 +0100
|
|
||||||
Subject: Fix build.
|
|
||||||
|
|
||||||
---
|
|
||||||
configure.ac | 6 ++++--
|
|
||||||
src/common/utils.h | 2 +-
|
|
||||||
src/xitk/network.c | 2 ++
|
|
||||||
3 files changed, 7 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 58342e0..8d7276e 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -600,8 +600,10 @@ int n = my_strlen ("what");
|
|
||||||
])], [have_attr_iaso=yes], [have_attr_iaso=no])
|
|
||||||
AC_MSG_RESULT([$have_attr_iaso])
|
|
||||||
if test x"$have_attr_iaso" = x"yes" ; then
|
|
||||||
- AC_DEFINE([ATTR_INLINE_ALL_STRINGOPS],
|
|
||||||
- [__attribute__ ((__target__ ("inline-all-stringops")))],
|
|
||||||
+ AC_DEFINE([ATTR_INLINE_ALL_STRINGOPS], [__attribute__ ((__target__ ("inline-all-stringops")))],
|
|
||||||
+ [Define this to a function attribute that inlines string handling code])
|
|
||||||
+else
|
|
||||||
+ AC_DEFINE([ATTR_INLINE_ALL_STRINGOPS], [],
|
|
||||||
[Define this to a function attribute that inlines string handling code])
|
|
||||||
fi
|
|
||||||
|
|
||||||
diff --git a/src/common/utils.h b/src/common/utils.h
|
|
||||||
index 8adad40..cfb2628 100644
|
|
||||||
--- a/src/common/utils.h
|
|
||||||
+++ b/src/common/utils.h
|
|
||||||
@@ -21,7 +21,7 @@
|
|
||||||
#ifndef _COMMON_UTILS_H
|
|
||||||
#define _COMMON_UTILS_H
|
|
||||||
|
|
||||||
-#ifndef HAVE_CONFIG_H
|
|
||||||
+#ifndef PACKAGE_NAME
|
|
||||||
#error config.h not included
|
|
||||||
#endif
|
|
||||||
|
|
||||||
diff --git a/src/xitk/network.c b/src/xitk/network.c
|
|
||||||
index 616400e..0fe39c5 100644
|
|
||||||
--- a/src/xitk/network.c
|
|
||||||
+++ b/src/xitk/network.c
|
|
||||||
@@ -34,7 +34,9 @@
|
|
||||||
|
|
||||||
//#warning IMPLEMENT POST SUPPORT
|
|
||||||
|
|
||||||
+#ifdef HAVE_CONFIG_H
|
|
||||||
#include "config.h"
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
#ifdef HAVE_READLINE
|
|
||||||
|
|
|
@ -1,8 +1,7 @@
|
||||||
# Maintainer : Daniel Bermond <dbermond@archlinux.org>
|
# Maintainer : Daniel Bermond <dbermond@archlinux.org>
|
||||||
# Contributor: Eric Bélanger
|
# Contributor: Eric Bélanger
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
# remove when bumped upstream
|
||||||
# - patch from debian to fix ARM FTBFS
|
|
||||||
|
|
||||||
pkgname=xine-ui
|
pkgname=xine-ui
|
||||||
pkgver=0.99.14
|
pkgver=0.99.14
|
||||||
|
@ -14,16 +13,8 @@ url='https://www.xine-project.org'
|
||||||
depends=('xine-lib' 'aalib' 'curl' 'hicolor-icon-theme' 'libjpeg-turbo' 'libpng'
|
depends=('xine-lib' 'aalib' 'curl' 'hicolor-icon-theme' 'libjpeg-turbo' 'libpng'
|
||||||
'libx11' 'libxext' 'libxft' 'libxinerama' 'libxv' 'libxxf86vm' 'lirc'
|
'libx11' 'libxext' 'libxft' 'libxinerama' 'libxv' 'libxxf86vm' 'lirc'
|
||||||
'readline')
|
'readline')
|
||||||
source=("https://downloads.sourceforge.net/xine/${pkgname}-${pkgver}.tar.xz"
|
source=("https://downloads.sourceforge.net/xine/${pkgname}-${pkgver}.tar.xz")
|
||||||
'0003-Fix-build.patch')
|
sha256sums=('d4d490d5cece70e2bb9849c9e482f2cf87af0302d451b614476fdcc3642cd9c3')
|
||||||
sha256sums=('d4d490d5cece70e2bb9849c9e482f2cf87af0302d451b614476fdcc3642cd9c3'
|
|
||||||
'f4a99353034788321c13ac754dd2122dae21d1f902f05e4917036e39d8e8b60b')
|
|
||||||
|
|
||||||
prepare() {
|
|
||||||
cd "${pkgname}-${pkgver}"
|
|
||||||
patch -p1 -i ../0003-Fix-build.patch
|
|
||||||
autoreconf -fi
|
|
||||||
}
|
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "${pkgname}-${pkgver}"
|
cd "${pkgname}-${pkgver}"
|
||||||
|
|
Loading…
Reference in a new issue