mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/mongodb to 3.2.10-2
This commit is contained in:
parent
525be54fe2
commit
a2e11addae
3 changed files with 46 additions and 2 deletions
|
@ -16,7 +16,7 @@
|
|||
buildarch=28
|
||||
|
||||
pkgname=mongodb
|
||||
pkgver=3.2.9
|
||||
pkgver=3.2.10
|
||||
pkgrel=2
|
||||
pkgdesc='A high-performance, open source, schema-free document-oriented database'
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -33,15 +33,19 @@ install=mongodb.install
|
|||
source=("http://downloads.mongodb.org/src/mongodb-src-r${pkgver}.tar.gz"
|
||||
'boost160.patch'
|
||||
'mongodb.conf' 'mongodb.service'
|
||||
'mongodb-3.2.10-boost-1.62.0.patch'
|
||||
'mongodb-3.2.10-network_interface_asio_integration_test.patch'
|
||||
'0001-mozjs-platform-support-for-ARM.patch'
|
||||
'0002-issue-693-convert-sys_futex-to-it-s-6-arg-form.patch'
|
||||
'0003-issue-693-enable-futex-usage-on-arm.patch'
|
||||
'0004-use-gnu-11-instead-of-c-11.patch'
|
||||
'0005-fix-options_parser-segfault.patch')
|
||||
sha512sums=('83187167c9775065ac24da180c6483bfc1580e085cfb7ff27572c812b9eee9ec7e9800d5da2238c333f03c641cc0e41b067341f28578ffc4513369a3f99dc002'
|
||||
sha512sums=('b9592c7cb0184ae10e1e7092b3fa0fc52b10acef1d7beffb2c2409867e237042d7765cc7191972ded10c278756cde1ff7b23b57fb7efd8363e18f2ce994985e9'
|
||||
'385c82875174caae433a3b381eb10f98a6fed0c8943788ddefff1de80a898e480bdbbf094a7783285cf2ae11ce3fc6878e57d58183d05be2f0837b206aaa4da6'
|
||||
'631d10baac9367e24d064c6ca05f1872dbf211c9d06ce2622d911da3a4f6416c521c649da686e0e283c10dba2802de74d952a45249461d0ca90ed1b316aed1ee'
|
||||
'177251404b2e818ae2b546fe8b13cb76e348c99e85c7bef22a04b0f07b600fd515a309ede50214f4198594388a6d2b31f46e945b9dae84aabb4dfa13b1123bb9'
|
||||
'd6f014d2778decde268b9e856d812bc61f7c45986aad751e44fdece39aa8a96505b77e0b917ea38880501497e01d4b051a6f3205c82af653425b5247cd813417'
|
||||
'4d044d5bae420c14cc4530728236486a2ea9abe0224ed4f114d5f9e23637bfdbdd0bdfe14ecc6c1f9d6e6a13f278c6f212034077d88aaac60d8220e6c738e209'
|
||||
'9877ef788fd1170337ef6da267d8fb624f74c59eb98533753d4db9ff841f562e81cbb3ee36431ea11cee4f9354876426bc24edaa68dd43ef2b1f5e5111395696'
|
||||
'12c56405bed46f8d607ea46dfce07d567dfb4cfc16c06b8a3fc07c41d72d377aeba16a5bbc6a53962b24cc5524500b28ff736b59fe7e558ca638ffa2c0fd4a71'
|
||||
'c6e50c4b1e59614309ef989bbff102394fd9d424c0f4af16917194662b744fc7a5a05e6b04dcdc56632dc6260d46d286bad7ed0b360cad79ee4c15f4d0e61035'
|
||||
|
@ -76,6 +80,8 @@ fi
|
|||
prepare() {
|
||||
cd mongodb-src-r${pkgver}
|
||||
patch -Np1 -i ../boost160.patch
|
||||
patch -Np1 -i ../mongodb-3.2.10-boost-1.62.0.patch
|
||||
patch -Np1 -i ../mongodb-3.2.10-network_interface_asio_integration_test.patch
|
||||
|
||||
sed -e 's|-std=c++11|-std=gnu++11|g' -i SConstruct # tests use hex floats, not supported in plain C++
|
||||
|
||||
|
|
15
community/mongodb/mongodb-3.2.10-boost-1.62.0.patch
Normal file
15
community/mongodb/mongodb-3.2.10-boost-1.62.0.patch
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-src_mongo_db_fts_unicode_string.cpp,v 1.1 2016/10/10 13:15:40 ryoon Exp $
|
||||
|
||||
* Fix build with boost 1.62.0
|
||||
|
||||
--- a/src/mongo/db/fts/unicode/string.cpp.orig 2016-09-26 12:10:04.000000000 +0000
|
||||
+++ b/src/mongo/db/fts/unicode/string.cpp
|
||||
@@ -274,7 +274,7 @@ bool String::substrMatch(const std::stri
|
||||
|
||||
// Case sensitive and diacritic sensitive.
|
||||
return boost::algorithm::boyer_moore_search(
|
||||
- haystack.begin(), haystack.end(), needle.begin(), needle.end()) != haystack.end();
|
||||
+ haystack.begin(), haystack.end(), needle.begin(), needle.end()) != std::make_pair(haystack.end(), haystack.end());
|
||||
}
|
||||
|
||||
} // namespace unicode
|
|
@ -0,0 +1,23 @@
|
|||
From ea20ce71ee1151abc5bbe5ea60713a86d34a751a Mon Sep 17 00:00:00 2001
|
||||
From: Waley Chen <waleycz@gmail.com>
|
||||
Date: Fri, 6 May 2016 17:53:10 -0400
|
||||
Subject: [PATCH] SERVER-23951 network_interface_asio_integration_test //
|
||||
ExceededTimeLimit
|
||||
|
||||
---
|
||||
src/mongo/executor/network_interface_asio_integration_test.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/mongo/executor/network_interface_asio_integration_test.cpp b/src/mongo/executor/network_interface_asio_integration_test.cpp
|
||||
index cb85f27..617ae36 100644
|
||||
--- a/src/mongo/executor/network_interface_asio_integration_test.cpp
|
||||
+++ b/src/mongo/executor/network_interface_asio_integration_test.cpp
|
||||
@@ -170,7 +170,7 @@ class StressTestOp {
|
||||
using Fixture = NetworkInterfaceASIOIntegrationTest;
|
||||
using Pool = ThreadPoolInterface;
|
||||
|
||||
- Deferred<Status> run(Fixture* fixture, Pool* pool, Milliseconds timeout = Milliseconds(5000)) {
|
||||
+ Deferred<Status> run(Fixture* fixture, Pool* pool, Milliseconds timeout = Milliseconds(60000)) {
|
||||
auto cb = makeCallbackHandle();
|
||||
auto self = *this;
|
||||
auto out =
|
Loading…
Reference in a new issue