extra/claws-mail to 3.16.0-1

This commit is contained in:
Kevin Mihelich 2017-12-22 12:39:48 +00:00
parent 7c23fdc875
commit a318a5bf16
3 changed files with 6 additions and 105 deletions

View file

@ -5,8 +5,8 @@
# - drop valgrind makedepend
pkgname=claws-mail
pkgver=3.15.1
pkgrel=3
pkgver=3.16.0
pkgrel=1
pkgdesc="A GTK+ based e-mail client."
arch=('x86_64')
license=('GPL3')
@ -39,22 +39,17 @@ replaces=('sylpheed-claws' 'claws-mail-extra-plugins')
conflicts=('claws-mail-extra-plugins')
provides=('claws')
source=(http://www.claws-mail.org/download.php?file=releases/claws-mail-$pkgver.tar.xz{,.asc}
dillo-plugin.diff
enchant-2.patch
claws-mail-3.15.1-libical3.patch)
sha256sums=('8d093c2f32db863c1141d56e35424c04ee48fe5d6adf4c7f349f647fa3149542'
dillo-plugin.diff)
sha256sums=('c212133d3d962129d8c7995c1c7d973faef2a8914481c0c74578217bf4c897ab'
'SKIP'
'ab08ca513145e847d30a29d9e5a9ae63b94222423e88c1b375fd5cfcb427d6c5'
'fafd9713b265b55a84b01e5071d930965b98d34cde57be4aaa46c5eb6c2635ce'
'160cb7a3ac057c5a8f65427adc152f53abd372eeaf1b371e9a99bfcb741a793f')
'ab08ca513145e847d30a29d9e5a9ae63b94222423e88c1b375fd5cfcb427d6c5')
validpgpkeys=('8B3B297A03468356692F8D592CD716D654D6BBD4') # Paul <paul@claws-mail.org>
prepare() {
cd ${pkgname}-${pkgver}
# upstream reintroduction of dillo plugin - after fancy plugin dropped
patch -Np1 -i ../dillo-plugin.diff
patch -Np1 -i ../enchant-2.patch
patch -Np1 -i ../claws-mail-3.15.1-libical3.patch
autoreconf -vfi
sed -i 's@^#!.*python.*@#!/usr/bin/python2@' tools/*.py
sed -i 's:python -c:python2 -c:g' configure

View file

@ -1,83 +0,0 @@
diff -Nur claws-mail-3.15.1-orig/src/plugins/vcalendar/vcalendar.c claws-mail-3.15.1/src/plugins/vcalendar/vcalendar.c
--- claws-mail-3.15.1-orig/src/plugins/vcalendar/vcalendar.c 2017-08-28 19:48:24.000000000 +0200
+++ claws-mail-3.15.1/src/plugins/vcalendar/vcalendar.c 2017-11-16 17:51:01.139709415 +0100
@@ -157,8 +157,8 @@
gchar *orgname = NULL;
gchar *summary = g_strdup(msginfo->subject ? msginfo->subject:_("no subject"));
gchar *description = file_read_stream_to_str(fp);
- gchar *dtstart = g_strdup(icaltime_as_ical_string(icaltime_from_timet(t, FALSE)));
- gchar *dtend = g_strdup(icaltime_as_ical_string(icaltime_from_timet(t2, FALSE)));
+ gchar *dtstart = g_strdup(icaltime_as_ical_string(icaltime_from_timet_with_zone(t, FALSE,NULL)));
+ gchar *dtend = g_strdup(icaltime_as_ical_string(icaltime_from_timet_with_zone(t2, FALSE,NULL)));
gchar *recur = NULL;
gchar *tzid = g_strdup("UTC");
gchar *url = NULL;
diff -Nur claws-mail-3.15.1-orig/src/plugins/vcalendar/vcal_manager.c claws-mail-3.15.1/src/plugins/vcalendar/vcal_manager.c
--- claws-mail-3.15.1-orig/src/plugins/vcalendar/vcal_manager.c 2017-08-28 19:48:24.000000000 +0200
+++ claws-mail-3.15.1/src/plugins/vcalendar/vcal_manager.c 2017-11-16 17:43:34.911106211 +0100
@@ -395,7 +395,7 @@
icalcomponent_add_property(ievent,
icalproperty_new_uid(event->uid));
icalcomponent_add_property(ievent,
- icalproperty_vanew_dtstamp(icaltime_from_timet(time(NULL), TRUE), (void*)0));
+ icalproperty_vanew_dtstamp(icaltime_from_timet_with_zone(time(NULL), TRUE, NULL), (void*)0));
icalcomponent_add_property(ievent,
icalproperty_vanew_dtstart((icaltime_from_string(event->dtstart)), (void*)0));
icalcomponent_add_property(ievent,
@@ -423,9 +423,9 @@
icalcomponent_add_property(ievent,
icalproperty_new_status(ICAL_STATUS_CONFIRMED));
icalcomponent_add_property(ievent,
- icalproperty_vanew_created(icaltime_from_timet(time(NULL), TRUE), (void*)0));
+ icalproperty_vanew_created(icaltime_from_timet_with_zone(time(NULL), TRUE, NULL), (void*)0));
icalcomponent_add_property(ievent,
- icalproperty_vanew_lastmodified(icaltime_from_timet(time(NULL), TRUE), (void*)0));
+ icalproperty_vanew_lastmodified(icaltime_from_timet_with_zone(time(NULL), TRUE, NULL), (void*)0));
icalcomponent_add_property(ievent,
orgprop);
diff -Nur claws-mail-3.15.1-orig/src/plugins/vcalendar/vcal_meeting_gtk.c claws-mail-3.15.1/src/plugins/vcalendar/vcal_meeting_gtk.c
--- claws-mail-3.15.1-orig/src/plugins/vcalendar/vcal_meeting_gtk.c 2017-08-28 19:48:24.000000000 +0200
+++ claws-mail-3.15.1/src/plugins/vcalendar/vcal_meeting_gtk.c 2017-11-16 17:54:45.798495950 +0100
@@ -477,7 +477,7 @@
debug_print("DST change offset to apply to time %d\n", dst_offset);
t += dst_offset;
debug_print("%s\n", ctime(&t));
- return g_strdup(icaltime_as_ical_string(icaltime_from_timet(t, FALSE)));
+ return g_strdup(icaltime_as_ical_string(icaltime_from_timet_with_zone(t, FALSE,NULL)));
}
static gchar *get_location(VCalMeeting *meet)
@@ -893,8 +893,8 @@
found = FALSE;
while (!found && offset >= -3600*6) {
gboolean ok = TRUE;
- struct icaltimetype new_start = icaltime_from_timet(icaltime_as_timet(start)+offset, FALSE);
- struct icaltimetype new_end = icaltime_from_timet(icaltime_as_timet(end)+offset, FALSE);
+ struct icaltimetype new_start = icaltime_from_timet_with_zone(icaltime_as_timet(start)+offset, FALSE, NULL);
+ struct icaltimetype new_end = icaltime_from_timet_with_zone(icaltime_as_timet(end)+offset, FALSE, NULL);
for (cur = attendees; cur; cur = cur->next) {
VCalAttendee *attendee = (VCalAttendee *)cur->data;
debug_print("trying %s - %s (offset %d)\n",
@@ -919,8 +919,8 @@
offset = 1800;
while (!found && offset <= 3600*6) {
gboolean ok = TRUE;
- struct icaltimetype new_start = icaltime_from_timet(icaltime_as_timet(start)+offset, FALSE);
- struct icaltimetype new_end = icaltime_from_timet(icaltime_as_timet(end)+offset, FALSE);
+ struct icaltimetype new_start = icaltime_from_timet_with_zone(icaltime_as_timet(start)+offset, FALSE, NULL);
+ struct icaltimetype new_end = icaltime_from_timet_with_zone(icaltime_as_timet(end)+offset, FALSE, NULL);
for (cur = attendees; cur; cur = cur->next) {
VCalAttendee *attendee = (VCalAttendee *)cur->data;
debug_print("trying %s - %s (offset %d)\n",
@@ -2172,8 +2172,8 @@
icalcomponent_add_component(calendar, timezone);
- itt_start = icaltime_from_timet(whole_start, FALSE);
- itt_end = icaltime_from_timet(whole_end, FALSE);
+ itt_start = icaltime_from_timet_with_zone(whole_start, FALSE, NULL);
+ itt_end = icaltime_from_timet_with_zone(whole_end, FALSE, NULL);
itt_start.second = itt_start.minute = itt_start.hour = 0;
itt_end.second = 59; itt_end.minute = 59; itt_end.hour = 23;

View file

@ -1,11 +0,0 @@
--- claws-mail-3.15.1/src/gtk/gtkaspell.c.orig 2017-08-28 17:48:24.000000000 +0000
+++ claws-mail-3.15.1/src/gtk/gtkaspell.c 2017-11-22 15:05:59.371073969 +0000
@@ -1348,7 +1348,7 @@
{
GtkAspell *gtkaspell = (GtkAspell *) data;
- enchant_dict_add_to_pwl(gtkaspell->gtkaspeller->speller, gtkaspell->theword, strlen(gtkaspell->theword));
+ enchant_dict_add(gtkaspell->gtkaspeller->speller, gtkaspell->theword, strlen(gtkaspell->theword));
gtkaspell->ctx.check_word(gtkaspell->ctx.data);
gtkaspell_dict_changed(gtkaspell);