mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/mariadb to 10.1.34-1
This commit is contained in:
parent
7997478c30
commit
a32bef7b03
2 changed files with 2 additions and 61 deletions
|
@ -1,53 +0,0 @@
|
|||
From 8b18a44fa7e5ddf6c8caee37de4f6112c64dfc87 Mon Sep 17 00:00:00 2001
|
||||
From: Sergei Golubchik <serg@mariadb.org>
|
||||
Date: Mon, 13 Nov 2017 13:11:53 +0800
|
||||
Subject: [PATCH] mroonga after-merge CMakeLists.txt fixes
|
||||
|
||||
1. remove erroneously committed *.orig
|
||||
2. fix LZ4 detection on Mac OS X and FreeBSD. Cannot do
|
||||
|
||||
pkg_check_modules(LIBLZ4 liblz4)
|
||||
find_library(LIBLZ4_LIBS ... )
|
||||
|
||||
because find_library(X) does not do anything if X is defined (documented),
|
||||
and pkg_check_modules(Y) sets Y_LIBS to "" (undocumented!)
|
||||
---
|
||||
storage/mroonga/vendor/groonga/CMakeLists.txt | 4 +-
|
||||
storage/mroonga/vendor/groonga/lib/CMakeLists.txt | 2 +-
|
||||
2 files changed, 3 insertions(+), 3 deletions(-)
|
||||
delete mode 100644 storage/mroonga/CMakeLists.txt.orig
|
||||
delete mode 100644 storage/mroonga/vendor/groonga/CMakeLists.txt.orig
|
||||
|
||||
diff --git a/storage/mroonga/vendor/groonga/CMakeLists.txt b/storage/mroonga/vendor/groonga/CMakeLists.txt
|
||||
index 3d957c9d5152..e27070f9e0c3 100644
|
||||
--- a/storage/mroonga/vendor/groonga/CMakeLists.txt
|
||||
+++ b/storage/mroonga/vendor/groonga/CMakeLists.txt
|
||||
@@ -355,13 +355,13 @@ if(NOT ${GRN_WITH_LZ4} STREQUAL "no")
|
||||
if(GRN_WITH_BUNDLED_LZ4)
|
||||
set(LIBLZ4_INCLUDE_DIRS
|
||||
"${CMAKE_CURRENT_SOURCE_DIR}/vendor/lz4-${GRN_BUNDLED_LZ4_VERSION}/lib")
|
||||
- set(LIBLZ4_LIBS liblz4)
|
||||
+ set(LZ4_LIBS liblz4)
|
||||
else()
|
||||
if(NOT DEFINED LIBLZ4_FOUND)
|
||||
pkg_check_modules(LIBLZ4 liblz4)
|
||||
endif()
|
||||
if(LIBLZ4_FOUND)
|
||||
- find_library(LIBLZ4_LIBS
|
||||
+ find_library(LZ4_LIBS
|
||||
NAMES ${LIBLZ4_LIBRARIES}
|
||||
PATHS ${LIBLZ4_LIBRARY_DIRS}
|
||||
NO_DEFAULT_PATH)
|
||||
diff --git a/storage/mroonga/vendor/groonga/lib/CMakeLists.txt b/storage/mroonga/vendor/groonga/lib/CMakeLists.txt
|
||||
index a90cea0043eb..6765261feb7d 100644
|
||||
--- a/storage/mroonga/vendor/groonga/lib/CMakeLists.txt
|
||||
+++ b/storage/mroonga/vendor/groonga/lib/CMakeLists.txt
|
||||
@@ -94,7 +94,7 @@ set(GRN_ALL_LIBRARIES
|
||||
${RT_LIBS}
|
||||
${PTHREAD_LIBS}
|
||||
${Z_LIBS}
|
||||
- ${LIBLZ4_LIBS}
|
||||
+ ${LZ4_LIBS}
|
||||
${LIBZSTD_LIBS}
|
||||
${MESSAGE_PACK_LIBS}
|
||||
${DL_LIBS}
|
|
@ -8,7 +8,7 @@
|
|||
|
||||
pkgbase=mariadb
|
||||
pkgname=('libmariadbclient' 'mariadb-clients' 'mytop' 'mariadb')
|
||||
pkgver=10.1.33
|
||||
pkgver=10.1.34
|
||||
pkgrel=1
|
||||
arch=('x86_64')
|
||||
license=('GPL')
|
||||
|
@ -18,12 +18,10 @@ makedepends=('boost' 'bzip2' 'cmake' 'jemalloc' 'libaio' 'libxml2' 'lz4' 'lzo'
|
|||
validpgpkeys=('199369E5404BD5FC7D2FE43BCBCB082A1BB943DB') # MariaDB Package Signing Key <package-signing-key@mariadb.org>
|
||||
source=("https://ftp.heanet.ie/mirrors/mariadb/mariadb-$pkgver/source/mariadb-$pkgver.tar.gz"{,.asc}
|
||||
'0001-openssl-1-1-0.patch'
|
||||
'0002-mroonga-after-merge-CMakeLists.txt-fixes.patch'
|
||||
'atomic.patch')
|
||||
sha256sums=('94312c519f2c0c25e1964c64e22aff0036fb22dfb2685638f43a6b2211395d2d'
|
||||
sha256sums=('c7e0719fd08790c096585bf867fe87e084b310f2f3679e059e3b10b9fd6d5548'
|
||||
'SKIP'
|
||||
'229d556748119757f36be1e9956834be28db0f5a35cdacce53f6c640784fca77'
|
||||
'98736aefef21e575e450f8066685ba82771264409412e33491ab0a54e4407ba7'
|
||||
'2ddfe7dc5eae905ed77d7438d6869f9bb26684945c2f82cc19f84926b1cb849f')
|
||||
|
||||
prepare() {
|
||||
|
@ -39,10 +37,6 @@ prepare() {
|
|||
# openssl 1.1.0
|
||||
patch -Np1 < "${srcdir}"/0001-openssl-1-1-0.patch
|
||||
|
||||
# revert to fix the build
|
||||
# mroonga after-merge CMakeLists.txt fixes
|
||||
patch -Np1 -R < "${srcdir}"/0002-mroonga-after-merge-CMakeLists.txt-fixes.patch
|
||||
|
||||
# let's create the datadir from tmpfiles
|
||||
echo 'd @MYSQL_DATADIR@ 0700 @MYSQLD_USER@ @MYSQLD_USER@ -' >> support-files/tmpfiles.conf.in
|
||||
|
||||
|
|
Loading…
Reference in a new issue