mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
added alarm/uboot-beagleboard
This commit is contained in:
parent
af41fef223
commit
a3623f836b
3 changed files with 97 additions and 0 deletions
44
alarm/uboot-beagleboard/PKGBUILD
Normal file
44
alarm/uboot-beagleboard/PKGBUILD
Normal file
|
@ -0,0 +1,44 @@
|
|||
# U-Boot: BeagleBoard and BeagleBoard-xM
|
||||
# Maintainer: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
|
||||
buildarch=4
|
||||
|
||||
pkgname=uboot-beagleboard
|
||||
pkgver=2014.01
|
||||
pkgrel=1
|
||||
pkgdesc="U-Boot for BeagleBoard and BeagleBoard-xM"
|
||||
arch=('armv7h')
|
||||
url="http://git.denx.de/u-boot.git/"
|
||||
license=('GPL')
|
||||
makedepends=('git')
|
||||
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
|
||||
"https://raw.github.com/eewiki/u-boot-patches/master/v${pkgver}/0001-omap3_beagle-uEnv.txt-bootz-n-fixes.patch"
|
||||
'alarm.patch'
|
||||
'uEnv.txt')
|
||||
md5sums=('e531307578f6d32a7ccb1d04f1e08cbc'
|
||||
'6d6a394e07527d30330092ea3aa35cc9'
|
||||
'8c8e5ce2a03e99ed561185e9a6cffad8'
|
||||
'3704f05f308e3bb73a5b67a033b2ce5c')
|
||||
|
||||
prepare() {
|
||||
cd u-boot-${pkgver}
|
||||
|
||||
patch -p1 -i "${srcdir}"/0001-omap3_beagle-uEnv.txt-bootz-n-fixes.patch
|
||||
patch -p1 -i "${srcdir}"/alarm.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd u-boot-${pkgver}
|
||||
|
||||
unset LDFLAGS CFLAGS CXXFLAGS
|
||||
|
||||
make distclean
|
||||
make omap3_beagle_config
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd u-boot-${pkgver}
|
||||
mkdir -p "${pkgdir}"/boot
|
||||
cp MLO u-boot.img "${srcdir}"/uEnv.txt "${pkgdir}"/boot
|
||||
}
|
52
alarm/uboot-beagleboard/alarm.patch
Normal file
52
alarm/uboot-beagleboard/alarm.patch
Normal file
|
@ -0,0 +1,52 @@
|
|||
diff -urN a/include/configs/omap3_beagle.h b/include/configs/omap3_beagle.h
|
||||
--- a/include/configs/omap3_beagle.h 2014-02-02 13:27:32.899074278 -0700
|
||||
+++ b/include/configs/omap3_beagle.h 2014-02-02 13:27:06.719177569 -0700
|
||||
@@ -193,6 +193,8 @@
|
||||
/* Environment information */
|
||||
#define CONFIG_BOOTDELAY 1
|
||||
|
||||
+#define CONFIG_IDENT_STRING " Arch Linux ARM"
|
||||
+
|
||||
#define CONFIG_EXTRA_ENV_SETTINGS \
|
||||
"loadaddr=0x80300000\0" \
|
||||
"rdaddr=0x81000000\0" \
|
||||
@@ -201,9 +203,9 @@
|
||||
"usbtty=cdc_acm\0" \
|
||||
"bootfile=zImage\0" \
|
||||
"ramdisk=ramdisk.gz\0" \
|
||||
- "bootdir=\0" \
|
||||
- "bootpart=0:1\0" \
|
||||
- "fdtdir=/dtbs\0" \
|
||||
+ "bootdir=/boot\0" \
|
||||
+ "bootpart=0:2\0" \
|
||||
+ "fdtdir=/boot/dtbs\0" \
|
||||
"console=ttyO2,115200n8\0" \
|
||||
"mpurate=auto\0" \
|
||||
"buddy=none\0" \
|
||||
@@ -214,8 +216,7 @@
|
||||
"dvimode=640x480MR-16@60\0" \
|
||||
"defaultdisplay=dvi\0" \
|
||||
"mmcdev=0\0" \
|
||||
- "mmcroot=/dev/mmcblk0p2 ro\0" \
|
||||
- "mmcrootfstype=ext4 rootwait fixrtc\0" \
|
||||
+ "mmcroot=/dev/mmcblk0p2 rw rootwait fixrtc\0" \
|
||||
"nandroot=ubi0:rootfs ubi.mtd=4\0" \
|
||||
"nandrootfstype=ubifs\0" \
|
||||
"ramroot=/dev/ram0 rw ramdisk_size=65536 initrd=0x81000000,64M\0" \
|
||||
@@ -229,7 +230,6 @@
|
||||
"omapfb.mode=dvi:${dvimode} " \
|
||||
"omapdss.def_disp=${defaultdisplay} " \
|
||||
"root=${mmcroot} " \
|
||||
- "rootfstype=${mmcrootfstype} " \
|
||||
"${musb}\0" \
|
||||
"nandargs=setenv bootargs console=${console} " \
|
||||
"${optargs} " \
|
||||
@@ -258,7 +258,7 @@
|
||||
"if test $beaglerev = xMAB; then " \
|
||||
"fdt addr ${fdtaddr}; fdt resize; fdt set /hsusb2_power_reg enable-active-high; fi; \0" \
|
||||
"bootenv=uEnv.txt\0" \
|
||||
- "loadbootenv=load mmc ${bootpart} ${loadaddr} ${bootenv}\0" \
|
||||
+ "loadbootenv=load mmc ${bootpart} ${loadaddr} ${bootdir}/${bootenv}\0" \
|
||||
"importbootenv=echo Importing environment from mmc ...; " \
|
||||
"env import -t $loadaddr $filesize\0" \
|
||||
"ramargs=setenv bootargs console=${console} " \
|
1
alarm/uboot-beagleboard/uEnv.txt
Normal file
1
alarm/uboot-beagleboard/uEnv.txt
Normal file
|
@ -0,0 +1 @@
|
|||
#mmcroot=/dev/mmcblk0p2 rw rootwait fixrtc
|
Loading…
Reference in a new issue