mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
added extra/texmacs
This commit is contained in:
parent
abd769e381
commit
a37911852c
3 changed files with 87 additions and 0 deletions
61
extra/texmacs/PKGBUILD
Normal file
61
extra/texmacs/PKGBUILD
Normal file
|
@ -0,0 +1,61 @@
|
||||||
|
# $Id$
|
||||||
|
# Maintainer: Ronald van Haren <ronald.archlinux.org>
|
||||||
|
# Contributor: Damir Perisa <damir.perisa@bluewin.ch> # Contributor: Christopher Reimer <c.reimer1993@gmail.com>
|
||||||
|
|
||||||
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
# - patch to fix qreal usage
|
||||||
|
|
||||||
|
pkgname=texmacs
|
||||||
|
pkgver=1.0.7.21
|
||||||
|
pkgrel=1
|
||||||
|
pkgdesc="Free scientific text editor, inspired by TeX and GNU Emacs. WYSIWYG editor TeX-fonts and CAS-interface (Giac, GTybalt, Macaulay 2, Maxima, Octave, Pari, Qcl, R and Yacas) in one."
|
||||||
|
arch=('i686' 'x86_64')
|
||||||
|
url="http://www.texmacs.org/"
|
||||||
|
license=('GPL')
|
||||||
|
depends=('perl' 'guile1.8' 'texlive-core' 'python2' 'libxext' 'freetype2' 'shared-mime-info'
|
||||||
|
'desktop-file-utils' 'qt4')
|
||||||
|
# do not remove texlive-core dependency, as it is needed!
|
||||||
|
optdepends=('transfig: convert images using fig2ps'
|
||||||
|
'gawk: conversion of some files')
|
||||||
|
makedepends=('ghostscript')
|
||||||
|
#source=(ftp://ftp.texmacs.org/pub/TeXmacs/targz/TeXmacs-${pkgver}-src.tar.gz)
|
||||||
|
source=(http://pkgs.fedoraproject.org/repo/pkgs/TeXmacs/TeXmacs-1.0.7.21-src.tar.gz/a56e2f14761e9003471fd26d91058ef0/TeXmacs-1.0.7.21-src.tar.gz
|
||||||
|
arm.patch)
|
||||||
|
install=texmacs.install
|
||||||
|
options=('!emptydirs')
|
||||||
|
sha1sums=('e8086acd4b7c1bb3aaccf75b6b0199aa612cb66c'
|
||||||
|
'3c431d63360da065b4021df04ed052ee6b18b8ae')
|
||||||
|
|
||||||
|
build() {
|
||||||
|
cd ${srcdir}/TeXmacs-${pkgver}-src
|
||||||
|
patch -p1 -i ../arm.patch
|
||||||
|
sed -i 's/env python/env python2/' \
|
||||||
|
plugins/{mathematica/bin/realpath.py,python/bin/tm_python,sage/bin/tm_sage} \
|
||||||
|
TeXmacs/misc/inkscape_plugin/texmacs_reedit.py
|
||||||
|
sed -i 's/"python"/"python2"/' plugins/python/progs/init-python.scm
|
||||||
|
sed -i '/^LDPATH/d' src/makefile.in
|
||||||
|
sed -i -e 's/guile /guile1.8 /g' \
|
||||||
|
-e 's/guile-config/guile-config1.8/g' \
|
||||||
|
configure
|
||||||
|
|
||||||
|
# Don't generate icon-cache and mime-database (namcap tells that they should not be in a package)
|
||||||
|
sed -i '/update-mime-database/d' Makefile.in
|
||||||
|
sed -i '/gtk-update-icon-cache/d' Makefile.in
|
||||||
|
sed -i '\/icons\/gnome 2>\/dev\/null/d' Makefile.in
|
||||||
|
|
||||||
|
export QMAKE=qmake-qt4
|
||||||
|
export MOC=moc-qt4
|
||||||
|
export UIC=uic-qt4
|
||||||
|
./configure --prefix=/usr \
|
||||||
|
--mandir=/usr/share/man \
|
||||||
|
--libexecdir=/usr/lib
|
||||||
|
make
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
cd ${srcdir}/TeXmacs-${pkgver}-src
|
||||||
|
make DESTDIR=${pkgdir} install
|
||||||
|
|
||||||
|
# fix fig2ps script
|
||||||
|
sed -i 's|${prefix}|/usr|' ${pkgdir}/usr/bin/fig2ps
|
||||||
|
}
|
12
extra/texmacs/arm.patch
Normal file
12
extra/texmacs/arm.patch
Normal file
|
@ -0,0 +1,12 @@
|
||||||
|
diff -urN a/src/Plugins/Qt/qt_renderer.cpp b/src/Plugins/Qt/qt_renderer.cpp
|
||||||
|
--- a/src/Plugins/Qt/qt_renderer.cpp 2013-11-03 16:09:35.000000000 -0700
|
||||||
|
+++ b/src/Plugins/Qt/qt_renderer.cpp 2014-02-03 13:45:42.670490781 -0700
|
||||||
|
@@ -271,7 +271,7 @@
|
||||||
|
if ((N(y) != n) || (n<2)) return;
|
||||||
|
STACK_NEW_ARRAY (pnt, QPointF, n);
|
||||||
|
for (i=0; i<n; i++)
|
||||||
|
- decode (x[i], y[i], pnt[i].rx(), pnt[i].ry());
|
||||||
|
+ decode (x[i], y[i], (double&)pnt[i].rx(), (double&)pnt[i].ry());
|
||||||
|
painter->setRenderHints (QPainter::Antialiasing);
|
||||||
|
painter->drawPolyline (pnt, n);
|
||||||
|
STACK_DELETE_ARRAY (pnt);
|
14
extra/texmacs/texmacs.install
Normal file
14
extra/texmacs/texmacs.install
Normal file
|
@ -0,0 +1,14 @@
|
||||||
|
post_install() {
|
||||||
|
update-desktop-database -q
|
||||||
|
update-mime-database usr/share/mime
|
||||||
|
}
|
||||||
|
|
||||||
|
post_upgrade() {
|
||||||
|
post_install
|
||||||
|
}
|
||||||
|
|
||||||
|
post_remove () {
|
||||||
|
post_install
|
||||||
|
}
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue