From a39e2cfc728d56aa5bed6504575dffa4a78a42d1 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Wed, 3 Feb 2016 00:37:53 +0000
Subject: [PATCH] extra/x265 to 1.9-1

---
 extra/x265/PKGBUILD | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)

diff --git a/extra/x265/PKGBUILD b/extra/x265/PKGBUILD
index d84a02b60..7188db95e 100644
--- a/extra/x265/PKGBUILD
+++ b/extra/x265/PKGBUILD
@@ -7,8 +7,8 @@
 #  - patch to attempt fixing ARM hackery by bandwagoning developers
 
 pkgname=x265
-pkgver=1.8
-pkgrel=3
+pkgver=1.9
+pkgrel=1
 pkgdesc='Open Source H265/HEVC video encoder'
 arch=('i686' 'x86_64')
 url='https://bitbucket.org/multicoreware/x265'
@@ -18,11 +18,11 @@ makedepends=('yasm' 'cmake')
 provides=('libx265.so')
 source=("https://bitbucket.org/multicoreware/x265/downloads/x265_${pkgver}.tar.gz"
         arm.patch)
-md5sums=('8b7ef9bc0b5bd26965d05a4508effeed'
+md5sums=('f34a1c4c660ff07511365cb0983cf164'
          '4c04f99e474df7f54f0b9db8ee1bb1f6')
 
 prepare() {
-  cd x265_11047
+  cd x265_${pkgver}
 
   patch -p1 -i ../arm.patch
 
@@ -37,7 +37,7 @@ prepare() {
 build() {
   if [[ $CARCH == x86_64 ]]; then
 
-    cd x265_11047/build-12
+    cd x265_${pkgver}/build-12
 
     cmake ../source \
       -DCMAKE_INSTALL_PREFIX='/usr' \
@@ -74,7 +74,7 @@ build() {
 
   else
 
-    cd x265_11047/build-8
+    cd x265_${pkgver}/build-8
 
     cmake ../source \
       -DCMAKE_INSTALL_PREFIX='/usr' \
@@ -84,7 +84,7 @@ build() {
 }
 
 package() {
-  cd x265_11047/build-8
+  cd x265_${pkgver}/build-8
 
   make DESTDIR="${pkgdir}" install
 }