kernel26-dockstar updated to 2.6.35.1

This commit is contained in:
Mike Staszel 2010-08-12 09:02:35 -05:00
parent 7550e475a6
commit a3eb8f022b
4 changed files with 79 additions and 13 deletions

View file

@ -0,0 +1,15 @@
--- a/arch/arm/mach-kirkwood/sheevaplug-setup.c
+++ b/arch/arm/mach-kirkwood/sheevaplug-setup.c
@@ -34,6 +34,10 @@ static struct mtd_partition sheevaplug_nand_parts[] = {
}, {
.name = "root",
.offset = MTDPART_OFS_NXTBLK,
+ .size = SZ_32M
+ }, {
+ .name = "data",
+ .offset = MTDPART_OFS_NXTBLK,
.size = MTDPART_SIZ_FULL
},
};
--
1.6.4.4

View file

@ -0,0 +1,32 @@
--- a/arch/arm/mach-kirkwood/sheevaplug-setup.c
+++ b/arch/arm/mach-kirkwood/sheevaplug-setup.c
@@ -52,9 +52,15 @@ static struct mvsdio_platform_data sheevaplug_mvsdio_data = {
static struct gpio_led sheevaplug_led_pins[] = {
{
- .name = "plug:green:health",
+ .name = "dockstar:green:health",
.default_trigger = "default-on",
- .gpio = 49,
+ .gpio = 46, /* green */
+ .active_low = 1,
+ },
+ {
+ .name = "dockstar:orange:misc",
+ .default_trigger = "none",
+ .gpio = 47, /* orange */
.active_low = 1,
},
};
@@ -74,7 +80,8 @@ static struct platform_device sheevaplug_leds = {
static unsigned int sheevaplug_mpp_config[] __initdata = {
MPP29_GPIO, /* USB Power Enable */
- MPP49_GPIO, /* LED */
+ MPP46_GPIO, /* LED green */
+ MPP47_GPIO, /* LED orange */
0
};
--
1.6.4.4

View file

@ -0,0 +1,22 @@
--- a/arch/arm/mach-kirkwood/Kconfig
+++ b/arch/arm/mach-kirkwood/Kconfig
@@ -27,10 +27,10 @@ config MACH_MV88F6281GTW_GE
Marvell 88F6281 GTW GE Board.
config MACH_SHEEVAPLUG
- bool "Marvell SheevaPlug Reference Board"
+ bool "Seagate DockStar Board"
help
Say 'Y' here if you want your kernel to support the
- Marvell SheevaPlug Reference Board.
+ Seagate DockStar Board.
config MACH_TS219
bool "QNAP TS-110, TS-119, TS-210, TS-219 and TS-219P Turbo NAS"
--- a/arch/arm/mach-kirkwood/sheevaplug-setup.c
+++ b/arch/arm/mach-kirkwood/sheevaplug-setup.c
@@ -143,1 +143,1 @@
-MACHINE_START(SHEEVAPLUG, "Marvell SheevaPlug Reference Board")
+MACHINE_START(SHEEVAPLUG, "Seagate DockStar Board")
--

View file

@ -3,7 +3,7 @@
# This PKGBUILD makes a kernel for the DockStar with aholler's LED patches.
pkgname=kernel26-dockstar
pkgver=2.6.34.2
pkgver=2.6.35.1
pkgrel=1
pkgdesc="The Linux Kernel and modules with DockStar LEDs"
arch=('arm')
@ -16,13 +16,11 @@ provides=('kernel26')
install=kernel26-dockstar.install
source=(http://www.kernel.org/pub/linux/kernel/v2.6/linux-$pkgver.tar.bz2
config-2.6.33-dockstar
0001-ARM-Add-option-CMDLINE_FORCE-to-force-usage-of-the-i.patch
0002-MTD-partitons-used-by-the-Seagate-FreeAgent-DockStar.patch
0003-LED-definitions-for-the-Seagate-FreeAgent-DockStar.patch
0004-Change-board-name-for-the-SheevaPlug-to-reflect-the-.patch)
md5sums=('bccca90a4bfd74b1335012e78d433cd5'
0001-MTD-partitons-used-by-the-Seagate-FreeAgent-DockStar.patch
0002-LED-definitions-for-the-Seagate-FreeAgent-DockStar.patch
0003-Change-board-name-for-the-SheevaPlug-to-reflect-the-.patch)
md5sums=('27b266dda534761fb027a6c47605b7e3'
'382c66de008d1bd1d97089b9ca049b6d'
'99f9eafc0b602483343c3c98f8828f79'
'0ed85186b0b5446c4afbbc45639a7466'
'e81eae381cc2c282d169c879cc4da54b'
'75287077b9a0105156977acb85d57546')
@ -35,21 +33,20 @@ build() {
cd linux/
# Apply Aholler's DockStar hardware patches
patch -p1 -i 0001-ARM-Add-option-CMDLINE_FORCE-to-force-usage-of-the-i.patch
patch -p1 -i 0002-MTD-partitons-used-by-the-Seagate-FreeAgent-DockStar.patch
patch -p1 -i 0003-LED-definitions-for-the-Seagate-FreeAgent-DockStar.patch
patch -p1 -i 0004-Change-board-name-for-the-SheevaPlug-to-reflect-the-.patch
patch -p1 -i 0001-MTD-partitons-used-by-the-Seagate-FreeAgent-DockStar.patch
patch -p1 -i 0002-LED-definitions-for-the-Seagate-FreeAgent-DockStar.patch
patch -p1 -i 0003-Change-board-name-for-the-SheevaPlug-to-reflect-the-.patch
# Prepare for make
mv config-2.6.33-dockstar .config
echo "Press ENTER 4973 times..."
echo "Press ENTER 4972 times..."
make oldconfig
# Use it to enable FUSE as a module
make menuconfig
# Make!
make clean modules uImage || return 1
make modules uImage || return 1
# Pack up the created uImage
mkdir -p $pkgdir/boot