mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
added extra/kdiff3
This commit is contained in:
parent
78dbacb44d
commit
a401e29845
2 changed files with 74 additions and 0 deletions
34
extra/kdiff3/0001-link-atomic.patch
Normal file
34
extra/kdiff3/0001-link-atomic.patch
Normal file
|
@ -0,0 +1,34 @@
|
|||
From 2ef432401be01de5ebb9e4545d497d2cacab9168 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 21 Aug 2018 06:51:04 -0600
|
||||
Subject: [PATCH] link atomic
|
||||
|
||||
---
|
||||
src/CMakeLists.txt | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
|
||||
index 4f9adab..8165292 100644
|
||||
--- a/src/CMakeLists.txt
|
||||
+++ b/src/CMakeLists.txt
|
||||
@@ -27,7 +27,7 @@ add_library(kdiff3part MODULE ${kdiff3part_PART_SRCS})
|
||||
|
||||
set_target_properties(kdiff3part PROPERTIES DEFINE_SYMBOL KDIFF3_PART)
|
||||
target_compile_features(kdiff3part PRIVATE ${needed_features})
|
||||
-target_link_libraries(kdiff3part ${KDiff3_LIBRARIES} KF5::Parts)
|
||||
+target_link_libraries(kdiff3part ${KDiff3_LIBRARIES} KF5::Parts atomic)
|
||||
|
||||
install(TARGETS kdiff3part DESTINATION ${KDE_INSTALL_PLUGINDIR}/kf5/parts )
|
||||
|
||||
@@ -42,7 +42,7 @@ set(kdiff3_SRCS
|
||||
|
||||
add_executable(kdiff3 ${kdiff3_SRCS})
|
||||
|
||||
-target_link_libraries(kdiff3 KF5::ConfigCore KF5::ConfigGui KF5::Parts ${KDiff3_LIBRARIES} )
|
||||
+target_link_libraries(kdiff3 KF5::ConfigCore KF5::ConfigGui KF5::Parts ${KDiff3_LIBRARIES} atomic)
|
||||
target_compile_features(kdiff3 PRIVATE ${needed_features})
|
||||
|
||||
install(TARGETS kdiff3 ${INSTALL_TARGETS_DEFAULT_ARGS})
|
||||
--
|
||||
2.18.0
|
||||
|
40
extra/kdiff3/PKGBUILD
Normal file
40
extra/kdiff3/PKGBUILD
Normal file
|
@ -0,0 +1,40 @@
|
|||
# Maintainer: Antonio Rojas <arojas@archlinux.org>
|
||||
# Maintainer: Eric Bélanger <eric@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to explicitly link v5/v6 with libatomic
|
||||
|
||||
pkgname=kdiff3
|
||||
pkgver=0.9.98.git20180821
|
||||
pkgrel=1
|
||||
_commit=6febacced6f69bfd9c1a77762d01ce975d1b6203
|
||||
pkgdesc="A KDE file comparator/merge tool"
|
||||
arch=(x86_64)
|
||||
url="https://kdiff3.sourceforge.net/"
|
||||
license=(GPL)
|
||||
depends=(kparts hicolor-icon-theme)
|
||||
makedepends=(extra-cmake-modules kdoctools git)
|
||||
source=(git://git.kde.org/kdiff3#commit=$_commit
|
||||
0001-link-atomic.patch)
|
||||
sha256sums=('SKIP'
|
||||
'2ace78e6fbc835e9192faefcbb651606ffe5a1e7d8fdfe620726f48117b7ab8e')
|
||||
|
||||
prepare() {
|
||||
mkdir -p build
|
||||
if [[ $CARCH == "armv6h" || $CARCH == "arm" ]]; then
|
||||
cd $pkgname
|
||||
patch -p1 -i ../0001-link-atomic.patch
|
||||
fi
|
||||
}
|
||||
|
||||
build() {
|
||||
cd build
|
||||
cmake ../$pkgname \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd build
|
||||
make DESTDIR="$pkgdir" install
|
||||
}
|
Loading…
Reference in a new issue