community/gitea to 1.11.4-2

This commit is contained in:
Kevin Mihelich 2020-04-02 22:02:15 +00:00
parent 619af3b7b5
commit a4391672bd
2 changed files with 14 additions and 3 deletions

View file

@ -8,7 +8,7 @@
pkgname=gitea
pkgver=1.11.4
pkgrel=1
pkgrel=2
pkgdesc="Painless self-hosted Git service. Community managed fork of Gogs."
arch=(x86_64)
url="https://gitea.io"
@ -35,7 +35,7 @@ sha256sums=('SKIP'
'1521fd7edc3830c695698ffe9835709f1408040b5ec989f07410972c894fa8ba'
'7789b3f6699b9e111fa080226047cdc765e55ff49a3f72aac989c11c06c3e7e0'
'2abc51ccd0086bb996194bb7fb241a3f26d84f518417c872b66a3db8970da7e4'
'9de4f1e85c1dabffaf79cf996dea0dc52e054f1f469883d950facb3ca97d4ee0')
'1fb97d8c77f5e66fcbe65b7e0c04e683adfb77ce89217cec16f2da998131b0f4')
validpgpkeys=(
8C4033A23895237CB27D52D9D9B5613BEB813F99 # Matti Ranta <matti@mdranta.net> old RSA2048, retrieved from https://github.com/techknowlogick.gpg
B56E3C7437A49E136862F5DE9D8A57ADAA232E95 # Matti Ranta <matti@mdranta.net> new RSA4096, retrieved from https://github.com/techknowlogick.gpg
@ -63,11 +63,13 @@ build() {
export GOGC=50
make generate
LDFLAGS="-linkmode external -extldflags \"${LDFLAGS}\" -X \"code.gitea.io/gitea/modules/setting.AppWorkPath=/var/lib/gitea/\""
make EXTRA_GOFLAGS="-trimpath" TAGS="bindata sqlite pam" build
make EXTRA_GOFLAGS="-trimpath" TAGS="sqlite pam" build
}
package() {
install -Dm755 ${pkgname}/${pkgname} -t "${pkgdir}"/usr/bin/
install -dm755 "${pkgdir}"/usr/share/${pkgname}
cp -dr --no-preserve=ownership ${pkgname}/{options,public,templates} "${pkgdir}"/usr/share/${pkgname}/
install -Dm644 ${pkgname}/LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}/
install -Dm644 ${pkgname}.service -t "${pkgdir}"/usr/lib/systemd/system/
install -Dm644 ${pkgname}.tmpfiles "${pkgdir}"/usr/lib/tmpfiles.d/${pkgname}.conf

View file

@ -16,6 +16,15 @@
SCRIPT_TYPE = bash
; Default ANSI charset
ANSI_CHARSET =
@@ -280,7 +280,7 @@ CERT_FILE = https/cert.pem
KEY_FILE = https/key.pem
; Root directory containing templates and static files.
; default is the path where Gitea is executed
-STATIC_ROOT_PATH =
+STATIC_ROOT_PATH = /usr/share/gitea
; Default path for App data
APP_DATA_PATH = data
; Application level GZIP support
@@ -342,7 +342,7 @@ SQLITE_TIMEOUT = 500
; For iterate buffer, default is 50
ITERATE_BUFFER_SIZE = 50