mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/ncmpcpp to 0.8.2-13
This commit is contained in:
parent
4b4de53ef0
commit
a471b5ab6f
2 changed files with 35 additions and 3 deletions
|
@ -9,18 +9,24 @@
|
|||
|
||||
pkgname=ncmpcpp
|
||||
pkgver=0.8.2
|
||||
pkgrel=12
|
||||
pkgrel=13
|
||||
pkgdesc='Almost exact clone of ncmpc with some new features'
|
||||
url='https://ncmpcpp.rybczak.net/'
|
||||
arch=('x86_64')
|
||||
license=('GPL')
|
||||
depends=('curl' 'libmpdclient' 'taglib' 'ncurses' 'fftw' 'boost-libs')
|
||||
makedepends=('boost')
|
||||
source=(${pkgname}-${pkgver}.tar.bz2::https://rybczak.net/ncmpcpp/stable/${pkgname}-${pkgver}.tar.bz2)
|
||||
sha512sums=('9384edd162f40af23e4f26f437356520f117e4e2ab513ed3de132d2f11e597082d1cb7f0dd3696660d0c9bb85ad03e31fb921c97a11c7b28b32c5907fdbb8e8f')
|
||||
source=(${pkgname}-${pkgver}.tar.bz2::https://rybczak.net/ncmpcpp/stable/${pkgname}-${pkgver}.tar.bz2
|
||||
gcc10.patch)
|
||||
sha512sums=('9384edd162f40af23e4f26f437356520f117e4e2ab513ed3de132d2f11e597082d1cb7f0dd3696660d0c9bb85ad03e31fb921c97a11c7b28b32c5907fdbb8e8f'
|
||||
'99298d813391c03fc70ab16ffe8dd57c6151b87f4cd84f25a1747691d8f9f41e5f647b59c0d2ca25808acb995c7df6c99f386a4cc1f3f133b722731ef99a8a3b')
|
||||
|
||||
prepare() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
|
||||
# https://github.com/ncmpcpp/ncmpcpp/pull/385
|
||||
patch -Np1 -i ../gcc10.patch
|
||||
|
||||
sed -i 's/-march=native//' extras/Makefile
|
||||
}
|
||||
|
||||
|
|
26
community/ncmpcpp/gcc10.patch
Normal file
26
community/ncmpcpp/gcc10.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
From 399e0f47008b487df3505476c959b4f42d8bc1b1 Mon Sep 17 00:00:00 2001
|
||||
From: Louis Sautier <sautier.louis@gmail.com>
|
||||
Date: Sat, 9 May 2020 14:31:52 +0200
|
||||
Subject: [PATCH] Fix build with GCC 10 by adding missing include
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Fixes the following error:
|
||||
./mpdpp.h:438:15: error: ‘runtime_error’ is not a member of ‘std’
|
||||
---
|
||||
src/mpdpp.h | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/mpdpp.h b/src/mpdpp.h
|
||||
index a2bb79eb..abd3666c 100644
|
||||
--- a/src/mpdpp.h
|
||||
+++ b/src/mpdpp.h
|
||||
@@ -25,6 +25,7 @@
|
||||
#include <exception>
|
||||
#include <random>
|
||||
#include <set>
|
||||
+#include <stdexcept>
|
||||
#include <vector>
|
||||
|
||||
#include <mpd/client.h>
|
Loading…
Reference in a new issue