mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/linux-aarch64-rc to 4.10.rc1-1
This commit is contained in:
parent
fc3c7b38f3
commit
a48996ef45
5 changed files with 497 additions and 120 deletions
|
@ -1,4 +1,4 @@
|
||||||
From 3bd7f7f2f62da582ee1e3908648387710b973f32 Mon Sep 17 00:00:00 2001
|
From 8b8f42a28d472578364e003ad6bb25aa6d027c35 Mon Sep 17 00:00:00 2001
|
||||||
From: popcornmix <popcornmix@gmail.com>
|
From: popcornmix <popcornmix@gmail.com>
|
||||||
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
||||||
Subject: [PATCH 1/2] net/smsc95xx: Allow mac address to be set as a parameter
|
Subject: [PATCH 1/2] net/smsc95xx: Allow mac address to be set as a parameter
|
||||||
|
@ -8,7 +8,7 @@ Subject: [PATCH 1/2] net/smsc95xx: Allow mac address to be set as a parameter
|
||||||
1 file changed, 56 insertions(+)
|
1 file changed, 56 insertions(+)
|
||||||
|
|
||||||
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
|
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
|
||||||
index 831aa33..0362554 100644
|
index 831aa33d078a..03625547d794 100644
|
||||||
--- a/drivers/net/usb/smsc95xx.c
|
--- a/drivers/net/usb/smsc95xx.c
|
||||||
+++ b/drivers/net/usb/smsc95xx.c
|
+++ b/drivers/net/usb/smsc95xx.c
|
||||||
@@ -60,6 +60,7 @@
|
@@ -60,6 +60,7 @@
|
||||||
|
@ -91,5 +91,5 @@ index 831aa33..0362554 100644
|
||||||
|
|
||||||
/* maybe the boot loader passed the MAC address in devicetree */
|
/* maybe the boot loader passed the MAC address in devicetree */
|
||||||
--
|
--
|
||||||
2.10.0
|
2.11.0
|
||||||
|
|
||||||
|
|
|
@ -0,0 +1,267 @@
|
||||||
|
From 3af195918143906fd262059302139d59cf4a0a70 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Al Viro <viro@zeniv.linux.org.uk>
|
||||||
|
Date: Mon, 26 Dec 2016 04:10:19 -0500
|
||||||
|
Subject: [PATCH 2/2] arm64: don't pull uaccess.h into *.S
|
||||||
|
|
||||||
|
Split asm-only parts of arm64 uaccess.h into a new header and use that
|
||||||
|
from *.S.
|
||||||
|
|
||||||
|
Signed-off-by: Al Viro <viro@zeniv.linux.org.uk>
|
||||||
|
---
|
||||||
|
arch/arm64/include/asm/asm-uaccess.h | 65 ++++++++++++++++++++++++++++++++++++
|
||||||
|
arch/arm64/include/asm/uaccess.h | 64 -----------------------------------
|
||||||
|
arch/arm64/kernel/entry.S | 2 +-
|
||||||
|
arch/arm64/lib/clear_user.S | 2 +-
|
||||||
|
arch/arm64/lib/copy_from_user.S | 2 +-
|
||||||
|
arch/arm64/lib/copy_in_user.S | 2 +-
|
||||||
|
arch/arm64/lib/copy_to_user.S | 2 +-
|
||||||
|
arch/arm64/mm/cache.S | 2 +-
|
||||||
|
arch/arm64/xen/hypercall.S | 2 +-
|
||||||
|
9 files changed, 72 insertions(+), 71 deletions(-)
|
||||||
|
create mode 100644 arch/arm64/include/asm/asm-uaccess.h
|
||||||
|
|
||||||
|
diff --git a/arch/arm64/include/asm/asm-uaccess.h b/arch/arm64/include/asm/asm-uaccess.h
|
||||||
|
new file mode 100644
|
||||||
|
index 000000000000..df411f3e083c
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/arch/arm64/include/asm/asm-uaccess.h
|
||||||
|
@@ -0,0 +1,65 @@
|
||||||
|
+#ifndef __ASM_ASM_UACCESS_H
|
||||||
|
+#define __ASM_ASM_UACCESS_H
|
||||||
|
+
|
||||||
|
+#include <asm/alternative.h>
|
||||||
|
+#include <asm/kernel-pgtable.h>
|
||||||
|
+#include <asm/sysreg.h>
|
||||||
|
+#include <asm/assembler.h>
|
||||||
|
+
|
||||||
|
+/*
|
||||||
|
+ * User access enabling/disabling macros.
|
||||||
|
+ */
|
||||||
|
+#ifdef CONFIG_ARM64_SW_TTBR0_PAN
|
||||||
|
+ .macro __uaccess_ttbr0_disable, tmp1
|
||||||
|
+ mrs \tmp1, ttbr1_el1 // swapper_pg_dir
|
||||||
|
+ add \tmp1, \tmp1, #SWAPPER_DIR_SIZE // reserved_ttbr0 at the end of swapper_pg_dir
|
||||||
|
+ msr ttbr0_el1, \tmp1 // set reserved TTBR0_EL1
|
||||||
|
+ isb
|
||||||
|
+ .endm
|
||||||
|
+
|
||||||
|
+ .macro __uaccess_ttbr0_enable, tmp1
|
||||||
|
+ get_thread_info \tmp1
|
||||||
|
+ ldr \tmp1, [\tmp1, #TSK_TI_TTBR0] // load saved TTBR0_EL1
|
||||||
|
+ msr ttbr0_el1, \tmp1 // set the non-PAN TTBR0_EL1
|
||||||
|
+ isb
|
||||||
|
+ .endm
|
||||||
|
+
|
||||||
|
+ .macro uaccess_ttbr0_disable, tmp1
|
||||||
|
+alternative_if_not ARM64_HAS_PAN
|
||||||
|
+ __uaccess_ttbr0_disable \tmp1
|
||||||
|
+alternative_else_nop_endif
|
||||||
|
+ .endm
|
||||||
|
+
|
||||||
|
+ .macro uaccess_ttbr0_enable, tmp1, tmp2
|
||||||
|
+alternative_if_not ARM64_HAS_PAN
|
||||||
|
+ save_and_disable_irq \tmp2 // avoid preemption
|
||||||
|
+ __uaccess_ttbr0_enable \tmp1
|
||||||
|
+ restore_irq \tmp2
|
||||||
|
+alternative_else_nop_endif
|
||||||
|
+ .endm
|
||||||
|
+#else
|
||||||
|
+ .macro uaccess_ttbr0_disable, tmp1
|
||||||
|
+ .endm
|
||||||
|
+
|
||||||
|
+ .macro uaccess_ttbr0_enable, tmp1, tmp2
|
||||||
|
+ .endm
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
+/*
|
||||||
|
+ * These macros are no-ops when UAO is present.
|
||||||
|
+ */
|
||||||
|
+ .macro uaccess_disable_not_uao, tmp1
|
||||||
|
+ uaccess_ttbr0_disable \tmp1
|
||||||
|
+alternative_if ARM64_ALT_PAN_NOT_UAO
|
||||||
|
+ SET_PSTATE_PAN(1)
|
||||||
|
+alternative_else_nop_endif
|
||||||
|
+ .endm
|
||||||
|
+
|
||||||
|
+ .macro uaccess_enable_not_uao, tmp1, tmp2
|
||||||
|
+ uaccess_ttbr0_enable \tmp1, \tmp2
|
||||||
|
+alternative_if ARM64_ALT_PAN_NOT_UAO
|
||||||
|
+ SET_PSTATE_PAN(0)
|
||||||
|
+alternative_else_nop_endif
|
||||||
|
+ .endm
|
||||||
|
+
|
||||||
|
+#endif
|
||||||
|
diff --git a/arch/arm64/include/asm/uaccess.h b/arch/arm64/include/asm/uaccess.h
|
||||||
|
index d26750ca6e06..46da3ea638bb 100644
|
||||||
|
--- a/arch/arm64/include/asm/uaccess.h
|
||||||
|
+++ b/arch/arm64/include/asm/uaccess.h
|
||||||
|
@@ -22,8 +22,6 @@
|
||||||
|
#include <asm/kernel-pgtable.h>
|
||||||
|
#include <asm/sysreg.h>
|
||||||
|
|
||||||
|
-#ifndef __ASSEMBLY__
|
||||||
|
-
|
||||||
|
/*
|
||||||
|
* User space memory access functions
|
||||||
|
*/
|
||||||
|
@@ -424,66 +422,4 @@ extern long strncpy_from_user(char *dest, const char __user *src, long count);
|
||||||
|
extern __must_check long strlen_user(const char __user *str);
|
||||||
|
extern __must_check long strnlen_user(const char __user *str, long n);
|
||||||
|
|
||||||
|
-#else /* __ASSEMBLY__ */
|
||||||
|
-
|
||||||
|
-#include <asm/assembler.h>
|
||||||
|
-
|
||||||
|
-/*
|
||||||
|
- * User access enabling/disabling macros.
|
||||||
|
- */
|
||||||
|
-#ifdef CONFIG_ARM64_SW_TTBR0_PAN
|
||||||
|
- .macro __uaccess_ttbr0_disable, tmp1
|
||||||
|
- mrs \tmp1, ttbr1_el1 // swapper_pg_dir
|
||||||
|
- add \tmp1, \tmp1, #SWAPPER_DIR_SIZE // reserved_ttbr0 at the end of swapper_pg_dir
|
||||||
|
- msr ttbr0_el1, \tmp1 // set reserved TTBR0_EL1
|
||||||
|
- isb
|
||||||
|
- .endm
|
||||||
|
-
|
||||||
|
- .macro __uaccess_ttbr0_enable, tmp1
|
||||||
|
- get_thread_info \tmp1
|
||||||
|
- ldr \tmp1, [\tmp1, #TSK_TI_TTBR0] // load saved TTBR0_EL1
|
||||||
|
- msr ttbr0_el1, \tmp1 // set the non-PAN TTBR0_EL1
|
||||||
|
- isb
|
||||||
|
- .endm
|
||||||
|
-
|
||||||
|
- .macro uaccess_ttbr0_disable, tmp1
|
||||||
|
-alternative_if_not ARM64_HAS_PAN
|
||||||
|
- __uaccess_ttbr0_disable \tmp1
|
||||||
|
-alternative_else_nop_endif
|
||||||
|
- .endm
|
||||||
|
-
|
||||||
|
- .macro uaccess_ttbr0_enable, tmp1, tmp2
|
||||||
|
-alternative_if_not ARM64_HAS_PAN
|
||||||
|
- save_and_disable_irq \tmp2 // avoid preemption
|
||||||
|
- __uaccess_ttbr0_enable \tmp1
|
||||||
|
- restore_irq \tmp2
|
||||||
|
-alternative_else_nop_endif
|
||||||
|
- .endm
|
||||||
|
-#else
|
||||||
|
- .macro uaccess_ttbr0_disable, tmp1
|
||||||
|
- .endm
|
||||||
|
-
|
||||||
|
- .macro uaccess_ttbr0_enable, tmp1, tmp2
|
||||||
|
- .endm
|
||||||
|
-#endif
|
||||||
|
-
|
||||||
|
-/*
|
||||||
|
- * These macros are no-ops when UAO is present.
|
||||||
|
- */
|
||||||
|
- .macro uaccess_disable_not_uao, tmp1
|
||||||
|
- uaccess_ttbr0_disable \tmp1
|
||||||
|
-alternative_if ARM64_ALT_PAN_NOT_UAO
|
||||||
|
- SET_PSTATE_PAN(1)
|
||||||
|
-alternative_else_nop_endif
|
||||||
|
- .endm
|
||||||
|
-
|
||||||
|
- .macro uaccess_enable_not_uao, tmp1, tmp2
|
||||||
|
- uaccess_ttbr0_enable \tmp1, \tmp2
|
||||||
|
-alternative_if ARM64_ALT_PAN_NOT_UAO
|
||||||
|
- SET_PSTATE_PAN(0)
|
||||||
|
-alternative_else_nop_endif
|
||||||
|
- .endm
|
||||||
|
-
|
||||||
|
-#endif /* __ASSEMBLY__ */
|
||||||
|
-
|
||||||
|
#endif /* __ASM_UACCESS_H */
|
||||||
|
diff --git a/arch/arm64/kernel/entry.S b/arch/arm64/kernel/entry.S
|
||||||
|
index a7504f40d7ee..923841ffe4a9 100644
|
||||||
|
--- a/arch/arm64/kernel/entry.S
|
||||||
|
+++ b/arch/arm64/kernel/entry.S
|
||||||
|
@@ -31,7 +31,7 @@
|
||||||
|
#include <asm/memory.h>
|
||||||
|
#include <asm/ptrace.h>
|
||||||
|
#include <asm/thread_info.h>
|
||||||
|
-#include <linux/uaccess.h>
|
||||||
|
+#include <asm/asm-uaccess.h>
|
||||||
|
#include <asm/unistd.h>
|
||||||
|
|
||||||
|
/*
|
||||||
|
diff --git a/arch/arm64/lib/clear_user.S b/arch/arm64/lib/clear_user.S
|
||||||
|
index add4a1334085..e88fb99c1561 100644
|
||||||
|
--- a/arch/arm64/lib/clear_user.S
|
||||||
|
+++ b/arch/arm64/lib/clear_user.S
|
||||||
|
@@ -17,7 +17,7 @@
|
||||||
|
*/
|
||||||
|
#include <linux/linkage.h>
|
||||||
|
|
||||||
|
-#include <linux/uaccess.h>
|
||||||
|
+#include <asm/asm-uaccess.h>
|
||||||
|
|
||||||
|
.text
|
||||||
|
|
||||||
|
diff --git a/arch/arm64/lib/copy_from_user.S b/arch/arm64/lib/copy_from_user.S
|
||||||
|
index fd6cd05593f9..4b5d826895ff 100644
|
||||||
|
--- a/arch/arm64/lib/copy_from_user.S
|
||||||
|
+++ b/arch/arm64/lib/copy_from_user.S
|
||||||
|
@@ -17,7 +17,7 @@
|
||||||
|
#include <linux/linkage.h>
|
||||||
|
|
||||||
|
#include <asm/cache.h>
|
||||||
|
-#include <linux/uaccess.h>
|
||||||
|
+#include <asm/asm-uaccess.h>
|
||||||
|
|
||||||
|
/*
|
||||||
|
* Copy from user space to a kernel buffer (alignment handled by the hardware)
|
||||||
|
diff --git a/arch/arm64/lib/copy_in_user.S b/arch/arm64/lib/copy_in_user.S
|
||||||
|
index d828540ded6f..47184c3a97da 100644
|
||||||
|
--- a/arch/arm64/lib/copy_in_user.S
|
||||||
|
+++ b/arch/arm64/lib/copy_in_user.S
|
||||||
|
@@ -19,7 +19,7 @@
|
||||||
|
#include <linux/linkage.h>
|
||||||
|
|
||||||
|
#include <asm/cache.h>
|
||||||
|
-#include <linux/uaccess.h>
|
||||||
|
+#include <asm/asm-uaccess.h>
|
||||||
|
|
||||||
|
/*
|
||||||
|
* Copy from user space to user space (alignment handled by the hardware)
|
||||||
|
diff --git a/arch/arm64/lib/copy_to_user.S b/arch/arm64/lib/copy_to_user.S
|
||||||
|
index 3e6ae2663b82..351f0766f7a6 100644
|
||||||
|
--- a/arch/arm64/lib/copy_to_user.S
|
||||||
|
+++ b/arch/arm64/lib/copy_to_user.S
|
||||||
|
@@ -17,7 +17,7 @@
|
||||||
|
#include <linux/linkage.h>
|
||||||
|
|
||||||
|
#include <asm/cache.h>
|
||||||
|
-#include <linux/uaccess.h>
|
||||||
|
+#include <asm/asm-uaccess.h>
|
||||||
|
|
||||||
|
/*
|
||||||
|
* Copy to user space from a kernel buffer (alignment handled by the hardware)
|
||||||
|
diff --git a/arch/arm64/mm/cache.S b/arch/arm64/mm/cache.S
|
||||||
|
index 17f422a4dc55..83c27b6e6dca 100644
|
||||||
|
--- a/arch/arm64/mm/cache.S
|
||||||
|
+++ b/arch/arm64/mm/cache.S
|
||||||
|
@@ -23,7 +23,7 @@
|
||||||
|
#include <asm/assembler.h>
|
||||||
|
#include <asm/cpufeature.h>
|
||||||
|
#include <asm/alternative.h>
|
||||||
|
-#include <linux/uaccess.h>
|
||||||
|
+#include <asm/asm-uaccess.h>
|
||||||
|
|
||||||
|
/*
|
||||||
|
* flush_icache_range(start,end)
|
||||||
|
diff --git a/arch/arm64/xen/hypercall.S b/arch/arm64/xen/hypercall.S
|
||||||
|
index 47cf3f9d89ff..947830a459d2 100644
|
||||||
|
--- a/arch/arm64/xen/hypercall.S
|
||||||
|
+++ b/arch/arm64/xen/hypercall.S
|
||||||
|
@@ -49,7 +49,7 @@
|
||||||
|
|
||||||
|
#include <linux/linkage.h>
|
||||||
|
#include <asm/assembler.h>
|
||||||
|
-#include <linux/uaccess.h>
|
||||||
|
+#include <asm/asm-uaccess.h>
|
||||||
|
#include <xen/interface/xen.h>
|
||||||
|
|
||||||
|
|
||||||
|
--
|
||||||
|
2.11.0
|
||||||
|
|
|
@ -1,34 +0,0 @@
|
||||||
From 795af7a613e7aa678d1b6cab0cb40d6e46f06798 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Srinivas Kandagatla <srinivas.kandagatla@linaro.org>
|
|
||||||
Date: Mon, 4 Jul 2016 10:21:48 +0100
|
|
||||||
Subject: [PATCH 2/2] sound: lpass-cpu: add module licence and description
|
|
||||||
|
|
||||||
This patch adds module licence to lpass-cpu driver, without this
|
|
||||||
patch lpass-cpu module would taint with below error:
|
|
||||||
|
|
||||||
snd_soc_lpass_cpu: module license 'unspecified' taints kernel.
|
|
||||||
Disabling lock debugging due to kernel taint
|
|
||||||
snd_soc_lpass_cpu: Unknown symbol regmap_write (err 0)
|
|
||||||
snd_soc_lpass_cpu: Unknown symbol devm_kmalloc (err 0)
|
|
||||||
...
|
|
||||||
|
|
||||||
Acked-by: Kenneth Westfield <kwestfie@codeaurora.org>
|
|
||||||
Signed-off-by: Srinivas Kandagatla <srinivas.kandagatla@linaro.org>
|
|
||||||
---
|
|
||||||
sound/soc/qcom/lpass-cpu.c | 3 +++
|
|
||||||
1 file changed, 3 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/sound/soc/qcom/lpass-cpu.c b/sound/soc/qcom/lpass-cpu.c
|
|
||||||
index 3cde9fb..eff3f9a 100644
|
|
||||||
--- a/sound/soc/qcom/lpass-cpu.c
|
|
||||||
+++ b/sound/soc/qcom/lpass-cpu.c
|
|
||||||
@@ -586,3 +586,6 @@ int asoc_qcom_lpass_cpu_platform_remove(struct platform_device *pdev)
|
|
||||||
return 0;
|
|
||||||
}
|
|
||||||
EXPORT_SYMBOL_GPL(asoc_qcom_lpass_cpu_platform_remove);
|
|
||||||
+
|
|
||||||
+MODULE_DESCRIPTION("QTi LPASS CPU Driver");
|
|
||||||
+MODULE_LICENSE("GPL v2");
|
|
||||||
--
|
|
||||||
2.10.0
|
|
||||||
|
|
|
@ -3,11 +3,10 @@
|
||||||
|
|
||||||
buildarch=8
|
buildarch=8
|
||||||
|
|
||||||
_rcver=4.9
|
_rcver=4.10
|
||||||
_rcrel=8
|
_rcrel=1
|
||||||
|
|
||||||
pkgbase=linux-aarch64-rc
|
pkgbase=linux-aarch64-rc
|
||||||
#_srcname=linux-4.$((${_rcver##*.}-1))
|
|
||||||
_srcname=linux-${_rcver}-rc${_rcrel}
|
_srcname=linux-${_rcver}-rc${_rcrel}
|
||||||
_kernelname=${pkgbase#linux}
|
_kernelname=${pkgbase#linux}
|
||||||
_desc="AArch64 multi-platform (release candidate)"
|
_desc="AArch64 multi-platform (release candidate)"
|
||||||
|
@ -18,25 +17,23 @@ url="http://www.kernel.org/"
|
||||||
license=('GPL2')
|
license=('GPL2')
|
||||||
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
|
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
|
||||||
options=('!strip')
|
options=('!strip')
|
||||||
source=(#"http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
|
source=("https://www.kernel.org/pub/linux/kernel/v4.x/testing/${_srcname}.tar.xz"
|
||||||
#"https://www.kernel.org/pub/linux/kernel/v4.x/testing/patch-${_rcver}-rc${_rcrel}.xz"
|
|
||||||
"https://www.kernel.org/pub/linux/kernel/v4.x/testing/${_srcname}.tar.xz"
|
|
||||||
'0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
|
'0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
|
||||||
|
'0002-arm64-don-t-pull-uaccess.h-into-.S.patch'
|
||||||
'config'
|
'config'
|
||||||
'linux.preset')
|
'linux.preset')
|
||||||
md5sums=('f8ab74a9a1a2adf30ddadbcf14ef7c8a'
|
md5sums=('f1969e506627fcd7d2e009576b1f30f0'
|
||||||
'07fc22563ada626fad44e924568c21e3'
|
'8d1078180e5fbe4716c9dac2633ec6ca'
|
||||||
'e6c5cacf8e62a9f022d030e8909a7814'
|
'27c05cc3320044ef8d7bed45adae6fd3'
|
||||||
|
'd04a87d353c5c276c639fd81ef3138a4'
|
||||||
'25d8f6983c9a616946848c0e075a949c')
|
'25d8f6983c9a616946848c0e075a949c')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd "${srcdir}/${_srcname}"
|
cd "${srcdir}/${_srcname}"
|
||||||
|
|
||||||
# add upstream patch
|
|
||||||
#patch -sp1 -i ../patch-${_rcver}-rc${_rcrel}
|
|
||||||
|
|
||||||
# ALARM patches
|
# ALARM patches
|
||||||
git apply ../0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
|
git apply ../0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
|
||||||
|
git apply ../0002-arm64-don-t-pull-uaccess.h-into-.S.patch
|
||||||
|
|
||||||
cat "${srcdir}/config" > ./.config
|
cat "${srcdir}/config" > ./.config
|
||||||
|
|
||||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue