removed community/agave

This commit is contained in:
Kevin Mihelich 2019-03-28 18:12:50 +00:00
parent c7ad86a6e6
commit a51f9258e7
6 changed files with 0 additions and 434 deletions

View file

@ -1,63 +0,0 @@
# $Id$
# Maintainer: Balló György <ballogyor+arch at gmail dot com>
# Contributor: Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
# Contributor: Roman Kyrylych <Roman.Kyrylych@gmail.com>
# Contributor: William Rea <sillywilly@gmail.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - compat-round.patch from debian to fix aarch64 FTBFS
pkgname=agave
pkgver=0.4.7
pkgrel=10
pkgdesc="Colorscheme designer tool for GNOME"
arch=('x86_64')
url="https://web.archive.org/web/20170327063642/http://home.gna.org/colorscheme/"
license=('GPL')
depends=('libglademm')
makedepends=('gnome-doc-utils' 'intltool' 'boost')
source=(http://ftp.debian.org/debian/pool/main/a/$pkgname/${pkgname}_$pkgver.orig.tar.gz
agave-0.4.7-mdv-fix-str-fmt.patch
schemebox.patch
drop-libgnome.patch
fix-build-without-gconf.patch
compat-round.patch)
sha256sums=('4005361ab1b137029c7d50afbbfbae7d83bdde7cec3e155a85eed59f6ec4e6fc'
'132008f0bbe040c59bbc134d9ca3eb244967a66f95bf113d94e976b8ed776c6c'
'0471ac9d7057f83d3fc667d7387837a2d85cb0d15a58853dd673a6ea1459623c'
'8651250047b5882b00d28ac6d7ff587f53f99bd681c201545b6cf25c5acaaac6'
'225f9a5cfebea4f9c1d4120611394eb148ffb9a6c151e79f749df1749e015c91'
'1cade4acc25b4da1999d6eb148e2f48ac3d6633fe4e695a6a1fc217d7c477a78')
prepare() {
cd $pkgname-$pkgver
# Build fix from Fedora
patch -Np1 -i ../agave-0.4.7-mdv-fix-str-fmt.patch
# Another build fix
patch -Np1 -i ../schemebox.patch
# Remove deprecated libgnome dependency
patch -Np1 -i ../drop-libgnome.patch
# Fix build without gconfmm installed
patch -Np1 -i ../fix-build-without-gconf.patch
# Build fix from Debian
patch -Np1 -i ../compat-round.patch
}
build() {
cd $pkgname-$pkgver
CXXFLAGS+=' -std=c++11'
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
--disable-scrollkeeper --disable-gnome --disable-gconf
make
}
package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install
rm "$pkgdir/agave.schemas"
}

View file

@ -1,12 +0,0 @@
diff -p -up agave-0.4.7/src/dialogs/gcs-about-window.cc.strfmt agave-0.4.7/src/dialogs/gcs-about-window.cc
--- agave-0.4.7/src/dialogs/gcs-about-window.cc.strfmt 2009-11-25 15:00:03.000000000 +0100
+++ agave-0.4.7/src/dialogs/gcs-about-window.cc 2009-11-25 15:31:43.000000000 +0100
@@ -105,7 +105,7 @@ namespace gcs
catch (const Glib::Error& e)
{
Glib::ustring message = "Couldn't load Agave logo image from theme. " + e.what();
- g_warning(message.c_str());
+ g_warning("%s", message.c_str());
}
}
}

View file

@ -1,227 +0,0 @@
Description: Patched compat-round.cc to be more portable on systems with GNU libc
Author: Torsten Werner <twerner@debian.org>
Date: Thu, 5 Oct 2006 23:52:57 +0200
Index: agave-0.4.5/src/core/compat-round.cc
===================================================================
--- agave-0.4.5.orig/src/core/compat-round.cc 2006-10-01 03:25:58.000000000 +0530
+++ agave-0.4.5/src/core/compat-round.cc 2008-02-15 19:34:10.000000000 +0530
@@ -34,206 +34,9 @@
* THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
*/
-#include <math.h>
-
-/* Symbolic constants to classify floating point numbers. */
-#define COMPAT_FP_INFINITE 0x01
-#define COMPAT_FP_NAN 0x02
-#define COMPAT_FP_NORMAL 0x04
-#define COMPAT_FP_SUBNORMAL 0x08
-#define COMPAT_FP_ZERO 0x10
-
-#ifdef Linux
-#include <endian.h>
-#elif defined(__FreeBSD__)
-#include <machine/endian.h>
-#endif
-#define compat_fpclassify(x) \
- ((sizeof (x) == sizeof (float)) ? compat___fpclassifyf(x) \
- : (sizeof (x) == sizeof (double)) ? compat___fpclassifyd(x) \
- : compat___fpclassifyl(x))
-
-union compat_IEEEf2bits {
- float f;
- struct {
-#if _BYTE_ORDER == _LITTLE_ENDIAN
- unsigned int man :23;
- unsigned int exp :8;
- unsigned int sign :1;
-#else /* _BIG_ENDIAN */
- unsigned int sign :1;
- unsigned int exp :8;
- unsigned int man :23;
-#endif
- } bits;
-};
-
-union compat_IEEEd2bits {
- double d;
- struct {
-#if _BYTE_ORDER == _LITTLE_ENDIAN
- unsigned int manl :32;
- unsigned int manh :20;
- unsigned int exp :11;
- unsigned int sign :1;
-#else /* _BIG_ENDIAN */
- unsigned int sign :1;
- unsigned int exp :11;
- unsigned int manh :20;
- unsigned int manl :32;
-#endif
- } bits;
-};
-
-#ifdef __alpha__
-union compat_IEEEl2bits {
- long double e;
- struct {
- unsigned int manl :32;
- unsigned int manh :20;
- unsigned int exp :11;
- unsigned int sign :1;
- } bits;
-};
-#define compat_mask_nbit_l(u) ((void)0)
-#elif __amd64__
-union compat_IEEEl2bits {
- long double e;
- struct {
- unsigned int manl :32;
- unsigned int manh :32;
- unsigned int exp :15;
- unsigned int sign :1;
- unsigned int junkl :16;
- unsigned int junkh :32;
- } bits;
-};
-#define compat_mask_nbit_l(u) ((u).bits.manh &= 0x7fffffff)
-#elif __arm__
-union compat_IEEEl2bits {
- long double e;
- struct {
- unsigned int manl :32;
- unsigned int manh :32;
- unsigned int exp :15;
- unsigned int sign :1;
- unsigned int junk :16;
- } bits;
-};
-#define compat_mask_nbit_l(u) ((u).bits.manh &= 0x7fffffff)
-#elif __i386__
-union compat_IEEEl2bits {
- long double e;
- struct {
- unsigned int manl :32;
- unsigned int manh :32;
- unsigned int exp :15;
- unsigned int sign :1;
- unsigned int junk :16;
- } bits;
-};
-#define compat_mask_nbit_l(u) ((u).bits.manh &= 0x7fffffff)
-#elif __ia64__
-union compat_IEEEl2bits {
- long double e;
- struct {
-#if _BYTE_ORDER == _LITTLE_ENDIAN
- unsigned int manl :32;
- unsigned int manh :32;
- unsigned int exp :15;
- unsigned int sign :1;
- unsigned long junk :48;
-#else /* _BIG_ENDIAN */
- unsigned long junk :48;
- unsigned int sign :1;
- unsigned int exp :15;
- unsigned int manh :32;
- unsigned int manl :32;
-#endif
- } bits;
-};
-#define compat_mask_nbit_l(u) ((u).bits.manh &= 0x7fffffff)
-#elif __powerpc__
-union compat_IEEEl2bits {
- long double e;
- struct {
- unsigned int sign :1;
- unsigned int exp :15;
- unsigned long long manh :48;
- unsigned long long manl :64;
- } bits;
-};
-#define compat_mask_nbit_l(u) ((void)0)
-#elif __sparc64__
-union compat_IEEEl2bits {
- long double e;
- struct {
- unsigned int sign :1;
- unsigned int exp :15;
- unsigned long manh :48;
- unsigned long manl :64;
- } bits;
-};
-#define compat_mask_nbit_l(u) ((void)0)
-#endif
-
- static int
-compat___fpclassifyf(float f)
-{
- union compat_IEEEf2bits u;
-
- u.f = f;
- if (u.bits.exp == 0) {
- if (u.bits.man == 0)
- return (COMPAT_FP_ZERO);
- return (COMPAT_FP_SUBNORMAL);
- }
- if (u.bits.exp == 255) {
- if (u.bits.man == 0)
- return (COMPAT_FP_INFINITE);
- return (COMPAT_FP_NAN);
- }
- return (COMPAT_FP_NORMAL);
-}
+/* modified by Torsten Werner <twerner@debian.org> for GNU libc */
- static int
-compat___fpclassifyd(double d)
-{
- union compat_IEEEd2bits u;
-
- u.d = d;
- if (u.bits.exp == 0) {
- if ((u.bits.manl | u.bits.manh) == 0)
- return (COMPAT_FP_ZERO);
- return (COMPAT_FP_SUBNORMAL);
- }
- if (u.bits.exp == 2047) {
- if ((u.bits.manl | u.bits.manh) == 0)
- return (COMPAT_FP_INFINITE);
- return (COMPAT_FP_NAN);
- }
- return (COMPAT_FP_NORMAL);
-}
-
- static int
-compat___fpclassifyl(long double e)
-{
- union compat_IEEEl2bits u;
-
- u.e = e;
- if (u.bits.exp == 0) {
- if ((u.bits.manl | u.bits.manh) == 0)
- return (COMPAT_FP_ZERO);
- return (COMPAT_FP_SUBNORMAL);
- }
- compat_mask_nbit_l(u); /* Mask normalization bit if applicable. */
- if (u.bits.exp == 32767) {
- if ((u.bits.manl | u.bits.manh) == 0)
- return (COMPAT_FP_INFINITE);
- return (COMPAT_FP_NAN);
- }
- return (COMPAT_FP_NORMAL);
-}
+#include <math.h>
double
compat_round(double x)
@@ -241,8 +44,8 @@
double t;
int i;
- i = compat_fpclassify(x);
- if (i == COMPAT_FP_INFINITE || i == COMPAT_FP_NAN)
+ i = fpclassify(x);
+ if (i == FP_INFINITE || i == FP_NAN)
return (x);
if (x >= 0.0) {

View file

@ -1,66 +0,0 @@
diff -Naur agave-0.4.4.orig/src/dialogs/gcs-about-window.cc agave-0.4.4/src/dialogs/gcs-about-window.cc
--- agave-0.4.4.orig/src/dialogs/gcs-about-window.cc 2007-11-02 04:16:16.000000000 +0100
+++ agave-0.4.4/src/dialogs/gcs-about-window.cc 2012-03-20 22:01:55.835021376 +0100
@@ -26,9 +26,6 @@
#include <cstring> // for strlen()
#include <config.h>
-#ifdef HAVE_GNOME
-#include <libgnome/gnome-url.h>
-#endif // HAVE_GNOME
#include <gtkmm/icontheme.h>
@@ -46,11 +43,8 @@
{
set_name(PACKAGE_NAME);
-#ifdef HAVE_GNOME
- set_url_hook(sigc::mem_fun(*this, &AboutWindow::on_link_clicked));
set_website(PACKAGE_WEBSITE);
set_website_label(_("Project Website"));
-#endif // HAVE_GNOME
Glib::ustring version(PACKAGE_VERSION);
set_version(version);
@@ -112,15 +106,6 @@
void
- AboutWindow::on_link_clicked(Gtk::AboutDialog& dialog,
- const Glib::ustring& link)
- {
-#ifdef HAVE_GNOME
- gnome_url_show(link.c_str(), 0);
-#endif // HAVE_GNOME
- }
-
- void
AboutWindow::on_response(int response_id)
{
if (response_id == Gtk::RESPONSE_DELETE_EVENT ||
diff -Naur agave-0.4.4.orig/src/gcs-mainwindow-actions.cc agave-0.4.4/src/gcs-mainwindow-actions.cc
--- agave-0.4.4.orig/src/gcs-mainwindow-actions.cc 2007-11-02 04:01:16.000000000 +0100
+++ agave-0.4.4/src/gcs-mainwindow-actions.cc 2012-03-20 22:01:10.637760066 +0100
@@ -25,7 +25,6 @@
#include <vector>
#include <gtk/gtk.h>
-#include <libgnome/gnome-help.h>
#include <gtkmm/iconfactory.h>
#include <gtkmm/stock.h>
#include <gtkmm/clipboard.h>
@@ -251,9 +250,10 @@
/* Help Menu Actions */
void MainWindow::on_action_help_contents(void)
{
- gnome_help_display("agave.xml",
- NULL /* link id */,
- NULL /* GError */);
+ gtk_show_uri (NULL,
+ "ghelp:agave",
+ gtk_get_current_event_time (),
+ NULL);
}

View file

@ -1,55 +0,0 @@
diff -Naur agave-0.4.7.orig/src/gcs-conf.cc agave-0.4.7/src/gcs-conf.cc
--- agave-0.4.7.orig/src/gcs-conf.cc 2008-02-26 04:07:02.000000000 +0100
+++ agave-0.4.7/src/gcs-conf.cc 2018-09-05 13:00:23.733940123 +0200
@@ -26,6 +26,7 @@
#include "config.h"
#include "gcs-conf.h"
#include "core/gcs-color.h"
+#include <glibmm.h>
#ifdef HAVE_GCONFMM
#include <gconfmm/client.h>
#include <gconfmm/value.h>
@@ -36,6 +37,7 @@
// gconf recommends storing enumerations as strings rather than integers
// since it's more robust against changes in enumeration order and is more
// human-readable. This is a helper for gconf_string_to_enum and vice versa
+#ifdef HAVE_GCONFMM
static GConfEnumStringPair schemetype_lookup_table[] =
{
{ SCHEME_COMPLEMENTS, "COMPLEMENTS" },
@@ -59,6 +61,7 @@
operator double() { return get_float(); }
operator float() { return get_float(); }
};
+#endif // HAVE_GCONFMM
const Glib::ustring Conf::APP_DIR = "/apps/agave";
@@ -128,8 +131,10 @@
void Conf::set_last_scheme_type(tSchemeType t)
{
+#ifdef HAVE_GCONFMM
Glib::ustring schemetype_string = gconf_enum_to_string(schemetype_lookup_table, t);
set_value(KEY_LAST_SCHEME_TYPE, schemetype_string);
+#endif // HAVE_GCONFMM
}
@@ -137,12 +142,16 @@
{
Glib::ustring scheme_type;
tSchemeType t;
+#ifdef HAVE_GCONFMM
if (!get_value(KEY_LAST_SCHEME_TYPE, scheme_type) ||
!gconf_string_to_enum(schemetype_lookup_table,
scheme_type.c_str(), reinterpret_cast<int*>(&t)))
{
+#endif // HAVE_GCONFMM
t = SCHEME_TRIADS;
+#ifdef HAVE_GCONFMM
}
+#endif // HAVE_GCONFMM
return t;
}

View file

@ -1,11 +0,0 @@
--- agave-0.4.7/src/widgets/gcs-schemebox.cc 2008-02-25 21:07:02.000000000 -0600
+++ agave-0.4.7/src/widgets/gcs-schemebox.cc.new 2010-05-24 00:28:51.000000000 -0500
@@ -45,7 +45,7 @@ namespace gcs
SchemeBox::SchemeBox(Scheme schm)
{
- SchemeBox::SchemeBox();
+ SchemeBox();
set_scheme(schm);
}