mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
removed extra/pyqt5
This commit is contained in:
parent
54a836edae
commit
a58e722516
2 changed files with 0 additions and 138 deletions
|
@ -1,126 +0,0 @@
|
|||
# Maintainer: Felix Yan <felixonmars@archlinux.org>
|
||||
# Contributor: Andrea Scarpino <andrea@archlinux.org>
|
||||
# Contributor: Yichao Yu <yyc1992@gmail.com>
|
||||
# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
|
||||
# Contributor: riai <riai@bigfoot.com> Ben <ben@benmazer.net>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - remove qt5-webengine makedepend for v5/v6
|
||||
|
||||
pkgbase=pyqt5
|
||||
pkgname=('pyqt5-common' 'python-pyqt5' 'python2-pyqt5')
|
||||
pkgver=5.11.3
|
||||
pkgrel=4
|
||||
arch=('x86_64')
|
||||
url="http://riverbankcomputing.co.uk/software/pyqt/intro"
|
||||
license=('GPL')
|
||||
makedepends=('python-sip-pyqt5' 'python2-sip-pyqt5' 'sip' 'python-opengl' 'python2-opengl' 'python2-enum34'
|
||||
'python2-dbus' 'python-dbus' 'qt5-connectivity' 'qt5-multimedia' 'qt5-tools' 'qt5-serialport' 'qt5-svg'
|
||||
'qt5-webkit' 'qt5-websockets' 'qt5-x11extras' 'qt5-networkauth' 'qt5-xmlpatterns')
|
||||
makedepends_armv7h=('qt5-webengine')
|
||||
makedepends_aarch64=('qt5-webengine')
|
||||
source=("http://sourceforge.net/projects/pyqt/files/PyQt5/PyQt-$pkgver/PyQt5_gpl-$pkgver.tar.gz" pyqt-support-new-qt.patch)
|
||||
sha512sums=('6f4abb1866ce357263c208121607072e127c8853e9c6bf039b034fefdda4c40e38f917c3b313375f0d692d764ecf26ff3a6b12cda2a2eeb5237db8b5e9443548')
|
||||
|
||||
prepare() {
|
||||
cp -a PyQt5_gpl-$pkgver{,-py2}
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir"/PyQt5_gpl-$pkgver
|
||||
python configure.py \
|
||||
--confirm-license \
|
||||
--no-sip-files \
|
||||
--qsci-api
|
||||
make
|
||||
|
||||
cd "$srcdir"/PyQt5_gpl-$pkgver-py2
|
||||
python2 configure.py \
|
||||
--confirm-license \
|
||||
--no-sip-files \
|
||||
--qsci-api
|
||||
make
|
||||
}
|
||||
|
||||
package_pyqt5-common(){
|
||||
pkgdesc="Common PyQt files shared between python-pyqt5 and python2-pyqt5"
|
||||
depends=('qt5-base')
|
||||
|
||||
cd PyQt5_gpl-$pkgver
|
||||
install -Dm644 PyQt5.api "$pkgdir"/usr/share/qt/qsci/api/python/PyQt5.api
|
||||
|
||||
install -d "$pkgdir"/usr/share/sip/PyQt5
|
||||
cp -a sip/* "$pkgdir"/usr/share/sip/PyQt5
|
||||
}
|
||||
|
||||
package_python-pyqt5(){
|
||||
pkgdesc="A set of Python 3.x bindings for the Qt5 toolkit"
|
||||
depends=('python-sip-pyqt5' 'pyqt5-common')
|
||||
optdepends=('python-opengl: enable OpenGL 3D graphics in PyQt applications'
|
||||
'python-dbus: for python-dbus mainloop support'
|
||||
'qt5-multimedia: QtMultimedia, QtMultimediaWidgets'
|
||||
'qt5-tools: QtHelp, QtDesigner'
|
||||
'qt5-svg: QtSvg'
|
||||
'qt5-webkit: QtWebKit, QtWebKitWidgets'
|
||||
'qt5-xmlpatterns: QtXmlPatterns'
|
||||
'qt5-declarative: QtQml, qmlplugin'
|
||||
'qt5-serialport: QtSerialPort'
|
||||
'qt5-websockets: QtWebSockets'
|
||||
'qt5-connectivity: QtNfc, QtBluetooth'
|
||||
'qt5-webengine: QtWebEngine, QtWebEngineCore, QtWebEngineWidgets'
|
||||
'qt5-x11extras: QtX11Extras'
|
||||
'qt5-networkauth: QtNetworkAuth')
|
||||
|
||||
cd PyQt5_gpl-$pkgver
|
||||
# INSTALL_ROOT is needed for the QtDesigner module, the other Makefiles use DESTDIR
|
||||
make DESTDIR="$pkgdir" INSTALL_ROOT="$pkgdir" install -j1
|
||||
|
||||
# Remove unused py2 version of uic modules:
|
||||
rm -r "$pkgdir"/usr/lib/python*/site-packages/PyQt5/uic/port_v2
|
||||
|
||||
# compile Python bytecode
|
||||
python -m compileall -d / "$pkgdir"/usr/lib
|
||||
python -O -m compileall -d / "$pkgdir"/usr/lib
|
||||
|
||||
# Provided by pyqt-common
|
||||
rm "$pkgdir"/usr/share/qt/qsci/api/python/PyQt5.api
|
||||
}
|
||||
|
||||
package_python2-pyqt5(){
|
||||
pkgdesc="A set of Python 2.x bindings for the Qt5 toolkit"
|
||||
depends=('python2-sip-pyqt5' 'pyqt5-common' 'python2-enum34')
|
||||
optdepends=('python2-opengl: enable OpenGL 3D graphics in PyQt applications'
|
||||
'python-dbus: for python-dbus mainloop support'
|
||||
'qt5-multimedia: QtMultimedia, QtMultimediaWidgets'
|
||||
'qt5-tools: QtHelp, QtDesigner'
|
||||
'qt5-svg: QtSvg'
|
||||
'qt5-webkit: QtWebKit, QtWebKitWidgets'
|
||||
'qt5-xmlpatterns: QtXmlPatterns'
|
||||
'qt5-declarative: QtQml, qmlplugin'
|
||||
'qt5-serialport: QtSerialPort'
|
||||
'qt5-websockets: QtWebSockets'
|
||||
'qt5-connectivity: QtNfc, QtBluetooth'
|
||||
'qt5-webengine: QtWebEngine, QtWebEngineCore, QtWebEngineWidgets'
|
||||
'qt5-x11extras: QtX11Extras'
|
||||
'qt5-networkauth: QtNetworkAuth')
|
||||
|
||||
cd PyQt5_gpl-$pkgver-py2
|
||||
# INSTALL_ROOT is needed for the QtDesigner module, the other Makefiles use DESTDIR
|
||||
make DESTDIR="$pkgdir" INSTALL_ROOT="$pkgdir" install -j1
|
||||
|
||||
# Remove unused py3 version of uic modules:
|
||||
rm -r "$pkgdir"/usr/lib/python*/site-packages/PyQt5/uic/port_v3
|
||||
|
||||
# compile Python bytecode
|
||||
python2 -m compileall -d / "$pkgdir"/usr/lib
|
||||
python2 -O -m compileall -d / "$pkgdir"/usr/lib
|
||||
|
||||
# Fix conflicts with python-pyqt5
|
||||
mv "$pkgdir"/usr/bin/{,python2-}pyuic5
|
||||
mv "$pkgdir"/usr/bin/{,python2-}pylupdate5
|
||||
mv "$pkgdir"/usr/bin/{,python2-}pyrcc5
|
||||
|
||||
rm "$pkgdir"/usr/lib/qt/plugins/designer/libpyqt5.so
|
||||
rm "$pkgdir"/usr/lib/qt/plugins/PyQt5/libpyqt5qmlplugin.so
|
||||
rm "$pkgdir"/usr/share/qt/qsci/api/python/PyQt5.api
|
||||
}
|
|
@ -1,12 +0,0 @@
|
|||
diff -ru a/sip/QtCore/QtCoremod.sip b/sip/QtCore/QtCoremod.sip
|
||||
--- a/sip/QtCore/QtCoremod.sip 2016-12-25 18:56:11.000000000 +0100
|
||||
+++ b/sip/QtCore/QtCoremod.sip 2017-01-24 12:03:50.707514377 +0100
|
||||
@@ -22,7 +22,7 @@
|
||||
|
||||
%Module(name=PyQt5.QtCore, call_super_init=True, default_VirtualErrorHandler=PyQt5, keyword_arguments="Optional", use_limited_api=True)
|
||||
|
||||
-%Timeline {Qt_5_0_0 Qt_5_0_1 Qt_5_0_2 Qt_5_1_0 Qt_5_1_1 Qt_5_2_0 Qt_5_2_1 Qt_5_3_0 Qt_5_3_1 Qt_5_3_2 Qt_5_4_0 Qt_5_4_1 Qt_5_4_2 Qt_5_5_0 Qt_5_5_1 Qt_5_6_0 Qt_5_6_1 Qt_5_6_2 Qt_5_6_3 Qt_5_6_4 Qt_5_6_5 Qt_5_6_6 Qt_5_6_7 Qt_5_6_8 Qt_5_6_9 Qt_5_7_0 Qt_5_7_1 Qt_5_8_0 Qt_5_8_1 Qt_5_9_0 Qt_5_9_1 Qt_5_9_2 Qt_5_9_3 Qt_5_9_99 Qt_5_10_0 Qt_5_10_1}
|
||||
+%Timeline {Qt_5_0_0 Qt_5_0_1 Qt_5_0_2 Qt_5_1_0 Qt_5_1_1 Qt_5_2_0 Qt_5_2_1 Qt_5_3_0 Qt_5_3_1 Qt_5_3_2 Qt_5_4_0 Qt_5_4_1 Qt_5_4_2 Qt_5_5_0 Qt_5_5_1 Qt_5_6_0 Qt_5_6_1 Qt_5_6_2 Qt_5_6_3 Qt_5_6_4 Qt_5_6_5 Qt_5_6_6 Qt_5_6_7 Qt_5_6_8 Qt_5_6_9 Qt_5_7_0 Qt_5_7_1 Qt_5_8_0 Qt_5_8_1 Qt_5_9_0 Qt_5_9_1 Qt_5_9_2 Qt_5_9_3 Qt_5_9_99 Qt_5_10_0 Qt_5_10_1 Qt_5_11_0 Qt_5_11_1}
|
||||
|
||||
%Platforms {WS_X11 WS_WIN WS_MACX}
|
||||
|
Loading…
Reference in a new issue