mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
added extra/stellarium
This commit is contained in:
parent
d08dc3c0db
commit
a594549158
5 changed files with 88 additions and 0 deletions
44
extra/stellarium/PKGBUILD
Normal file
44
extra/stellarium/PKGBUILD
Normal file
|
@ -0,0 +1,44 @@
|
|||
# $Id$
|
||||
# Maintainer: Ronald van Haren <ronald.archlinux.org>
|
||||
# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - drop unsupported compiler flag
|
||||
|
||||
pkgname=stellarium
|
||||
pkgver=0.13.0
|
||||
pkgrel=1
|
||||
pkgdesc="A stellarium with great graphics and a nice database of sky-objects"
|
||||
arch=("i686" "x86_64")
|
||||
url="http://stellarium.free.fr/"
|
||||
license=('GPL2')
|
||||
depends=('libpng' 'glu' 'libgl' 'freetype2' 'qt5-quick1' 'openssl'
|
||||
'desktop-file-utils' 'xdg-utils' 'phonon')
|
||||
install=stellarium.install
|
||||
makedepends=('cmake' 'boost' 'mesa' 'mesa-libgl' 'qt5-tools')
|
||||
source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
|
||||
stellarium.desktop
|
||||
stellarium.png)
|
||||
sha1sums=('d14078084f7951d7c5ae7ba38499439234f71292'
|
||||
'c9cc79212542238227b5bd6af99f60fe056f4ab2'
|
||||
'b890d3b6c4dcfcfcc696514202af11b2a50c0fea')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
|
||||
sed -i '/mno-ms-bitfields/d' CMakeLists.txt
|
||||
cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RELEASE
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
|
||||
make DESTDIR="${pkgdir}" install
|
||||
|
||||
# install desktop file & pixmap
|
||||
install -Dm644 "${srcdir}/stellarium.desktop" \
|
||||
"${pkgdir}/usr/share/applications/stellarium.desktop"
|
||||
install -Dm644 "${srcdir}/stellarium.png" \
|
||||
"${pkgdir}/usr/share/pixmaps/stellarium.png"
|
||||
}
|
21
extra/stellarium/libpng14.patch
Normal file
21
extra/stellarium/libpng14.patch
Normal file
|
@ -0,0 +1,21 @@
|
|||
diff -Naur stellarium-0.10.2-orig/src/core/StelTextureMgr.cpp stellarium-0.10.2/src/core/StelTextureMgr.cpp
|
||||
--- stellarium-0.10.2-orig/src/core/StelTextureMgr.cpp 2010-01-21 17:04:57.000000000 -0500
|
||||
+++ stellarium-0.10.2/src/core/StelTextureMgr.cpp 2010-01-21 17:06:55.000000000 -0500
|
||||
@@ -513,7 +513,7 @@
|
||||
fread (magic, 1, sizeof (magic), fp);
|
||||
|
||||
/* check for valid magic number */
|
||||
- if (!png_check_sig (magic, sizeof (magic)))
|
||||
+ if (png_sig_cmp (magic, 0, sizeof (magic)))
|
||||
{
|
||||
qWarning() << "error: \"" << filename << "\" is not a valid PNG image!";
|
||||
fclose (fp);
|
||||
@@ -576,7 +576,7 @@
|
||||
/* convert 1-2-4 bits grayscale images to 8 bits
|
||||
grayscale. */
|
||||
if (color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8)
|
||||
- png_set_gray_1_2_4_to_8 (png_ptr);
|
||||
+ png_set_expand_gray_1_2_4_to_8 (png_ptr);
|
||||
|
||||
if (png_get_valid (png_ptr, info_ptr, PNG_INFO_tRNS))
|
||||
png_set_tRNS_to_alpha (png_ptr);
|
9
extra/stellarium/stellarium.desktop
Normal file
9
extra/stellarium/stellarium.desktop
Normal file
|
@ -0,0 +1,9 @@
|
|||
[Desktop Entry]
|
||||
Name=Stellarium nightsky renderer
|
||||
GenericName=Nightsky renderer
|
||||
Comment=A real-time nightsky renderer
|
||||
Categories=Education;Science;Astronomy;
|
||||
Icon=stellarium
|
||||
Exec=stellarium
|
||||
Terminal=false
|
||||
Type=Application
|
14
extra/stellarium/stellarium.install
Normal file
14
extra/stellarium/stellarium.install
Normal file
|
@ -0,0 +1,14 @@
|
|||
pkgname=stellarium
|
||||
|
||||
post_install() {
|
||||
update-desktop-database -q
|
||||
xdg-icon-resource forceupdate
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install $1
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
post_install $1
|
||||
}
|
BIN
extra/stellarium/stellarium.png
Normal file
BIN
extra/stellarium/stellarium.png
Normal file
Binary file not shown.
After Width: | Height: | Size: 18 KiB |
Loading…
Reference in a new issue