alarm/uboot-wandboard to 2014.10-1

This commit is contained in:
Kevin Mihelich 2014-11-23 21:01:41 +00:00
parent d47a6297bc
commit a5947e104c
2 changed files with 32 additions and 18 deletions

View file

@ -1,6 +1,17 @@
diff -urN a/include/configs/wandboard.h b/include/configs/wandboard.h
--- a/include/configs/wandboard.h 2014-07-14 11:16:45.000000000 -0600
+++ b/include/configs/wandboard.h 2014-08-17 11:41:59.539017046 -0600
From 9898c2efa3539e27e11d5672c552ad6dab2b7063 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 23 Nov 2014 08:23:29 -0700
Subject: [PATCH] arch linux arm modifications
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
include/configs/wandboard.h | 117 ++++++++++++++++++++++----------------------
1 file changed, 58 insertions(+), 59 deletions(-)
diff --git a/include/configs/wandboard.h b/include/configs/wandboard.h
index 9fb501a..20d71d8 100644
--- a/include/configs/wandboard.h
+++ b/include/configs/wandboard.h
@@ -51,7 +51,7 @@
#define CONFIG_CMD_BMODE
#define CONFIG_CMD_SETEXPR
@ -19,16 +30,16 @@ diff -urN a/include/configs/wandboard.h b/include/configs/wandboard.h
#define CONFIG_DOS_PARTITION
/* Ethernet Configuration */
@@ -110,6 +112,8 @@
#define CONFIG_IMX_HDMI
#define CONFIG_IMX_VIDEO_SKIP
@@ -115,6 +117,8 @@
#define CONFIG_MXC_OCOTP
#endif
+#define CONFIG_IDENT_STRING " Arch Linux ARM"
+
#if defined(CONFIG_MX6DL) || defined(CONFIG_MX6S)
#define CONFIG_DEFAULT_FDT_FILE "imx6dl-wandboard.dtb"
#elif defined(CONFIG_MX6Q)
@@ -117,42 +121,33 @@
@@ -122,42 +126,33 @@
#endif
#define CONFIG_EXTRA_ENV_SETTINGS \
@ -88,7 +99,7 @@ diff -urN a/include/configs/wandboard.h b/include/configs/wandboard.h
"setexpr nextcon ${nextcon} + 1; " \
"else " \
"echo - no HDMI monitor;" \
@@ -172,26 +167,38 @@
@@ -177,26 +172,38 @@
"echo '- no FWBADAPT-7WVGA-LCD-F07A-0102 display';" \
"fi; " \
"setenv bootargs ${bootargs} ${fbmem}\0" \
@ -146,7 +157,7 @@ diff -urN a/include/configs/wandboard.h b/include/configs/wandboard.h
"fi;\0" \
"netargs=setenv bootargs console=${console},${baudrate} " \
"root=/dev/nfs " \
@@ -203,10 +210,10 @@
@@ -208,10 +215,10 @@
"else " \
"setenv get_cmd tftp; " \
"fi; " \
@ -160,7 +171,7 @@ diff -urN a/include/configs/wandboard.h b/include/configs/wandboard.h
"else " \
"if test ${boot_fdt} = try; then " \
"bootz; " \
@@ -219,16 +226,7 @@
@@ -224,16 +231,7 @@
"fi;\0"
#define CONFIG_BOOTCOMMAND \
@ -178,7 +189,7 @@ diff -urN a/include/configs/wandboard.h b/include/configs/wandboard.h
/* Miscellaneous configurable options */
#define CONFIG_SYS_LONGHELP
@@ -269,6 +267,7 @@
@@ -274,6 +272,7 @@
#define CONFIG_OF_LIBFDT
#define CONFIG_CMD_BOOTZ
@ -186,3 +197,6 @@ diff -urN a/include/configs/wandboard.h b/include/configs/wandboard.h
#ifndef CONFIG_SYS_DCACHE_OFF
#define CONFIG_CMD_CACHE
--
2.1.3

View file

@ -5,26 +5,26 @@ buildarch=4
pkgbase=uboot-wandboard
pkgname=('uboot-wandboard-solo' 'uboot-wandboard-dual' 'uboot-wandboard-quad')
pkgver=2014.07
pkgver=2014.10
pkgrel=1
arch=('armv7h')
url="http://git.denx.de/u-boot.git/"
license=('GPL')
makedepends=('git')
makedepends=('git' 'bc')
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
'alarm.patch')
md5sums=('36d4bad687edcafa396fee607e505d4e'
'5c98cbb91f6c165273b35841d06af122')
'0001-arch-linux-arm-modifications.patch')
md5sums=('3ddcaee2f05b7c464778112ec83664b5'
'edae26c4acf325b590f8b40a0209c62e')
prepare() {
cd u-boot-${pkgver}
patch -p1 -i ../alarm.patch
git apply ../0001-arch-linux-arm-modifications.patch
}
build() {
cd u-boot-${pkgver}
unset CFLAGS CXXFLAGS LDFLAGS
unset LDFLAGS
mkdir bins
for i in solo dl quad; do