extra/firefox to 90.0-1

This commit is contained in:
Kevin Mihelich 2021-07-14 04:53:22 +00:00
parent 0d07616c35
commit a5948b89a4
2 changed files with 9 additions and 9 deletions

View file

@ -9,10 +9,10 @@ Subject: [PATCH] Use remoting name for GDK application names
2 files changed, 6 insertions(+), 12 deletions(-)
diff --git a/toolkit/xre/nsAppRunner.cpp b/toolkit/xre/nsAppRunner.cpp
index 3a9928cee4525..da60306cfaf01 100644
index 3ec33c9b45417..56081f76a0074 100644
--- a/toolkit/xre/nsAppRunner.cpp
+++ b/toolkit/xre/nsAppRunner.cpp
@@ -4358,11 +4358,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
@@ -4252,11 +4252,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
// consistently.
// Set program name to the one defined in application.ini.
@ -26,7 +26,7 @@ index 3a9928cee4525..da60306cfaf01 100644
// Initialize GTK here for splash.
diff --git a/widget/gtk/nsAppShell.cpp b/widget/gtk/nsAppShell.cpp
index 24bdd5083375b..74dd54a5ae0e6 100644
index 60de473de07ab..004c066575c17 100644
--- a/widget/gtk/nsAppShell.cpp
+++ b/widget/gtk/nsAppShell.cpp
@@ -24,6 +24,8 @@
@ -38,7 +38,7 @@ index 24bdd5083375b..74dd54a5ae0e6 100644
#include "ScreenHelperGTK.h"
#include "HeadlessScreenHelper.h"
#include "mozilla/widget/ScreenManager.h"
@@ -153,13 +155,9 @@ nsresult nsAppShell::Init() {
@@ -152,13 +154,9 @@ nsresult nsAppShell::Init() {
// See https://bugzilla.gnome.org/show_bug.cgi?id=747634
//
// Only bother doing this for the parent process, since it's the one

View file

@ -10,7 +10,7 @@ buildarch=12
highmem=1
pkgname=firefox
pkgver=89.0.2
pkgver=90.0
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org"
arch=(x86_64)
@ -18,7 +18,7 @@ license=(MPL GPL LGPL)
url="https://www.mozilla.org/firefox/"
depends=(gtk3 libxt mime-types dbus-glib ffmpeg nss ttf-font libpulse)
makedepends=(unzip zip diffutils yasm mesa imake inetutils xorg-server-xvfb
autoconf2.13 rust clang llvm jack gtk2 nodejs cbindgen nasm
autoconf2.13 rust clang llvm jack nodejs cbindgen nasm
python-setuptools python-psutil python-zstandard lld dump_syms)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
@ -32,11 +32,11 @@ source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-
build-arm-libopus.patch
0001-Use-remoting-name-for-GDK-application-names.patch
$pkgname.desktop)
sha256sums=('3225f583c5e36bdf52ad16f71a2c359deb0c765c38205acdeb6b7b6520ac5494'
sha256sums=('43a943e7d7660c6d7f5b41c95b344b7fd6a4a88ad0bb45dbd844b372ea60d58b'
'SKIP'
'bc00516032330760444939c516a60c78f868631e1b37f075f0fe71a53737b966'
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9'
'98b6b30973bb1e12e17e8a78baf7d1db0d5085f35252f4611870bb23e8faeff1'
'7e7435e8171426e87a84cecf9eb017cb969c9c85d973feb78c1e05771972b6e9'
'298eae9de76ec53182f38d5c549d0379569916eebf62149f9d7f4a7edef36abf')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
@ -73,6 +73,7 @@ ac_add_options --enable-release
#ac_add_options --enable-optimize="-O2"
#ac_add_options --enable-rust-simd
ac_add_options --enable-linker=lld
ac_add_options --disable-bootstrap
# Branding
ac_add_options --enable-official-branding
@ -82,7 +83,6 @@ ac_add_options --with-unsigned-addon-scopes=app,system
ac_add_options --allow-addon-sideload
export MOZILLA_OFFICIAL=1
export MOZ_APP_REMOTINGNAME=${pkgname//-/}
export MOZ_REQUIRE_SIGNING=1
# Keys
ac_add_options --with-google-location-service-api-keyfile=${PWD@Q}/google-api-key