core/linux-utilite fix reboot issue, fix Intel ethernet

This commit is contained in:
Dave Higham 2014-04-16 23:40:39 +01:00
parent cff2e5b3b1
commit a5d87de9f9
3 changed files with 31 additions and 6 deletions

View file

@ -8,7 +8,7 @@ _srcname=utilite-${_commit}
_kernelname=${pkgbase#linux}
_desc="CompuLab Utilite alternate kernel"
pkgver=3.0.35
pkgrel=11
pkgrel=12
arch=('armv7h')
url="https://gitorious.org/utilite/utilite"
license=('GPL2')
@ -16,10 +16,12 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'uboot-mkimage')
options=('!strip')
source=("https://github.com/wolfgar/utilite/archive/${_commit}.tar.gz"
'config'
'https://raw.github.com/Freescale/meta-fsl-arm/46de5ee9dec3486c3e081f9f39ac1a0f967afd54/recipes-kernel/linux/linux-imx-3.0.35/ENGR00278350-gpu-viante-4.6.9p13-kernel-part-integra.patch')
'https://raw.github.com/Freescale/meta-fsl-arm/46de5ee9dec3486c3e081f9f39ac1a0f967afd54/recipes-kernel/linux/linux-imx-3.0.35/ENGR00278350-gpu-viante-4.6.9p13-kernel-part-integra.patch'
'disable-smarteee.patch')
md5sums=('d79ebe426f473de6de25162f85b7c90b'
'16b72cb03b987f61ede6c840c1bccdb0'
'41941771adfed8b55574a7434d2c3393')
'10ef3a2bc67d15b46f5ce9b20b689568'
'41941771adfed8b55574a7434d2c3393'
'8e592f455c2ecbf83fddfac5f6691c0f')
prepare() {
cd "${srcdir}/${_srcname}"
@ -29,6 +31,9 @@ prepare() {
# allow use of 3.10.17 gpu binaries
patch --ignore-whitespace -p1 < ../ENGR00278350-gpu-viante-4.6.9p13-kernel-part-integra.patch
# Disable SmartEEE which causes ethernet link down/up issue
patch -Np1 -i ../disable-smarteee.patch
# add pkgrel to extraversion
sed -ri "s|^(EXTRAVERSION =)(.*)|\1 \2-${pkgrel}|" Makefile

View file

@ -1,6 +1,6 @@
#
# Automatically generated make config: don't edit
# Linux/arm 3.0.35-10 Kernel Configuration
# Linux/arm 3.0.35-12 Kernel Configuration
#
CONFIG_ARM=y
CONFIG_HAVE_PWM=y
@ -419,7 +419,7 @@ CONFIG_ARM_ERRATA_743622=y
CONFIG_ARM_ERRATA_751472=y
# CONFIG_ARM_ERRATA_753970 is not set
CONFIG_ARM_ERRATA_754322=y
CONFIG_ARM_ERRATA_754327=y
# CONFIG_ARM_ERRATA_754327 is not set
CONFIG_ARM_ERRATA_775420=y
CONFIG_ARM_GIC=y

View file

@ -0,0 +1,20 @@
diff -rupN utilite-a/arch/arm/mach-mx6/board-cm-fx6.c utilite-b/arch/arm/mach-mx6/board-cm-fx6.c
--- utilite-a/arch/arm/mach-mx6/board-cm-fx6.c 2014-02-24 21:35:41.000000000 +0000
+++ utilite-b/arch/arm/mach-mx6/board-cm-fx6.c 2014-04-16 20:33:04.473660149 +0000
@@ -200,6 +200,16 @@ static int cm_fx6_fec_phy_init(struct ph
{
unsigned short val;
+ /* Ar8031 phy SmartEEE feature cause link status generates glitch,
+ * which cause ethernet link down/up issue, so disable SmartEEE
+ */
+ phy_write(phydev, 0xd, 0x3);
+ phy_write(phydev, 0xe, 0x805d);
+ phy_write(phydev, 0xd, 0x4003);
+ val = phy_read(phydev, 0xe);
+ val &= ~(0x1 << 8);
+ phy_write(phydev, 0xe, val);
+
/* To enable AR8031 ouput a 125MHz clk from CLK_25M */
phy_write(phydev, 0xd, 0x7);
phy_write(phydev, 0xe, 0x8016);