mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
community/xbmc to 12.1-3
This commit is contained in:
parent
14782f9c75
commit
a624e620bc
2 changed files with 4 additions and 51 deletions
|
@ -14,8 +14,8 @@ buildarch=4
|
|||
_prefix=/usr
|
||||
|
||||
pkgname=xbmc
|
||||
pkgver=12.0
|
||||
pkgrel=1
|
||||
pkgver=12.1
|
||||
pkgrel=3
|
||||
pkgdesc="A software media player and entertainment hub for digital media"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://xbmc.org"
|
||||
|
@ -37,11 +37,9 @@ optdepends=('libcec: support for Pulse-Eight USB-CEC adapter'
|
|||
'xorg-xinit: autostart xbmc')
|
||||
install="${pkgname}.install"
|
||||
source=("http://mirrors.xbmc.org/releases/source/xbmc-$pkgver.tar.gz"
|
||||
"xbmc.service"
|
||||
"cdio.patch")
|
||||
"xbmc.service")
|
||||
md5sums=('a79128b9d094a046947bfd9bb4550809'
|
||||
'76fae229ebc3bcfaab7e7f27e4fb51f5'
|
||||
'49c0a7cbfca3666a24e8824950bd371b')
|
||||
'76fae229ebc3bcfaab7e7f27e4fb51f5')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/xbmc-$pkgver"
|
||||
|
@ -49,12 +47,6 @@ build() {
|
|||
# fix lsb_release dependency
|
||||
sed -i -e 's:/usr/bin/lsb_release -d:cat /etc/arch-release:' xbmc/utils/SystemInfo.cpp
|
||||
|
||||
# sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADER:' \
|
||||
# lib/libid3tag/libid3tag/configure.ac \
|
||||
# lib/libdvd/libdvdcss/configure.ac
|
||||
|
||||
# patch -p1 <$srcdir/cdio.patch
|
||||
|
||||
# Bootstrapping XBMC
|
||||
./bootstrap
|
||||
|
||||
|
|
|
@ -1,39 +0,0 @@
|
|||
diff -wbBur xbmc-11.0/xbmc/music/tags/MusicInfoTagLoaderCDDA.cpp xbmc-11.0.my/xbmc/music/tags/MusicInfoTagLoaderCDDA.cpp
|
||||
--- xbmc-11.0/xbmc/music/tags/MusicInfoTagLoaderCDDA.cpp 2012-03-22 02:07:50.000000000 +0400
|
||||
+++ xbmc-11.0.my/xbmc/music/tags/MusicInfoTagLoaderCDDA.cpp 2013-01-09 14:40:10.670040454 +0400
|
||||
@@ -27,6 +27,10 @@
|
||||
#include "storage/MediaManager.h"
|
||||
#include "utils/log.h"
|
||||
|
||||
+#define CDTEXT_TITLE CDTEXT_FIELD_TITLE
|
||||
+#define CDTEXT_PERFORMER CDTEXT_FIELD_PERFORMER
|
||||
+#define CDTEXT_GENRE CDTEXT_FIELD_GENRE
|
||||
+
|
||||
using namespace MUSIC_INFO;
|
||||
|
||||
#ifdef HAS_DVD_DRIVE
|
||||
diff -wbBur xbmc-11.0/xbmc/storage/cdioSupport.cpp xbmc-11.0.my/xbmc/storage/cdioSupport.cpp
|
||||
--- xbmc-11.0/xbmc/storage/cdioSupport.cpp 2012-03-22 02:07:50.000000000 +0400
|
||||
+++ xbmc-11.0.my/xbmc/storage/cdioSupport.cpp 2013-01-09 14:51:40.276801092 +0400
|
||||
@@ -648,15 +648,18 @@
|
||||
CSingleLock lock(*m_cdio);
|
||||
|
||||
// Get the CD-Text , if any
|
||||
- cdtext_t *pcdtext = (cdtext_t *)::cdio_get_cdtext(cdio, trackNum);
|
||||
+ cdtext_t *pcdtext = (cdtext_t *)::cdio_get_cdtext(cdio);
|
||||
|
||||
if (pcdtext == NULL)
|
||||
return ;
|
||||
|
||||
// same ids used in libcdio and for our structure + the ids are consecutive make this copy loop safe.
|
||||
for (int i = 0; i < MAX_CDTEXT_FIELDS; i++)
|
||||
- if (pcdtext->field[i])
|
||||
- xcdt[(cdtext_field_t)i] = pcdtext->field[(cdtext_field_t)i];
|
||||
+ {
|
||||
+ char *data = cdtext_get(pcdtext, (cdtext_field_t)i, trackNum);
|
||||
+ if (data != NULL)
|
||||
+ xcdt[(cdtext_field_t)i] = data;
|
||||
+ }
|
||||
}
|
||||
|
||||
CCdInfo* CCdIoSupport::GetCdInfo(char* cDeviceFileName)
|
Loading…
Reference in a new issue