mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
community/sigil to 0.9.8-2
This commit is contained in:
parent
34a7dc06c2
commit
a67bf4f1dc
4 changed files with 31 additions and 5 deletions
|
@ -7,7 +7,7 @@
|
|||
|
||||
pkgname=sigil
|
||||
pkgver=0.9.8
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc="WYSIWYG ebook editor"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://sigil-ebook.com/"
|
||||
|
|
|
@ -12,11 +12,11 @@ highmem=1
|
|||
|
||||
pkgname=xulrunner
|
||||
pkgver=41.0.2
|
||||
pkgrel=9
|
||||
pkgrel=10
|
||||
pkgdesc="Mozilla Runtime Environment"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('MPL' 'GPL' 'LGPL')
|
||||
depends=('gtk2' 'mozilla-common' 'nss>3.18' 'libxt' 'startup-notification' 'mime-types' 'dbus-glib' 'libpulse' 'libevent' 'libvpx' 'icu' 'python2')
|
||||
depends=('gtk2' 'mozilla-common' 'nss>3.18' 'libxt' 'hunspell' 'startup-notification' 'mime-types' 'dbus-glib' 'libpulse' 'libevent' 'libvpx' 'icu' 'python2')
|
||||
makedepends=('zip' 'unzip' 'pkg-config' 'diffutils' 'yasm' 'mesa' 'gconf' 'autoconf2.13' 'gst-plugins-base-libs')
|
||||
url="http://wiki.mozilla.org/XUL:Xul_Runner"
|
||||
source=(https://ftp.mozilla.org/pub/mozilla.org/xulrunner/releases/$pkgver/source/xulrunner-$pkgver.source.tar.xz
|
||||
|
@ -26,16 +26,18 @@ source=(https://ftp.mozilla.org/pub/mozilla.org/xulrunner/releases/$pkgver/sourc
|
|||
LFS_graphite2_harfbuzz.patch
|
||||
mozilla-pkgconfig.patch
|
||||
shared-libs.patch
|
||||
sed43.patch
|
||||
gcc6.diff)
|
||||
options=('!emptydirs' 'staticlibs')
|
||||
replaces=('xulrunner-oss')
|
||||
sha256sums=('f7abb2e2989779305ab1f80d30caf9fc55d96c7e66d1394e2cc9639442e2b864'
|
||||
'8db8bccf75282a8dbf83bdc233c80d80d22d3feb30360574a1f774006ae61c73'
|
||||
'689db506c2536dd594411e09ef054ab083bd22e26daffe03183a93a8d3b5b673'
|
||||
'3aea9a83bf304da5525f34a911712cf42f8ded1c8b6becf0a2cf8a4b4f7facd6'
|
||||
'13a27a385fab88938ac7417f1e7ca7225ec6b88840bafe67e0f5642e5446554a'
|
||||
'afcd7d3f6113b0f9ead0cb1b47b3fccedadce56a16b4406c439411864bd11863'
|
||||
'1aa9ebe67542a2b8c28905d070829ada5b29438c6a7961f2b0cdd6b92d8b9f5c'
|
||||
'59d9fc421bc10a5515b73e159f44a72365bf7b7e8b3fc8a8c46043ef40bd3a40'
|
||||
'e9b7199b57fa07e440d37db0cc3cf52aa1c1fd7d5e8b31db14e511d77b5ce327'
|
||||
'0992d5dce883de760ff0445448466f096d0baa75fe5fd1e60bfd3cc13cb4d098')
|
||||
|
||||
prepare() {
|
||||
|
@ -47,6 +49,9 @@ prepare() {
|
|||
|
||||
[[ $CARCH == "aarch64" ]] && echo "ac_add_options --disable-gold" >> .mozconfig
|
||||
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1329272
|
||||
patch -Np1 -i ../sed43.patch
|
||||
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1194520
|
||||
patch -Np1 -i ../freetype261.patch
|
||||
|
||||
|
|
|
@ -20,7 +20,7 @@ ac_add_options --with-system-libevent
|
|||
ac_add_options --with-system-libvpx
|
||||
ac_add_options --with-system-icu
|
||||
ac_add_options --with-system-graphite2
|
||||
#ac_add_options --enable-system-hunspell
|
||||
ac_add_options --enable-system-hunspell
|
||||
ac_add_options --enable-system-sqlite
|
||||
ac_add_options --enable-system-ffi
|
||||
ac_add_options --enable-system-cairo
|
||||
|
|
21
community/xulrunner/sed43.patch
Normal file
21
community/xulrunner/sed43.patch
Normal file
|
@ -0,0 +1,21 @@
|
|||
|
||||
# HG changeset patch
|
||||
# User Daniel Stenberg <daniel@haxx.se>
|
||||
# Date 1484000700 -3600
|
||||
# Node ID ebcbf47a83e7d3b89460cf1c991b6be5a79a967b
|
||||
# Parent 0759511f24e1b8d42acf5e9612f3ab91715842c2
|
||||
Bug 1329272 - add bracket for sed 4.3 compliance, r=glandium
|
||||
|
||||
diff --git a/build/autoconf/icu.m4 b/build/autoconf/icu.m4
|
||||
--- a/build/autoconf/icu.m4
|
||||
+++ b/build/autoconf/icu.m4
|
||||
@@ -69,7 +69,7 @@ if test -n "$USE_ICU"; then
|
||||
fi
|
||||
fi
|
||||
|
||||
- version=`sed -n 's/^[[:space:]]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
|
||||
+ version=`sed -n 's/^[[[:space:]]]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
|
||||
if test x"$version" = x; then
|
||||
AC_MSG_ERROR([cannot determine icu version number from uvernum.h header file $lineno])
|
||||
fi
|
||||
|
Loading…
Reference in a new issue