mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
extra/texlive-bin to 2014.34260-1
This commit is contained in:
parent
109aba3e79
commit
a6f7607925
3 changed files with 30 additions and 128 deletions
|
@ -8,8 +8,8 @@
|
||||||
# --disable-cxx-runtime-hack
|
# --disable-cxx-runtime-hack
|
||||||
|
|
||||||
pkgname=texlive-bin
|
pkgname=texlive-bin
|
||||||
pkgver=2013.30973
|
pkgver=2014.34260
|
||||||
pkgrel=10
|
pkgrel=1
|
||||||
pkgdesc="TeX Live binaries"
|
pkgdesc="TeX Live binaries"
|
||||||
license=('GPL')
|
license=('GPL')
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
|
@ -24,16 +24,12 @@ options=('!strip')
|
||||||
url='http://tug.org/texlive/'
|
url='http://tug.org/texlive/'
|
||||||
install="texlive.install"
|
install="texlive.install"
|
||||||
source=('fix-fontforge-encoding.patch'
|
source=('fix-fontforge-encoding.patch'
|
||||||
"http://mirrors.kernel.org/archlinux/other/texlive/texlive-bin-source-${pkgver}.tar.xz"
|
"http://mirrors.kernel.org/archlinux/other/texlive/texlive-bin-source-${pkgver}.tar.xz")
|
||||||
poppler-0.26.patch
|
|
||||||
)
|
|
||||||
md5sums=('bfb9716aa00c86c08cd31e5b32edeb98'
|
md5sums=('bfb9716aa00c86c08cd31e5b32edeb98'
|
||||||
'0a8ffd5c0002a080a4202057b1f106c6'
|
'b6fe9a6e6b3df0d69e804b87370039ef')
|
||||||
'65f5eef04fdf65fe8ff2df873509c855')
|
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd source
|
cd source
|
||||||
patch -Np2 -i ../poppler-0.26.patch
|
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
@ -121,10 +117,6 @@ package() {
|
||||||
make DESTDIR="${pkgdir}" texmf="$pkgdir"/usr/share/texmf install
|
make DESTDIR="${pkgdir}" texmf="$pkgdir"/usr/share/texmf install
|
||||||
rm -rf "${pkgdir}"/usr/{texmf,share/texmf-dist}
|
rm -rf "${pkgdir}"/usr/{texmf,share/texmf-dist}
|
||||||
|
|
||||||
## install Perl libraries
|
|
||||||
mkdir -p "$pkgdir"/usr/share/tlpkg/TeXLive
|
|
||||||
install -m644 "${srcdir}"/source/utils/biber/TeXLive/*.pm "${pkgdir}/usr/share/tlpkg/TeXLive"
|
|
||||||
|
|
||||||
## symlink engines by hand. texlinks has moved to texlive-core...
|
## symlink engines by hand. texlinks has moved to texlive-core...
|
||||||
mkdir -p ${pkgdir}/usr/bin
|
mkdir -p ${pkgdir}/usr/bin
|
||||||
ln -s eptex ${pkgdir}/usr/bin/platex
|
ln -s eptex ${pkgdir}/usr/bin/platex
|
||||||
|
@ -132,6 +124,7 @@ package() {
|
||||||
ln -s luatex ${pkgdir}/usr/bin/dvilualatex
|
ln -s luatex ${pkgdir}/usr/bin/dvilualatex
|
||||||
ln -s luatex ${pkgdir}/usr/bin/dviluatex
|
ln -s luatex ${pkgdir}/usr/bin/dviluatex
|
||||||
ln -s luatex ${pkgdir}/usr/bin/lualatex
|
ln -s luatex ${pkgdir}/usr/bin/lualatex
|
||||||
|
ln -s luatex ${pkgdir}/usr/bin/lualollipop
|
||||||
ln -s pdftex ${pkgdir}/usr/bin/amstex
|
ln -s pdftex ${pkgdir}/usr/bin/amstex
|
||||||
ln -s pdftex ${pkgdir}/usr/bin/cslatex
|
ln -s pdftex ${pkgdir}/usr/bin/cslatex
|
||||||
ln -s pdftex ${pkgdir}/usr/bin/csplain
|
ln -s pdftex ${pkgdir}/usr/bin/csplain
|
||||||
|
@ -139,6 +132,7 @@ package() {
|
||||||
ln -s pdftex ${pkgdir}/usr/bin/etex
|
ln -s pdftex ${pkgdir}/usr/bin/etex
|
||||||
ln -s pdftex ${pkgdir}/usr/bin/jadetex
|
ln -s pdftex ${pkgdir}/usr/bin/jadetex
|
||||||
ln -s pdftex ${pkgdir}/usr/bin/latex
|
ln -s pdftex ${pkgdir}/usr/bin/latex
|
||||||
|
ln -s pdftex ${pkgdir}/usr/bin/lollipop
|
||||||
ln -s pdftex ${pkgdir}/usr/bin/mex
|
ln -s pdftex ${pkgdir}/usr/bin/mex
|
||||||
ln -s pdftex ${pkgdir}/usr/bin/mllatex
|
ln -s pdftex ${pkgdir}/usr/bin/mllatex
|
||||||
ln -s pdftex ${pkgdir}/usr/bin/mltex
|
ln -s pdftex ${pkgdir}/usr/bin/mltex
|
||||||
|
@ -153,6 +147,7 @@ package() {
|
||||||
ln -s pdftex ${pkgdir}/usr/bin/utf8mex
|
ln -s pdftex ${pkgdir}/usr/bin/utf8mex
|
||||||
ln -s pdftex ${pkgdir}/usr/bin/xmltex
|
ln -s pdftex ${pkgdir}/usr/bin/xmltex
|
||||||
ln -s xetex ${pkgdir}/usr/bin/xelatex
|
ln -s xetex ${pkgdir}/usr/bin/xelatex
|
||||||
|
ln -s xetex ${pkgdir}/usr/bin/xelollipop
|
||||||
|
|
||||||
#############################################################
|
#############################################################
|
||||||
# remove dangling symlinks
|
# remove dangling symlinks
|
||||||
|
@ -177,10 +172,11 @@ bundledoc
|
||||||
checkcites
|
checkcites
|
||||||
chkweb
|
chkweb
|
||||||
context
|
context
|
||||||
|
contextjit
|
||||||
ctanify
|
ctanify
|
||||||
ctanupload
|
ctanupload
|
||||||
ctxtools
|
|
||||||
de-macro
|
de-macro
|
||||||
|
depythontex
|
||||||
deweb
|
deweb
|
||||||
dosepsbin
|
dosepsbin
|
||||||
dtxgen
|
dtxgen
|
||||||
|
@ -199,15 +195,18 @@ kpsepath
|
||||||
kpsetool
|
kpsetool
|
||||||
kpsewhere
|
kpsewhere
|
||||||
kpsexpand
|
kpsexpand
|
||||||
|
latex-git-log
|
||||||
latex2man
|
latex2man
|
||||||
latexdiff
|
latexdiff
|
||||||
latexdiff-vc
|
latexdiff-vc
|
||||||
latexfileversion
|
latexfileversion
|
||||||
|
latexindent
|
||||||
latexmk
|
latexmk
|
||||||
latexpand
|
latexpand
|
||||||
latexrevise
|
latexrevise
|
||||||
listings-ext.sh
|
listings-ext.sh
|
||||||
ltxfileinfo
|
ltxfileinfo
|
||||||
|
ltximg
|
||||||
lua2dox_filter
|
lua2dox_filter
|
||||||
luaotfload-tool
|
luaotfload-tool
|
||||||
luatools
|
luatools
|
||||||
|
@ -219,6 +218,7 @@ mkt1font
|
||||||
mktexfmt
|
mktexfmt
|
||||||
mptopdf
|
mptopdf
|
||||||
mtxrun
|
mtxrun
|
||||||
|
mtxrunjit
|
||||||
ot2kpx
|
ot2kpx
|
||||||
pdf180
|
pdf180
|
||||||
pdf270
|
pdf270
|
||||||
|
@ -242,6 +242,7 @@ ps2frag
|
||||||
pslatex
|
pslatex
|
||||||
pstopdf
|
pstopdf
|
||||||
purifyeps
|
purifyeps
|
||||||
|
pythontex
|
||||||
repstopdf
|
repstopdf
|
||||||
rpdfcrop
|
rpdfcrop
|
||||||
rungs
|
rungs
|
||||||
|
@ -257,6 +258,7 @@ texdirflatten
|
||||||
texdoc
|
texdoc
|
||||||
texdoctk
|
texdoctk
|
||||||
texexec
|
texexec
|
||||||
|
texfot
|
||||||
texlinks
|
texlinks
|
||||||
texliveonfly
|
texliveonfly
|
||||||
texloganalyser
|
texloganalyser
|
||||||
|
@ -268,15 +270,17 @@ updmap-sys
|
||||||
vpl2ovp
|
vpl2ovp
|
||||||
vpl2vpl
|
vpl2vpl
|
||||||
"
|
"
|
||||||
|
_games_scripts="rubikrotation"
|
||||||
_htmlxml_scripts="ht htcontext htlatex htmex httex httexi htxelatex htxetex mk4ht"
|
_htmlxml_scripts="ht htcontext htlatex htmex httex httexi htxelatex htxetex mk4ht"
|
||||||
_langcyrillic_scripts="rubibtex rumakeindex"
|
_langcyrillic_scripts="rubibtex rumakeindex"
|
||||||
_langcjk_scripts="convbkmk ptex2pdf
|
_langextra_scripts="ebong"
|
||||||
|
_langgreek_scripts="mkgrkindex"
|
||||||
|
_langjapanese_scripts="convbkmk ptex2pdf
|
||||||
kanji-fontmap-creator
|
kanji-fontmap-creator
|
||||||
kanji-config-updmap
|
kanji-config-updmap
|
||||||
kanji-config-updmap-sys
|
kanji-config-updmap-sys
|
||||||
"
|
"
|
||||||
_langextra_scripts="ebong"
|
_langkorean_scripts="jamo-normalize komkindex ttf2kotexfont"
|
||||||
_langgreek_scripts="mkgrkindex"
|
|
||||||
_latexextra_scripts="
|
_latexextra_scripts="
|
||||||
authorindex
|
authorindex
|
||||||
exceltex
|
exceltex
|
||||||
|
@ -287,18 +291,21 @@ ps4pdf
|
||||||
splitindex
|
splitindex
|
||||||
svn-multi
|
svn-multi
|
||||||
vpe"
|
vpe"
|
||||||
_music_scripts="m-tx musixtex musixflx pmx2pdf"
|
_music_scripts="lily-glyph-commands lily-image-commands lily-rebuild-pdfs
|
||||||
_pictures_scripts="cachepic epspdf epspdftk fig4latex mathspic"
|
m-tx musixtex musixflx pmx2pdf pmxchords"
|
||||||
|
_pictures_scripts="cachepic epspdf epspdftk fig4latex mathspic mkpic"
|
||||||
_pstricks_scripts="pedigree pst2pdf"
|
_pstricks_scripts="pedigree pst2pdf"
|
||||||
_science_scripts="ulqda"
|
_science_scripts="ulqda"
|
||||||
for s in \
|
for s in \
|
||||||
${_bibtexextra_scripts} \
|
${_bibtexextra_scripts} \
|
||||||
${_core_scripts} \
|
${_core_scripts} \
|
||||||
|
${_games_scripts} \
|
||||||
${_htmlxml_scripts} \
|
${_htmlxml_scripts} \
|
||||||
${_langcjk_scripts} \
|
|
||||||
${_langcyrillic_scripts} \
|
${_langcyrillic_scripts} \
|
||||||
${_langextra_scripts} \
|
${_langextra_scripts} \
|
||||||
${_langgreek_scripts} \
|
${_langgreek_scripts} \
|
||||||
|
${_langjapanese_scripts} \
|
||||||
|
${_langkorean_scripts} \
|
||||||
${_latexextra_scripts} \
|
${_latexextra_scripts} \
|
||||||
${_music_scripts} \
|
${_music_scripts} \
|
||||||
${_pictures_scripts} \
|
${_pictures_scripts} \
|
||||||
|
|
|
@ -1,104 +0,0 @@
|
||||||
--- trunk/source/texk/web2c/luatexdir/image/epdf.h 2013/01/20 19:58:26 4559
|
|
||||||
+++ trunk/source/texk/web2c/luatexdir/image/epdf.h 2014/01/02 15:35:31 4718
|
|
||||||
@@ -40,21 +40,22 @@
|
|
||||||
# include <goo/GooString.h>
|
|
||||||
# include <goo/gmem.h>
|
|
||||||
# include <goo/gfile.h>
|
|
||||||
-# include "Object.h"
|
|
||||||
-# include "Stream.h"
|
|
||||||
-# include "Gfx.h"
|
|
||||||
-# include "Annot.h"
|
|
||||||
-# include "Array.h"
|
|
||||||
-# include "Dict.h"
|
|
||||||
-# include "XRef.h"
|
|
||||||
-# include "Catalog.h"
|
|
||||||
-# include "Link.h"
|
|
||||||
-# include "Page.h"
|
|
||||||
-# include "GfxFont.h"
|
|
||||||
-# include "PDFDoc.h"
|
|
||||||
-# include "GlobalParams.h"
|
|
||||||
-# include "Error.h"
|
|
||||||
-# include "FileSpec.h"
|
|
||||||
+# include <Object.h>
|
|
||||||
+# include <Stream.h>
|
|
||||||
+# include <Gfx.h>
|
|
||||||
+# include <Annot.h>
|
|
||||||
+# include <Array.h>
|
|
||||||
+# include <Dict.h>
|
|
||||||
+# include <XRef.h>
|
|
||||||
+# include <Catalog.h>
|
|
||||||
+# include <StructTreeRoot.h>
|
|
||||||
+# include <Link.h>
|
|
||||||
+# include <Page.h>
|
|
||||||
+# include <GfxFont.h>
|
|
||||||
+# include <PDFDoc.h>
|
|
||||||
+# include <GlobalParams.h>
|
|
||||||
+# include <Error.h>
|
|
||||||
+# include <FileSpec.h>
|
|
||||||
|
|
||||||
extern "C" {
|
|
||||||
|
|
||||||
@@ -81,8 +82,8 @@
|
|
||||||
# include "utils/avlstuff.h"
|
|
||||||
# include "pdf/pdftypes.h"
|
|
||||||
|
|
||||||
-# include "lua52/lua.h"
|
|
||||||
-# include "lua52/lauxlib.h"
|
|
||||||
+# include "lua.h"
|
|
||||||
+# include "lauxlib.h"
|
|
||||||
|
|
||||||
/* pdfgen.w */
|
|
||||||
extern int ten_pow[10];
|
|
||||||
--- trunk/source/texk/web2c/luatexdir/lua/lepdflib.cc 2013/04/05 10:54:08 4629
|
|
||||||
+++ trunk/source/texk/web2c/luatexdir/lua/lepdflib.cc 2014/01/02 15:35:31 4718
|
|
||||||
@@ -65,6 +65,7 @@
|
|
||||||
#define M_PDFRectangle "PDFRectangle"
|
|
||||||
#define M_Ref "Ref"
|
|
||||||
#define M_Stream "Stream"
|
|
||||||
+#define M_StructTreeRoot "StructTreeRoot"
|
|
||||||
#define M_XRefEntry "XRefEntry"
|
|
||||||
#define M_XRef "XRef"
|
|
||||||
|
|
||||||
@@ -96,6 +97,7 @@
|
|
||||||
new_poppler_userdata(PDFRectangle);
|
|
||||||
new_poppler_userdata(Ref);
|
|
||||||
new_poppler_userdata(Stream);
|
|
||||||
+new_poppler_userdata(StructTreeRoot);
|
|
||||||
new_poppler_userdata(XRef);
|
|
||||||
|
|
||||||
//**********************************************************************
|
|
||||||
@@ -573,7 +575,11 @@
|
|
||||||
|
|
||||||
m_poppler_get_GOOSTRING(Catalog, getBaseURI);
|
|
||||||
m_poppler_get_GOOSTRING(Catalog, readMetadata);
|
|
||||||
+#ifdef GETSTRUCTTREEROOT_RETURNS_OBJECT
|
|
||||||
m_poppler_get_poppler(Catalog, Object, getStructTreeRoot);
|
|
||||||
+#else
|
|
||||||
+m_poppler_get_poppler(Catalog, StructTreeRoot, getStructTreeRoot);
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
static int m_Catalog_findPage(lua_State * L)
|
|
||||||
{
|
|
||||||
@@ -2146,14 +2152,22 @@
|
|
||||||
|
|
||||||
static int m_PDFDoc_getStructTreeRoot(lua_State * L)
|
|
||||||
{
|
|
||||||
+#ifdef GETSTRUCTTREEROOT_RETURNS_OBJECT
|
|
||||||
Object *obj;
|
|
||||||
+#else
|
|
||||||
+ StructTreeRoot *obj;
|
|
||||||
+#endif
|
|
||||||
udstruct *uin, *uout;
|
|
||||||
uin = (udstruct *) luaL_checkudata(L, 1, M_PDFDoc);
|
|
||||||
if (uin->pd != NULL && uin->pd->pc != uin->pc)
|
|
||||||
pdfdoc_changed_error(L);
|
|
||||||
if (((PdfDocument *) uin->d)->doc->getCatalog()->isOk()) {
|
|
||||||
obj = ((PdfDocument *) uin->d)->doc->getStructTreeRoot();
|
|
||||||
+#ifdef GETSTRUCTTREEROOT_RETURNS_OBJECT
|
|
||||||
uout = new_Object_userdata(L);
|
|
||||||
+#else
|
|
||||||
+ uout = new_StructTreeRoot_userdata(L);
|
|
||||||
+#endif
|
|
||||||
uout->d = obj;
|
|
||||||
uout->pc = uin->pc;
|
|
||||||
uout->pd = uin->pd;
|
|
|
@ -26,15 +26,14 @@ post_upgrade() {
|
||||||
fi
|
fi
|
||||||
_pacout=$(pacman -Q texlive-core 2>/dev/null)
|
_pacout=$(pacman -Q texlive-core 2>/dev/null)
|
||||||
read corename corever <<< ${_pacout}
|
read corename corever <<< ${_pacout}
|
||||||
if [[ ${corever} == 2012* ]]; then
|
# only recreate formats if texlive-core has right version
|
||||||
|
if [[ ${corever} == 2014* ]]; then
|
||||||
if [[ -f usr/bin/fmtutil-sys ]]; then
|
if [[ -f usr/bin/fmtutil-sys ]]; then
|
||||||
echo -n "recreating all formats..."
|
echo -n "recreating all formats..."
|
||||||
usr/bin/fmtutil-sys --all 1>/dev/null
|
usr/bin/fmtutil-sys --all 1>/dev/null
|
||||||
echo " done."
|
echo " done."
|
||||||
echo " (logs are under /var/lib/texmf/web2c/<engine>/<formatname>.log)"
|
echo " (logs are under /var/lib/texmf/web2c/<engine>/<formatname>.log)"
|
||||||
fi
|
fi
|
||||||
else
|
|
||||||
echo "WARNING: not recreating formats since texlive-core has version '$corever'"
|
|
||||||
fi
|
fi
|
||||||
[[ -x usr/bin/install-info ]] || return 0
|
[[ -x usr/bin/install-info ]] || return 0
|
||||||
for file in "${filelist[@]}"; do
|
for file in "${filelist[@]}"; do
|
||||||
|
|
Loading…
Reference in a new issue