mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
community/seamonkey to 2.53.2-1
This commit is contained in:
parent
5bd18777a2
commit
a759dc142c
7 changed files with 72 additions and 114 deletions
|
@ -6,66 +6,52 @@
|
|||
highmem=1
|
||||
|
||||
pkgname=seamonkey
|
||||
pkgver=2.49.4
|
||||
pkgrel=5
|
||||
pkgver=2.53.2
|
||||
pkgrel=1
|
||||
pkgdesc="SeaMonkey internet suite"
|
||||
arch=('x86_64')
|
||||
license=('MPL')
|
||||
depends=('alsa-lib' 'dbus-glib' 'desktop-file-utils' 'gtk2' 'gtk3' 'hunspell' 'libevent' 'libnotify' 'libvpx' 'libxt' 'mime-types' 'mozilla-common' 'nss' 'sqlite' 'startup-notification' 'libpulse' 'icu')
|
||||
makedepends=('unzip' 'zip' 'python2' 'yasm' 'mesa' 'autoconf2.13' 'imake' 'python3' 'gst-plugins-base')
|
||||
optdepends=('gst-plugins-base: vorbis decoding, ogg demuxing'
|
||||
'gst-plugins-bad: aac, vp8 and opus decoding'
|
||||
'gst-plugins-good: webm and mp4 demuxing'
|
||||
'gst-plugins-ugly: h.264 decoding'
|
||||
'networkmanager: Location detection via available WiFi networks')
|
||||
depends=('dbus-glib' 'gtk3' 'hunspell' 'icu'
|
||||
'libevent' 'libpulse' 'libvpx' 'libxt' 'mime-types'
|
||||
'nss' 'sqlite' 'startup-notification')
|
||||
makedepends=('autoconf2.13' 'clang' 'gtk2' 'imake' 'llvm' 'mesa' 'python2-setuptools'
|
||||
'python2-psutil' 'rust' 'yasm' 'unzip' 'zip')
|
||||
optdepends=('networkmanager: Location detection via available WiFi networks'
|
||||
'libnotify: Notification integration'
|
||||
'pulseaudio: Audio support')
|
||||
url="https://www.seamonkey-project.org/"
|
||||
source=("https://archive.mozilla.org/pub/mozilla.org/seamonkey/releases/$pkgver/source/seamonkey-$pkgver.source.tar.xz"
|
||||
mozconfig
|
||||
seamonkey-2.0-lang.patch
|
||||
patch-bug1435212.xz
|
||||
gettid.patch
|
||||
no-crmf.diff
|
||||
xulrunner-27.0-build-arm.patch)
|
||||
sha256sums=('c8a66774d0a3525698b559fa2c41397186f2de99c5733e35b8eafb0ae5ccc4ee'
|
||||
'6ff9fd323eec175eb02cfefd3136c79491c3b40be0b1f899da7c75c2f76259ca'
|
||||
'ab19d10fbd6258aec37ab5e5efb12429814b2c24a1193284a48dd654311b4e2e'
|
||||
'dce68858694f820a9a1fc2428038a88ea00b4835cea0778734db794fea3bb21a'
|
||||
'923154d052f041af15a2495ceb1f76f7c8619fd8bfc66a0bbedfeab2514adf0b'
|
||||
'fb85a538044c15471c12cf561d6aa74570f8de7b054a7063ef88ee1bdfc1ccbb'
|
||||
source=("https://archive.mozilla.org/pub/seamonkey/releases/$pkgver/source/seamonkey-$pkgver.source.tar.xz"
|
||||
"mozconfig"
|
||||
"xulrunner-27.0-build-arm.patch")
|
||||
sha256sums=('d339a2968191368b3444635cf91d19b73d6499566c27e3833150d16083448a83'
|
||||
'ad6ba5338340498971219eed6246b4ae27427511e126f4b3ad1b6f305883b8b7'
|
||||
'bc83b8a51c81a401da2fbe1f7cd0843248c32607d3a51119585df074d797922e')
|
||||
install="$pkgname.install"
|
||||
|
||||
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
|
||||
# Note: These are for Arch Linux use ONLY. For your own distribution, please
|
||||
# get your own set of keys. Feel free to contact foutrelis@archlinux.org for
|
||||
# more information.
|
||||
_google_api_key=AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM
|
||||
|
||||
# Mozilla API keys (see https://location.services.mozilla.com/api)
|
||||
# Note: These are for Arch Linux use ONLY. For your own distribution, please
|
||||
# get your own set of keys. Feel free to contact heftig@archlinux.org for
|
||||
# more information.
|
||||
_mozilla_api_key=e05d56db0a694edc8b5aaebda3f2db6a
|
||||
|
||||
prepare() {
|
||||
cd "$pkgname-$pkgver"
|
||||
cp ../mozconfig .mozconfig
|
||||
#patch -Np1 -i ../seamonkey-2.0-lang.patch
|
||||
|
||||
# FS#48404
|
||||
#echo "ac_add_options --enable-gstreamer=1.0" >> .mozconfig
|
||||
echo -n "$_google_api_key" > google-api-key
|
||||
echo -n "$_mozilla_api_key" > mozilla-api-key
|
||||
|
||||
# ffmpeg 4.0 patch from freebsd
|
||||
# https://github.com/freebsd/freebsd-ports/blob/master/www/seamonkey/files/patch-bug1435212
|
||||
patch -Np1 -d mozilla -i ../../patch-bug1435212
|
||||
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1533969
|
||||
patch -Np1 -i ../gettid.patch
|
||||
|
||||
# Don't exit with error when some libs are missing which we have in
|
||||
# system.
|
||||
sed -i '/^MOZ_PKG_FATAL_WARNINGS/s@= 1@= 0@' suite/installer/Makefile.in
|
||||
|
||||
# configure script misdetects the preprocessor without an optimization level
|
||||
sed -i '/ac_cpp=/s/$CPPFLAGS/& -O2/' configure
|
||||
|
||||
# 2.26 build fix from wgnie (blfs ch 37)
|
||||
sed -i 's/$(MOZ_ZLIB_CFLAGS)/& $(MOZ_PIXMAN_CFLAGS)/' config/config.mk
|
||||
|
||||
# work around from FS#54395
|
||||
patch -Np1 -d mozilla -i ../../no-crmf.diff
|
||||
sed -i "s/'crmf',//" mozilla/security/manager/ssl/moz.build
|
||||
sed -i 's/^.*-lcrmf/#&/' mozilla/config/external/nss/crmf/moz.build
|
||||
sed -i 's/ -lcrmf"/"/' mozilla/old-configure.in.orig
|
||||
sed -i 's/ -lcrmf"/"/' mozilla/old-configure
|
||||
sed -i 's/SDK_LIBS = crmf/SDK_LIBS = /' mozilla/config/external/nss/Makefile.in
|
||||
cat >> .mozconfig <<EOF
|
||||
ac_add_options --with-google-location-service-api-keyfile=${PWD@Q}/google-api-key
|
||||
ac_add_options --with-google-safebrowsing-api-keyfile=${PWD@Q}/google-api-key
|
||||
ac_add_options --with-mozilla-api-keyfile=${PWD@Q}/mozilla-api-key
|
||||
EOF
|
||||
|
||||
[[ $CARCH != "aarch64" ]] && echo "ac_add_options --disable-elf-hack" >> .mozconfig
|
||||
LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
|
||||
|
@ -75,39 +61,24 @@ prepare() {
|
|||
build() {
|
||||
cd "$pkgname-$pkgver"
|
||||
|
||||
export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/seamonkey-$pkgver"
|
||||
export MOZ_MAKE_FLAGS="$MAKEFLAGS"
|
||||
unset MAKEFLAGS
|
||||
unset CPPFLAGS
|
||||
|
||||
# GCC 6
|
||||
CFLAGS+=" -fno-delete-null-pointer-checks -fno-lifetime-dse -fno-schedule-insns2"
|
||||
CXXFLAGS+=" -fno-delete-null-pointer-checks -fno-lifetime-dse -fno-schedule-insns2"
|
||||
|
||||
# GCC 9
|
||||
CXXFLAGS+=" -Wno-format-overflow"
|
||||
|
||||
make -j1 -f client.mk build
|
||||
make -f client.mk build
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$pkgname-$pkgver"
|
||||
|
||||
make -j1 -f client.mk DESTDIR="$pkgdir" INSTALL_SDK= install
|
||||
make -f client.mk DESTDIR="$pkgdir" INSTALL_SDK= install
|
||||
|
||||
rm -rf "$pkgdir"/usr/lib/seamonkey-$pkgver/{dictionaries,hyphenation}
|
||||
ln -s /usr/share/hunspell "$pkgdir/usr/lib/seamonkey-$pkgver/dictionaries"
|
||||
ln -s /usr/share/hyphen "$pkgdir/usr/lib/seamonkey-$pkgver/hyphenation"
|
||||
rm -rf "$pkgdir"/usr/lib/seamonkey/{dictionaries,hyphenation}
|
||||
ln -s /usr/share/hunspell "$pkgdir/usr/lib/seamonkey/dictionaries"
|
||||
ln -s /usr/share/hyphen "$pkgdir/usr/lib/seamonkey/hyphenation"
|
||||
|
||||
install -Dm644 suite/branding/nightly/icons/gtk/seamonkey.png \
|
||||
"$pkgdir/usr/share/pixmaps/seamonkey.png"
|
||||
install -Dm644 suite/branding/seamonkey/default128.png \
|
||||
"$pkgdir/usr/share/pixmaps/seamonkey.png"
|
||||
|
||||
install -Dm644 mozilla/toolkit/mozapps/installer/linux/rpm/mozilla.desktop \
|
||||
"$pkgdir/usr/share/applications/seamonkey.desktop"
|
||||
sed -i 's/@MOZ_APP_DISPLAYNAME@/SeaMonkey internet suite/' \
|
||||
"$pkgdir/usr/share/applications/seamonkey.desktop"
|
||||
sed -i 's/@MOZ_APP_NAME@/seamonkey/' "$pkgdir/usr/share/applications/seamonkey.desktop"
|
||||
|
||||
rm -f "$pkgdir/usr/lib/pkgconfig/"seamonkey-ns{s,pr}.pc
|
||||
#rm -r "$pkgdir"/usr/{include,lib/seamonkey-devel-$pkgver,share/idl}
|
||||
}
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
--- seamonkey-2.49.4/mozilla/tools/profiler/core/platform.h.orig 2020-04-09 05:40:25.587372314 +0300
|
||||
+++ seamonkey-2.49.4/mozilla/tools/profiler/core/platform.h 2020-04-09 05:41:24.195387788 +0300
|
||||
@@ -65,10 +65,6 @@
|
||||
#include <unistd.h>
|
||||
#if !defined(__BIONIC__)
|
||||
#include <sys/syscall.h>
|
||||
-static inline pid_t gettid()
|
||||
-{
|
||||
- return (pid_t) syscall(SYS_gettid);
|
||||
-}
|
||||
#endif
|
||||
#endif
|
||||
|
|
@ -10,8 +10,8 @@ ac_add_options --with-system-jpeg
|
|||
ac_add_options --with-system-zlib
|
||||
ac_add_options --with-system-bz2
|
||||
ac_add_options --with-system-png
|
||||
#ac_add_options --with-system-libevent
|
||||
ac_add_options --with-system-libvpx
|
||||
ac_add_options --with-system-libevent
|
||||
#ac_add_options --with-system-libvpx
|
||||
ac_add_options --enable-system-hunspell
|
||||
ac_add_options --enable-system-sqlite
|
||||
ac_add_options --enable-system-ffi
|
||||
|
@ -19,14 +19,19 @@ ac_add_options --enable-system-ffi
|
|||
ac_add_options --with-pthreads
|
||||
ac_add_options --enable-system-pixman
|
||||
ac_add_options --disable-gconf
|
||||
ac_add_options --with-system-icu
|
||||
|
||||
# Features
|
||||
ac_add_options --enable-startup-notification
|
||||
ac_add_options --enable-safe-browsing
|
||||
ac_add_options --enable-gio
|
||||
#ac_add_options --enable-safe-browsing
|
||||
#ac_add_options --enable-gio
|
||||
#ac_add_options --disable-gstreamer
|
||||
ac_add_options --enable-pulseaudio
|
||||
|
||||
ac_add_options --enable-calendar
|
||||
ac_add_options --enable-irc
|
||||
ac_add_options --enable-dominspector
|
||||
|
||||
ac_add_options --enable-optimize="-O2"
|
||||
ac_add_options --enable-strip
|
||||
ac_add_options --enable-install-strip
|
||||
|
@ -37,4 +42,12 @@ ac_add_options --disable-updater
|
|||
ac_add_options --disable-tests
|
||||
#ac_add_options --disable-installer
|
||||
|
||||
ac_add_options --disable-webrender
|
||||
ac_add_options --disable-stylo
|
||||
|
||||
export MOZILLA_OFFICIAL=1
|
||||
export CC=clang
|
||||
export CXX=clang++
|
||||
export AR=llvm-ar
|
||||
export NM=llvm-nm
|
||||
export RANLIB=llvm-ranlib
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
diff --git i/old-configure.in w/old-configure.in
|
||||
index 0a06e470d2085922..d41c8e9d5dd2dbfb 100644
|
||||
--- i/old-configure.in
|
||||
+++ w/old-configure.in
|
||||
@@ -2020,9 +2020,7 @@ if test -n "$_USE_SYSTEM_NSS"; then
|
||||
AM_PATH_NSS(3.31, [MOZ_SYSTEM_NSS=1], [AC_MSG_ERROR([you don't have NSS installed or your version is too old])])
|
||||
fi
|
||||
|
||||
-if test -n "$MOZ_SYSTEM_NSS"; then
|
||||
- NSS_LIBS="$NSS_LIBS -lcrmf"
|
||||
-else
|
||||
+if test -z "$MOZ_SYSTEM_NSS"; then
|
||||
NSS_CFLAGS="-I${DIST}/include/nss"
|
||||
case "${OS_ARCH}" in
|
||||
# Only few platforms have been tested with GYP
|
Binary file not shown.
|
@ -1,11 +0,0 @@
|
|||
--- comm-1.9.1/mozilla/modules/libpref/src/init/all.js 2009-10-11 02:12:44.000000000 +0200
|
||||
+++ comm-1.9.1/mozilla/modules/libpref/src/init/all.js 2009-09-16 02:56:45.000000000 +0200
|
||||
@@ -890,7 +890,7 @@
|
||||
pref("intl.charset.detector", "chrome://global/locale/intl.properties");
|
||||
pref("intl.charset.default", "chrome://global-platform/locale/intl.properties");
|
||||
pref("intl.ellipsis", "chrome://global-platform/locale/intl.properties");
|
||||
-pref("intl.locale.matchOS", false);
|
||||
+pref("intl.locale.matchOS", true);
|
||||
// fallback charset list for Unicode conversion (converting from Unicode)
|
||||
// currently used for mail send only to handle symbol characters (e.g Euro, trademark, smartquotes)
|
||||
// for ISO-8859-1
|
13
community/seamonkey/seamonkey.install
Normal file
13
community/seamonkey/seamonkey.install
Normal file
|
@ -0,0 +1,13 @@
|
|||
post_upgrade() {
|
||||
# This currently triggers every time the new version has a pkgver (not pkgrel)
|
||||
# greater than the previous version. Rationale: upstream's prominent release
|
||||
# notes as described here: https://bbs.archlinux.org/viewtopic.php?pid=1903689#p1903689
|
||||
if (( $(vercmp $2 ${1%-*}) < 0 )); then
|
||||
cat << __EOF__
|
||||
SeaMonkey ${1%-*} makes changes to your profile that can't be reverted in case
|
||||
you want to go back to a previous version of SeaMonkey. Make a full backup of
|
||||
your profile and thoroughly read and follow the Release Notes at
|
||||
https://www.seamonkey-project.org/releases/seamonkey${1%-*}."
|
||||
__EOF__
|
||||
fi
|
||||
}
|
Loading…
Reference in a new issue