mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/dhcp to 4.4.2.P1-1
This commit is contained in:
parent
3831b9b198
commit
a7aa8841c7
2 changed files with 138 additions and 15 deletions
117
extra/dhcp/0003-117-fixed-gcc-10-compilation-issues.patch
Normal file
117
extra/dhcp/0003-117-fixed-gcc-10-compilation-issues.patch
Normal file
|
@ -0,0 +1,117 @@
|
|||
From 6c7e61578b1b449272dbb40dd8b98d03dad8a57a Mon Sep 17 00:00:00 2001
|
||||
From: Thomas Markwalder <tmark@isc.org>
|
||||
Date: Thu, 30 Jul 2020 10:01:36 -0400
|
||||
Subject: [PATCH] [#117] Fixed gcc 10 compilation issues
|
||||
|
||||
client/dhclient.c
|
||||
relay/dhcrelay.c
|
||||
extern'ed local_port,remote_port
|
||||
|
||||
common/discover.c
|
||||
init local_port,remote_port to 0
|
||||
|
||||
server/mdb.c
|
||||
extern'ed dhcp_type_host
|
||||
|
||||
server/mdb6.c
|
||||
create_prefix6() - eliminated memcpy string overflow error
|
||||
---
|
||||
RELNOTES | 5 +++++
|
||||
client/dhclient.c | 5 +++--
|
||||
common/discover.c | 4 ++--
|
||||
relay/dhcrelay.c | 4 ++--
|
||||
server/mdb.c | 2 +-
|
||||
server/mdb6.c | 2 +-
|
||||
6 files changed, 14 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/RELNOTES b/RELNOTES
|
||||
index 9d0a0414..6919dba7 100644
|
||||
--- a/RELNOTES
|
||||
+++ b/RELNOTES
|
||||
@@ -103,6 +103,11 @@ ISC DHCP is open source software maintained by Internet Systems
|
||||
Consortium. This product includes cryptographic software written
|
||||
by Eric Young (eay@cryptsoft.com).
|
||||
|
||||
+ Changes since 4.4.2 (Bug Fixes)
|
||||
+
|
||||
+- Minor corrections to allow compilation under gcc 10.
|
||||
+ [Gitlab #117]
|
||||
+
|
||||
Changes since 4.4.2b1 (Bug Fixes)
|
||||
|
||||
- Added a clarification on DHCPINFORMs and server authority to
|
||||
diff --git a/client/dhclient.c b/client/dhclient.c
|
||||
index 189e5270..7a7837cb 100644
|
||||
--- a/client/dhclient.c
|
||||
+++ b/client/dhclient.c
|
||||
@@ -83,8 +83,9 @@ static const char message [] = "Internet Systems Consortium DHCP Client";
|
||||
static const char url [] = "For info, please visit https://www.isc.org/software/dhcp/";
|
||||
#endif /* UNIT_TEST */
|
||||
|
||||
-u_int16_t local_port = 0;
|
||||
-u_int16_t remote_port = 0;
|
||||
+extern u_int16_t local_port;
|
||||
+extern u_int16_t remote_port;
|
||||
+
|
||||
#if defined(DHCPv6) && defined(DHCP4o6)
|
||||
int dhcp4o6_state = -1; /* -1 = stopped, 0 = polling, 1 = started */
|
||||
#endif
|
||||
diff --git a/common/discover.c b/common/discover.c
|
||||
index ca4f4d55..22f09767 100644
|
||||
--- a/common/discover.c
|
||||
+++ b/common/discover.c
|
||||
@@ -45,8 +45,8 @@ struct interface_info *fallback_interface = 0;
|
||||
|
||||
int interfaces_invalidated;
|
||||
int quiet_interface_discovery;
|
||||
-u_int16_t local_port;
|
||||
-u_int16_t remote_port;
|
||||
+u_int16_t local_port = 0;
|
||||
+u_int16_t remote_port = 0;
|
||||
u_int16_t relay_port = 0;
|
||||
int dhcpv4_over_dhcpv6 = 0;
|
||||
int (*dhcp_interface_setup_hook) (struct interface_info *, struct iaddr *);
|
||||
diff --git a/relay/dhcrelay.c b/relay/dhcrelay.c
|
||||
index 883d5058..7211e3bb 100644
|
||||
--- a/relay/dhcrelay.c
|
||||
+++ b/relay/dhcrelay.c
|
||||
@@ -95,8 +95,8 @@ enum { forward_and_append, /* Forward and append our own relay option. */
|
||||
forward_untouched, /* Forward without changes. */
|
||||
discard } agent_relay_mode = forward_and_replace;
|
||||
|
||||
-u_int16_t local_port;
|
||||
-u_int16_t remote_port;
|
||||
+extern u_int16_t local_port;
|
||||
+extern u_int16_t remote_port;
|
||||
|
||||
/* Relay agent server list. */
|
||||
struct server_list {
|
||||
diff --git a/server/mdb.c b/server/mdb.c
|
||||
index ff8a707f..8266d764 100644
|
||||
--- a/server/mdb.c
|
||||
+++ b/server/mdb.c
|
||||
@@ -67,7 +67,7 @@ static host_id_info_t *host_id_info = NULL;
|
||||
|
||||
int numclasseswritten;
|
||||
|
||||
-omapi_object_type_t *dhcp_type_host;
|
||||
+extern omapi_object_type_t *dhcp_type_host;
|
||||
|
||||
isc_result_t enter_class(cd, dynamicp, commit)
|
||||
struct class *cd;
|
||||
diff --git a/server/mdb6.c b/server/mdb6.c
|
||||
index da7baf6e..ebe01e56 100644
|
||||
--- a/server/mdb6.c
|
||||
+++ b/server/mdb6.c
|
||||
@@ -1945,7 +1945,7 @@ create_prefix6(struct ipv6_pool *pool, struct iasubopt **pref,
|
||||
}
|
||||
new_ds.data = new_ds.buffer->data;
|
||||
memcpy(new_ds.buffer->data, ds.data, ds.len);
|
||||
- memcpy(new_ds.buffer->data + ds.len, &tmp, sizeof(tmp));
|
||||
+ memcpy(&new_ds.buffer->data[0] + ds.len, &tmp, sizeof(tmp));
|
||||
data_string_forget(&ds, MDL);
|
||||
data_string_copy(&ds, &new_ds, MDL);
|
||||
data_string_forget(&new_ds, MDL);
|
||||
--
|
||||
GitLab
|
||||
|
|
@ -10,37 +10,43 @@ pkgbase=dhcp
|
|||
pkgname=('dhcp' 'dhclient')
|
||||
|
||||
# separate patch levels with a period to maintain proper versioning.
|
||||
pkgver=4.4.2
|
||||
pkgrel=2
|
||||
_realver=4.4.2-P1
|
||||
pkgver=${_realver/-/.}
|
||||
pkgrel=1
|
||||
arch=('x86_64')
|
||||
license=('custom:isc-dhcp')
|
||||
url='https://www.isc.org/dhcp/'
|
||||
makedepends=('bash' 'iproute2' 'openldap')
|
||||
validpgpkeys=('AE3FAC796711EC59FC007AA474BB6B9A4CBB3D38') # Internet Systems Consortium, Inc. (Signing key, 2019-2020) <codesign@isc.org>
|
||||
source=("https://downloads.isc.org/isc/${pkgbase}/${pkgver}/${pkgbase}-${pkgver}.tar.gz"{,.asc}
|
||||
validpgpkeys=('7E1C91AC8030A5A59D1EFAB9750F3C87723E4012') # Internet Systems Consortium, Inc. (Signing key, 2021-2022) <codesign@isc.org>
|
||||
source=("https://downloads.isc.org/isc/${pkgbase}/${_realver}/${pkgbase}-${_realver}.tar.gz"{,.asc}
|
||||
'0002-iproute2.patch'
|
||||
'0003-117-fixed-gcc-10-compilation-issues.patch'
|
||||
'fix-variable-name-in-conditional-block.patch'
|
||||
'dhcp-sysusers.conf'
|
||||
'dhcp-tmpfiles.conf'
|
||||
'dhcpd4.service'
|
||||
'dhcpd6.service'
|
||||
'dhclient@.service'
|
||||
'0002-iproute2.patch'
|
||||
'fix-variable-name-in-conditional-block.patch')
|
||||
sha256sums=('1a7ccd64a16e5e68f7b5e0f527fd07240a2892ea53fe245620f4f5f607004521'
|
||||
'dhclient@.service')
|
||||
sha256sums=('b05e04337539545a8faa0d6ac518defc61a07e5aec66a857f455e7f218c85a1a'
|
||||
'SKIP'
|
||||
'837a64189b949afae951655546967cc8f17f2f2cf370faabff00575364f0fcf7'
|
||||
'ab652f408a0730caa996df11bea608f279c5547acc849d5562a592ea19f67727'
|
||||
'895e655f320f3de0053d512d1915a3706f710f24c560ad811a48593a16ef3b34'
|
||||
'b16083e6bb572ffacaa7cd97e7fde5fcfa1b6dbeb166f162e2ec6e8ec4b928d6'
|
||||
'abcd30e9e8428e34d22ab4d3074ef4bd84c2b11f5868597111b47d6f56d204da'
|
||||
'03fce30efab819b2d928085b0bab962a33ce56fc376acae98ad9b30aa278c9c8'
|
||||
'f98a4438f4f69cab7cc5cce6927df4790ee993ebc8f88a169e63043c53d25625'
|
||||
'86cd0b1e0ea1d47ab096f6ee925eee60545116fb887a155761eda589b30e4f0e'
|
||||
'837a64189b949afae951655546967cc8f17f2f2cf370faabff00575364f0fcf7'
|
||||
'895e655f320f3de0053d512d1915a3706f710f24c560ad811a48593a16ef3b34')
|
||||
'86cd0b1e0ea1d47ab096f6ee925eee60545116fb887a155761eda589b30e4f0e')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${pkgbase}-${pkgver}"
|
||||
cd "${srcdir}/${pkgbase}-${_realver}"
|
||||
|
||||
# no ifconfig, use ip from iproute2
|
||||
patch -Np1 -i ../0002-iproute2.patch
|
||||
|
||||
# [#117] Fixed gcc 10 compilation issues
|
||||
patch -Np1 -i ../0003-117-fixed-gcc-10-compilation-issues.patch
|
||||
|
||||
cd bind
|
||||
bsdtar -xf bind.tar.gz
|
||||
cd bind-9.*
|
||||
|
@ -48,7 +54,7 @@ prepare() {
|
|||
}
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${pkgbase}-${pkgver}"
|
||||
cd "${srcdir}/${pkgbase}-${_realver}"
|
||||
|
||||
[[ $CARCH == "arm" || $CARCH == "armv6h" ]] && CONFIG='--with-bind-extra-config="--disable-atomic"'
|
||||
|
||||
|
@ -73,7 +79,7 @@ package_dhcp(){
|
|||
depends=('glibc' 'libldap')
|
||||
backup=('etc/dhcpd.conf' 'etc/dhcpd6.conf')
|
||||
|
||||
cd "${srcdir}/${pkgbase}-${pkgver}"
|
||||
cd "${srcdir}/${pkgbase}-${_realver}"
|
||||
|
||||
make DESTDIR="${pkgdir}" install
|
||||
|
||||
|
@ -98,7 +104,7 @@ package_dhclient(){
|
|||
depends=('glibc' 'bash' 'iproute2' 'run-parts')
|
||||
provides=('dhcp-client')
|
||||
|
||||
cd "${srcdir}/${pkgbase}-${pkgver}"
|
||||
cd "${srcdir}/${pkgbase}-${_realver}"
|
||||
|
||||
make -C client DESTDIR="${pkgdir}" install
|
||||
|
||||
|
|
Loading…
Reference in a new issue