mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/pipewire to 0.3.45-1.1
This commit is contained in:
parent
5bbeaf2d78
commit
a7dcc17bc5
2 changed files with 6 additions and 68 deletions
|
@ -1,53 +0,0 @@
|
|||
From 64a4a456897db045ebf94c2f801b888a172d138a Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 24 Oct 2021 17:01:30 -0600
|
||||
Subject: [PATCH] disable neon
|
||||
|
||||
---
|
||||
meson.build | 16 ----------------
|
||||
spa/plugins/support/cpu.c | 2 +-
|
||||
2 files changed, 1 insertion(+), 17 deletions(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 7172ee4f5..2251188f8 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -132,22 +132,6 @@ if host_machine.cpu_family() == 'aarch64'
|
||||
have_neon = true
|
||||
|
||||
endif
|
||||
-elif cc.has_argument('-mfpu=neon')
|
||||
- if cc.compiles('''
|
||||
- #include <arm_neon.h>
|
||||
- int main () {
|
||||
- float *s;
|
||||
- asm volatile(
|
||||
- " vld1.32 { q0 }, [%[s]]!\n"
|
||||
- " vcvt.s32.f32 q0, q0, #31\n"
|
||||
- : [s] "+r" (s) : :);
|
||||
- }
|
||||
- ''',
|
||||
- args: '-mfpu=neon',
|
||||
- name : 'arm Neon Support')
|
||||
- neon_args = ['-mfpu=neon']
|
||||
- have_neon = true
|
||||
- endif
|
||||
endif
|
||||
|
||||
libatomic = cc.find_library('atomic', required : false)
|
||||
diff --git a/spa/plugins/support/cpu.c b/spa/plugins/support/cpu.c
|
||||
index ee1816512..44fc279b0 100644
|
||||
--- a/spa/plugins/support/cpu.c
|
||||
+++ b/spa/plugins/support/cpu.c
|
||||
@@ -79,7 +79,7 @@ static char *read_file(const char *name, char *buffer, size_t len)
|
||||
#include "cpu-x86.c"
|
||||
#define init(t) x86_init(t)
|
||||
#define impl_cpu_zero_denormals x86_zero_denormals
|
||||
-# elif defined (__arm__) || defined (__aarch64__)
|
||||
+# elif defined (__aarch64__)
|
||||
#include "cpu-arm.c"
|
||||
#define init(t) arm_init(t)
|
||||
#define impl_cpu_zero_denormals arm_zero_denormals
|
||||
--
|
||||
2.33.0
|
||||
|
|
@ -1,32 +1,28 @@
|
|||
# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
|
||||
# Maintainer: David Runge <dvzrv@archlinux.org>
|
||||
# Contributor: Jan de Groot <jgc@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - remove makedepend on valgrind
|
||||
# - patch to disable neon
|
||||
# - cherry-pick upstream patch to fix neon disable
|
||||
# remove when bumped upstream
|
||||
|
||||
pkgbase=pipewire
|
||||
pkgname=(pipewire alsa-card-profiles pipewire-docs pipewire-alsa pipewire-jack
|
||||
pipewire-pulse gst-plugin-pipewire pipewire-zeroconf pipewire-v4l2 pipewire-x11-bell)
|
||||
pkgver=0.3.45
|
||||
pkgrel=1
|
||||
pkgrel=1.1
|
||||
epoch=1
|
||||
pkgdesc="Low-latency audio/video router and processor"
|
||||
url="https://pipewire.org"
|
||||
license=(MIT)
|
||||
arch=(x86_64)
|
||||
makedepends=(git meson doxygen graphviz python-docutils libpulse
|
||||
makedepends=(git meson doxygen graphviz python-docutils valgrind libpulse
|
||||
alsa-lib libusb gst-plugins-base rtkit dbus sdl2 ncurses libcanberra libsndfile
|
||||
bluez-libs sbc libldac libfreeaptx libfdk-aac avahi lilv
|
||||
webrtc-audio-processing)
|
||||
checkdepends=(desktop-file-utils)
|
||||
options=(debug)
|
||||
_commit=bdd407fe66cc9e46d4bc4dcc989d50679000482b # tags/0.3.45
|
||||
source=("git+https://gitlab.freedesktop.org/pipewire/pipewire.git#commit=$_commit"
|
||||
0001-disable-neon.patch)
|
||||
sha256sums=('SKIP'
|
||||
'03692caee572d9e9c5d4f68986533c24ed84163c1ad607c7a13ef50cc3f8558e')
|
||||
source=("git+https://gitlab.freedesktop.org/pipewire/pipewire.git#commit=$_commit")
|
||||
sha256sums=('SKIP')
|
||||
|
||||
pkgver() {
|
||||
cd pipewire
|
||||
|
@ -37,11 +33,6 @@ prepare() {
|
|||
cd pipewire
|
||||
# remove export of LD_LIBRARY_PATH for pw-jack as it would add /usr/lib
|
||||
sed -e '/LD_LIBRARY_PATH/d' -i pipewire-jack/src/pw-jack.in
|
||||
|
||||
if [[ $CARCH != "aarch64" ]]; then
|
||||
git cherry-pick -n 651f0decea5f83730c271e9bed03cdd0048fcd49
|
||||
patch -p1 -i ../0001-disable-neon.patch
|
||||
fi
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue