mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/mysql-workbench to 6.3.7-4
This commit is contained in:
parent
ccebe16cd7
commit
a80cd14866
2 changed files with 71 additions and 4 deletions
|
@ -0,0 +1,62 @@
|
|||
From 743c9cfb9d95f4dfcf2d4e1dc412fd5495100aac Mon Sep 17 00:00:00 2001
|
||||
From: Christian Hesse <mail@eworm.de>
|
||||
Date: Thu, 13 Oct 2016 10:56:55 +0200
|
||||
Subject: [PATCH 1/1] fix compilation with gcc 6.2.1
|
||||
|
||||
Compilation fails with recent versions of gcc with:
|
||||
|
||||
error: cannot convert 'Glib::RefPtr<Gdk::Colormap>' to 'bool' in
|
||||
assignment
|
||||
|
||||
and
|
||||
|
||||
error: no match for 'operator!=' (operand types are
|
||||
'Glib::RefPtr<Gdk::Window>' and 'int')
|
||||
|
||||
This fixes compilation with gcc 6.2.1.
|
||||
|
||||
Signed-off-by: Christian Hesse <mail@eworm.de>
|
||||
---
|
||||
library/forms/gtk/src/lf_popover.cpp | 4 ++--
|
||||
library/forms/gtk/src/lf_popup.cpp | 3 ++-
|
||||
2 files changed, 4 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/library/forms/gtk/src/lf_popover.cpp b/library/forms/gtk/src/lf_popover.cpp
|
||||
index 1a659a6..7502811 100644
|
||||
--- a/library/forms/gtk/src/lf_popover.cpp
|
||||
+++ b/library/forms/gtk/src/lf_popover.cpp
|
||||
@@ -380,7 +380,7 @@ void PopoverWidget::show_popover(const int rx, const int ry, const mforms::Start
|
||||
if (_style == mforms::PopoverStyleTooltip)
|
||||
{
|
||||
Glib::RefPtr<Gdk::Window> wnd = this->get_window();
|
||||
- if (wnd != 0)
|
||||
+ if (wnd)
|
||||
{
|
||||
int xx;
|
||||
int yy;
|
||||
@@ -396,7 +396,7 @@ void PopoverWidget::show_popover(const int rx, const int ry, const mforms::Start
|
||||
{
|
||||
Gdk::ModifierType mask;
|
||||
Glib::RefPtr<Gdk::Display> dsp = Gdk::Display::get_default();
|
||||
- if (dsp != 0)
|
||||
+ if (dsp)
|
||||
dsp->get_pointer(x, y, mask);
|
||||
}
|
||||
|
||||
diff --git a/library/forms/gtk/src/lf_popup.cpp b/library/forms/gtk/src/lf_popup.cpp
|
||||
index 289c511..5de3b49 100644
|
||||
--- a/library/forms/gtk/src/lf_popup.cpp
|
||||
+++ b/library/forms/gtk/src/lf_popup.cpp
|
||||
@@ -81,7 +81,8 @@ void PopupImpl::on_screen_changed(const Glib::RefPtr<Gdk::Screen>& screen)
|
||||
{
|
||||
d("\n");
|
||||
Glib::RefPtr<Gdk::Colormap> colormap = screen->get_rgba_colormap();
|
||||
- _have_rgba = colormap;
|
||||
+ if (colormap)
|
||||
+ _have_rgba = true;
|
||||
|
||||
if (!_have_rgba)
|
||||
colormap = screen->get_rgb_colormap();
|
||||
--
|
||||
2.10.0
|
||||
|
|
@ -10,8 +10,8 @@
|
|||
|
||||
pkgname=mysql-workbench
|
||||
pkgver=6.3.7
|
||||
pkgrel=3
|
||||
_mysql_version=5.7.15
|
||||
pkgrel=4
|
||||
_mysql_version=5.7.16
|
||||
_connector_version=1.1.7
|
||||
_gdal_version=2.1.1
|
||||
_boost_version=1.59.0
|
||||
|
@ -28,21 +28,23 @@ optdepends=('gnome-keyring: store SSH/MySQL passwords in GNOME password manager'
|
|||
makedepends=('cmake' 'boost' 'mesa' 'swig' 'imagemagick')
|
||||
validpgpkeys=('A4A9406876FCBD3C456770C88C718D3B5072E1F5')
|
||||
source=("http://cdn.mysql.com/Downloads/MySQLGUITools/mysql-workbench-community-${pkgver}-src.tar.gz"{,.asc}
|
||||
"http://cdn.mysql.com/Downloads/MySQL-5.7/mysql-${_mysql_version}.tar.gz"{,.asc}
|
||||
"http://cdn.mysql.com/Downloads/MySQL-${_mysql_version%.*}/mysql-${_mysql_version}.tar.gz"{,.asc}
|
||||
"http://cdn.mysql.com/Downloads/Connector-C++/mysql-connector-c++-${_connector_version}.tar.gz"{,.asc}
|
||||
"http://download.osgeo.org/gdal/${_gdal_version}/gdal-${_gdal_version}.tar.xz"
|
||||
"https://downloads.sourceforge.net/project/boost/boost/${_boost_version}/boost_${_boost_version//./_}.tar.bz2"
|
||||
'0001-mysql-workbench-no-check-for-updates.patch'
|
||||
'0002-fix-compilation-with-gcc-6.2.1.patch'
|
||||
'arch_linux_profile.xml')
|
||||
sha256sums=('84941f6dc33674a245d53a21bc14c5f0c192e370940147ddc7c236a61c0193ec'
|
||||
'SKIP'
|
||||
'9085353143bfda59c90aa959e79a35622a22aa592e710993416e193b37eb9956'
|
||||
'4935b59974edb275629f6724a0fcf72265a5845faf1e30eeb50ed4b6528318a5'
|
||||
'SKIP'
|
||||
'5b353fbcd26f607a2a0987ce78a4b811f8971813d46b0f4ae6fa07887e9fc763'
|
||||
'SKIP'
|
||||
'87ce516ce757ad1edf1e21f007fbe232ed2e932af422e9893f40199711c41f92'
|
||||
'727a932322d94287b62abb1bd2d41723eec4356a7728909e38adb65ca25241ca'
|
||||
'b189e15c6b6f5a707357d9a9297f39ee3a33264fd28b44d5de6f537f851f82cf'
|
||||
'2c429fc1d02e5bae38ef51da7b4b27c5f82571b43b04b0d2a414189c8fdb6db9'
|
||||
'2ade582ca25f6d6d748bc84a913de39b34dcaa6e621a77740fe143007f2833af')
|
||||
|
||||
prepare() {
|
||||
|
@ -52,6 +54,9 @@ prepare() {
|
|||
# Updates are provided via Arch Linux packages
|
||||
patch -Np1 < "${srcdir}"/0001-mysql-workbench-no-check-for-updates.patch
|
||||
|
||||
# fix compilation with gcc 6.2.1
|
||||
patch -Np1 < "${srcdir}"/0002-fix-compilation-with-gcc-6.2.1.patch
|
||||
|
||||
# we need python 2.x
|
||||
sed -i '/^FIND_PROGRAM(PYTHON_EXEC /c FIND_PROGRAM(PYTHON_EXEC "python2")' \
|
||||
CMakeLists.txt
|
||||
|
|
Loading…
Reference in a new issue