extra/mariadb to 10.1.32-1

This commit is contained in:
Kevin Mihelich 2018-04-01 18:45:24 +00:00
parent c8f1a151c4
commit a88422d99b
2 changed files with 4 additions and 25 deletions

View file

@ -1,24 +1,3 @@
diff --git a/extra/yassl/src/handshake.cpp b/extra/yassl/src/handshake.cpp
index 407e409..6e181a9 100644
--- a/extra/yassl/src/handshake.cpp
+++ b/extra/yassl/src/handshake.cpp
@@ -788,6 +788,16 @@ int DoProcessReply(SSL& ssl)
needHdr = true;
else {
buffer >> hdr;
+ /*
+ According to RFC 4346 (see "7.4.1.3. Server Hello"), the Server Hello
+ packet needs to specify the highest supported TLS version, but not
+ higher than what client requests. YaSSL highest supported version is
+ TLSv1.1 (=3.2) - if the client requests a higher version, downgrade it
+ here to 3.2.
+ See also Appendix E of RFC 5246 (TLS 1.2)
+ */
+ if (hdr.version_.major_ == 3 && hdr.version_.minor_ > 2)
+ hdr.version_.minor_ = 2;
ssl.verifyState(hdr);
}
diff --git a/include/ssl_compat.h b/include/ssl_compat.h
new file mode 100644
index 0000000..b0e3ed4
@ -150,7 +129,7 @@ diff --git a/mysql-test/mysql-test-run.pl b/mysql-test/mysql-test-run.pl
index eaec51b..1b28469 100755
--- a/mysql-test/mysql-test-run.pl
+++ b/mysql-test/mysql-test-run.pl
@@ -2301,6 +2301,11 @@ sub environment_setup {
@@ -2307,6 +2307,11 @@ sub environment_setup {
$ENV{'MYSQL_PLUGIN'}= $exe_mysql_plugin;
$ENV{'MYSQL_EMBEDDED'}= $exe_mysql_embedded;

View file

@ -8,7 +8,7 @@
pkgbase=mariadb
pkgname=('libmariadbclient' 'mariadb-clients' 'mytop' 'mariadb')
pkgver=10.1.31
pkgver=10.1.32
pkgrel=1
arch=('x86_64')
license=('GPL')
@ -20,9 +20,9 @@ source=("https://ftp.heanet.ie/mirrors/mariadb/mariadb-$pkgver/source/mariadb-$p
'0001-openssl-1-1-0.patch'
'0002-mroonga-after-merge-CMakeLists.txt-fixes.patch'
'atomic.patch')
sha256sums=('ab7641c2fe4e5289da6141766a9c3350e013def56fafd6f1377080bc8048b2e6'
sha256sums=('0e2aae6a6a190d07c8e36e87dd43377057fa82651ca3c583462563f3e9369096'
'SKIP'
'c209c939e5b27582df16fe7cef8fd31c2c574165dddce15d157bfcf9a1a38b2f'
'229d556748119757f36be1e9956834be28db0f5a35cdacce53f6c640784fca77'
'98736aefef21e575e450f8066685ba82771264409412e33491ab0a54e4407ba7'
'2ddfe7dc5eae905ed77d7438d6869f9bb26684945c2f82cc19f84926b1cb849f')