added extra/vlc

This commit is contained in:
Kevin Mihelich 2015-08-06 00:55:17 +00:00
parent e15f2f6a38
commit a89e4fc658
3 changed files with 158 additions and 0 deletions

110
extra/vlc/PKGBUILD Normal file
View file

@ -0,0 +1,110 @@
# $Id$
# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Sarah Hay <sarahhay@mb.sympatico.ca>
# Contributor: Martin Sandsmark <martin.sandsmark@kde.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - enable gles2
pkgname=vlc
pkgver=2.2.1
pkgrel=6.1
pkgdesc="A multi-platform MPEG, VCD/DVD, and DivX player"
arch=('i686' 'x86_64')
url="http://www.videolan.org/vlc/"
license=('LGPL2.1' 'GPL2')
depends=('a52dec' 'libdvbpsi' 'libxpm' 'libdca' 'qt4' 'libproxy'
'sdl_image' 'libdvdnav' 'libtiger' 'lua' 'libmatroska'
'zvbi' 'taglib' 'libmpcdec' 'ffmpeg' 'faad2' 'libupnp'
'libshout' 'libmad' 'libmpeg2' 'xcb-util-keysyms' 'libtar'
'libxinerama')
makedepends=('live-media' 'libnotify' 'libbluray' 'flac' 'kdelibs'
'libdc1394' 'libavc1394' 'lirc' 'libcaca' 'gtk2'
'librsvg' 'portaudio' 'libgme' 'xosd' 'projectm'
'twolame' 'aalib' 'libmtp' 'libdvdcss' 'gnome-vfs'
'libgoom2' 'vcdimager' 'opus' 'libssh2' 'mesa')
optdepends=('avahi: for service discovery using bonjour protocol'
'libnotify: for notification plugin'
'gtk2: for notify plugin'
'ncurses: for ncurses interface support'
'libdvdcss: for decoding encrypted DVDs'
'lirc: for lirc plugin'
'libavc1394: for devices using the 1394ta AV/C'
'libdc1394: for IEEE 1394 plugin'
'kdelibs: KDE Solid hardware integration'
'libva-vdpau-driver: vdpau back-end for nvidia'
'libva-intel-driver: back-end for intel cards'
'libbluray: for Blu-Ray support'
'flac: for Free Lossless Audio Codec plugin'
'portaudio: for portaudio support'
'twolame: for TwoLAME mpeg2 encoder plugin'
'projectm: for ProjectM visualisation plugin'
'libcaca: for colored ASCII art video output'
'libgme: for libgme plugin'
'librsvg: for SVG plugin'
'gnome-vfs: for GNOME Virtual File System support'
'libgoom2: for libgoom plugin'
'vcdimager: navigate VCD with libvcdinfo'
'aalib: for ASCII art plugin'
'libmtp: for MTP devices support'
'smbclient: for SMB access plugin'
'libcdio: for audio CD playback support'
'ttf-freefont: for subtitle font '
'ttf-dejavu: for subtitle font'
'opus: for opus support'
'libssh2: for sftp support'
'lua-socket: for http interface')
conflicts=('vlc-plugin')
replaces=('vlc-plugin')
backup=('usr/share/vlc/lua/http/.hosts'
'usr/share/vlc/lua/http/dialogs/.hosts')
options=('!emptydirs')
install=vlc.install
source=("http://download.videolan.org/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.xz"
"lua53_compat.patch")
md5sums=('42273945758b521c408fabc7fd6d9946'
'96d3b346d9149ffb1b430066dfb6249a')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
sed -i -e 's:truetype/freefont:TTF:g' modules/text_renderer/freetype.c
sed -i -e 's:truetype/ttf-dejavu:TTF:g' modules/visualization/projectm.cpp
patch -p1 < "${srcdir}/lua53_compat.patch"
}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
CFLAGS+=" -I/usr/include/samba-4.0" CPPFLAGS+=" -I/usr/include/samba-4.0" \
./configure --prefix=/usr \
--sysconfdir=/etc \
--disable-rpath \
--enable-faad \
--enable-nls \
--enable-lirc \
--enable-ncurses \
--enable-realrtsp \
--enable-aa \
--enable-vcdx \
--enable-upnp \
--enable-opus \
--enable-sftp \
--enable-gles2 \
LUAC=/usr/bin/luac LUA_LIBS="`pkg-config --libs lua`" \
RCC=/usr/bin/rcc-qt4
make
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
for res in 16 32 48 128; do
install -D -m644 "${srcdir}/vlc-${pkgver}/share/icons/${res}x${res}/vlc.png" \
"${pkgdir}/usr/share/icons/hicolor/${res}x${res}/apps/vlc.png"
done
}

View file

@ -0,0 +1,30 @@
commit 41caaa08cde60c4fec4bf2e5f9610e2a1b9e6a23
Author: Vinson Lee <vlee@freedesktop.org>
Date: Thu Feb 5 14:48:53 2015 -0800
lua: Define LUA_COMPAT_APIINTCASTS for Lua >= 5.3.0 compatibility.
In Lua 5.3.0, luaL_checkint was deprecated.
This patch fixes this build error with Lua 5.3.0.
lua/demux.c: In function vlclua_demux_peek:
lua/demux.c:55:5: error: implicit declaration of function luaL_checkint [-Werror=implicit-function-declaration]
int n = luaL_checkint( L, 1 );
^
Signed-off-by: Vinson Lee <vlee@freedesktop.org>
Signed-off-by: Jean-Baptiste Kempf <jb@videolan.org>
diff --git a/modules/lua/vlc.h b/modules/lua/vlc.h
index efd94f1..85c7fc1 100644
--- a/modules/lua/vlc.h
+++ b/modules/lua/vlc.h
@@ -38,6 +38,7 @@
#include <vlc_stream.h>
#include <vlc_demux.h>
+#define LUA_COMPAT_APIINTCASTS
#define LUA_COMPAT_MODULE
#include <lua.h> /* Low level lua C API */
#include <lauxlib.h> /* Higher level C API */

18
extra/vlc/vlc.install Normal file
View file

@ -0,0 +1,18 @@
post_install() {
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins
update-desktop-database -q
}
post_upgrade() {
post_install
}
pre_remove() {
rm -f usr/lib/vlc/plugins/plugins-*.dat
}
post_remove() {
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
update-desktop-database -q
}