extra/openmpi to 1.8.3-1

This commit is contained in:
Kevin Mihelich 2014-09-29 15:51:13 +00:00
parent 5121604766
commit a8a66102a6
2 changed files with 85 additions and 6 deletions

View file

@ -6,8 +6,8 @@
# - only use valgrind with v7
pkgname=openmpi
pkgver=1.8.2
pkgrel=1.1
pkgver=1.8.3
pkgrel=1
pkgdesc='High performance message passing library (MPI)'
arch=(i686 x86_64)
url='http://www.open-mpi.org'
@ -16,16 +16,24 @@ depends=(libltdl hwloc)
makedepends=(inetutils gcc-fortran)
optdepends=('gcc-fortran: fortran support')
options=(staticlibs)
source=(http://www.open-mpi.org/software/ompi/v1.8/downloads/${pkgname}-${pkgver}.tar.bz2)
sha1sums=('55067856b351cbeb5ebe8a430bfe0656115a04ed')
source=(http://www.open-mpi.org/software/ompi/v1.8/downloads/${pkgname}-${pkgver}.tar.bz2
system_ltdl.patch)
sha1sums=('4be9c5d2a8baee6a80bde94c6485931979a428fe'
'd5f8a3d463f1a1f29ca4725d6fb3b9f8c40799dc')
[[ $CARCH = armv7h ]] && makedepends+=('valgrind')
build() {
prepare() {
cd $pkgname-$pkgver
# Make sure we use the system ltdl library rather than the ones in the tarball
rm -r opal/libltdl
patch -p1 < ../system_ltdl.patch
./autogen.pl
}
build() {
cd $pkgname-$pkgver
# enable valgrind and memchecker for v7
[[ $CARCH = armv7h ]] && CONFIG='--with-valgrind --enable-memchecker'
@ -36,7 +44,6 @@ build() {
--libdir=/usr/lib/${pkgname} \
--with-threads=posix \
--enable-smp-locks \
--enable-debug \
--enable-pretty-print-stacktrace \
--without-slurm \
--with-hwloc=/usr \
@ -48,6 +55,12 @@ build() {
make
}
check() {
cd $pkgname-$pkgver
make check
}
package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install

View file

@ -0,0 +1,66 @@
diff --git a/config/ltdl.m4 b/config/ltdl.m4
index ea76f4d..2f1cbfe 100644
--- a/config/ltdl.m4
+++ b/config/ltdl.m4
@@ -162,6 +162,8 @@ m4_defun([_LTDL_INSTALLABLE],
fi
fi
+enable_ltdl_install=no
+
# If configure.ac declared an installable ltdl, and the user didn't override
# with --disable-ltdl-install, we will install the shipped libltdl.
case $enable_ltdl_install in
diff --git a/ompi/debuggers/Makefile.am b/ompi/debuggers/Makefile.am
index 2adf3fd..5b22a91 100644
--- a/ompi/debuggers/Makefile.am
+++ b/ompi/debuggers/Makefile.am
@@ -46,8 +46,7 @@ headers = \
# Simple checks to ensure that the DSOs are functional
dlopen_test_SOURCES = dlopen_test.c
-dlopen_test_CPPFLAGS = -I$(top_srcdir)/opal/libltdl
-dlopen_test_LDADD = $(top_builddir)/opal/libltdl/libltdlc.la
+dlopen_test_LDADD = -lltdl
predefined_gap_test_SOURCES = predefined_gap_test.c
predefined_gap_test_LDFLAGS = $(WRAPPER_EXTRA_LDFLAGS)
diff --git a/ompi/debuggers/dlopen_test.c b/ompi/debuggers/dlopen_test.c
index 029a4ee..023afb8 100644
--- a/ompi/debuggers/dlopen_test.c
+++ b/ompi/debuggers/dlopen_test.c
@@ -13,7 +13,7 @@
#include <string.h>
#include <stdlib.h>
-#include "opal/libltdl/ltdl.h"
+#include "ltdl.h"
static int do_test(void);
diff --git a/test/support/components.c b/test/support/components.c
index 41c4345..6b4b464 100644
--- a/test/support/components.c
+++ b/test/support/components.c
@@ -24,7 +24,7 @@
#include "opal/constants.h"
#include "opal/mca/mca.h"
-#include "opal/libltdl/ltdl.h"
+#include "ltdl.h"
#include "components.h"
diff --git a/test/support/components.h b/test/support/components.h
index 6db1f0d..fc8dfc5 100644
--- a/test/support/components.h
+++ b/test/support/components.h
@@ -20,7 +20,7 @@
#ifndef OMPI_SUPPORT_COMPONENTS_H
#define OMPI_SUPPORT_COMPONENTS_H
-#include "opal/libltdl/ltdl.h"
+#include "ltdl.h"
#include "opal/mca/mca.h"
BEGIN_C_DECLS