mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/chromium to 58.0.3029.81-1
This commit is contained in:
parent
ef88f4d9cc
commit
a8d9e562e5
2 changed files with 26 additions and 19 deletions
|
@ -10,6 +10,7 @@
|
|||
|
||||
buildarch=12
|
||||
highmem=1
|
||||
noautobuild=1
|
||||
|
||||
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
|
||||
# Keys are the names in the above script; values are the dependencies in Arch
|
||||
|
@ -20,7 +21,7 @@ declare -rgA _system_libs=(
|
|||
[icu]=icu
|
||||
[libjpeg]=libjpeg
|
||||
[libpng]=libpng
|
||||
[libvpx]=libvpx
|
||||
#[libvpx]=libvpx # https://bugs.gentoo.org/show_bug.cgi?id=611394
|
||||
[libwebp]=libwebp
|
||||
#[libxml]=libxml2 # https://bugs.archlinux.org/task/29939
|
||||
[libxslt]=libxslt
|
||||
|
@ -31,10 +32,10 @@ declare -rgA _system_libs=(
|
|||
)
|
||||
|
||||
pkgname=chromium
|
||||
pkgver=57.0.2987.133
|
||||
pkgver=58.0.3029.81
|
||||
pkgrel=1
|
||||
_launcher_ver=3
|
||||
pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
|
||||
pkgdesc="A web browser built for speed, simplicity, and security"
|
||||
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
|
||||
url="https://www.chromium.org/Home"
|
||||
license=('BSD')
|
||||
|
@ -42,7 +43,7 @@ depends=('gtk2' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libexif' 'libgcrypt'
|
|||
'ttf-font' 'systemd' 'dbus' 'libpulse' 'perl' 'perl-file-basedir'
|
||||
'pciutils' 'desktop-file-utils' 'hicolor-icon-theme')
|
||||
depends+=(${_system_libs[@]})
|
||||
makedepends=('gtk3' 'python2' 'gperf' 'yasm' 'mesa' 'ninja' 'git')
|
||||
makedepends=('python2' 'gperf' 'yasm' 'mesa' 'ninja' 'nodejs' 'git')
|
||||
optdepends=('kdialog: needed for file dialogs in KDE'
|
||||
'gnome-keyring: for storing passwords in GNOME keyring'
|
||||
'kwallet: for storing passwords in KWallet')
|
||||
|
@ -51,12 +52,14 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
|
|||
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
|
||||
chromium.desktop
|
||||
chromium-system-ffmpeg-r4.patch
|
||||
chromium-gn-bootstrap-r2.patch
|
||||
chromium-widevine.patch
|
||||
0001-ARM-toolchain-fixes.patch)
|
||||
sha256sums=('70011770a7e522c92826a3af48d3fd28a46bf8042897d072d20c748cbf828cf7'
|
||||
sha256sums=('5ab61b7025a5143fa1b21713479b316ec7a98e262e79e84f9c9a9656179217cb'
|
||||
'8b01fb4efe58146279858a754d90b49e5a38c9a0b36a1f84cbb7d12f92b84c28'
|
||||
'028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9'
|
||||
'e3c474dbf3822a0be50695683bd8a2c9dfc82d41c1524a20b4581883c0c88986'
|
||||
'64d743c78183c302c42d1f289863e34c74832fca57443833e46a0a3157e2b5de'
|
||||
'd6fdcb922e5a7fbe15759d39ccc8ea4225821c44d98054ce0f23f9d1f00c9808'
|
||||
'8489d2a85b32e9b08f5c30d47b40ae41911d1915f48b6de3c41fe350dfecfef6')
|
||||
|
||||
|
@ -86,11 +89,7 @@ prepare() {
|
|||
# Fixes from Gentoo
|
||||
patch -Np1 -i ../chromium-system-ffmpeg-r4.patch
|
||||
|
||||
# Work around bug in blink in which GCC 6 optimizes away null pointer checks
|
||||
# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=833524
|
||||
# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=68853#c2
|
||||
sed -i '/config("compiler")/ a cflags_cc = [ "-fno-delete-null-pointer-checks" ]' \
|
||||
build/config/linux/BUILD.gn
|
||||
patch -Np1 -i ../chromium-gn-bootstrap-r2.patch
|
||||
|
||||
# Use Python 2
|
||||
find . -name '*.py' -exec sed -i -r 's|/usr/bin/python$|&2|g' {} +
|
||||
|
@ -130,7 +129,6 @@ build() {
|
|||
local _flags=(
|
||||
'is_clang=false'
|
||||
'clang_use_chrome_plugins=false'
|
||||
'symbol_level=0'
|
||||
'is_debug=false'
|
||||
'fatal_linker_warnings=false'
|
||||
'treat_warnings_as_errors=false'
|
||||
|
@ -140,18 +138,13 @@ build() {
|
|||
'proprietary_codecs=true'
|
||||
'link_pulseaudio=true'
|
||||
'linux_use_bundled_binutils=false'
|
||||
'use_cups=true'
|
||||
'use_gconf=false'
|
||||
'use_gnome_keyring=false'
|
||||
'use_gold=false'
|
||||
'use_gtk3=false'
|
||||
'use_kerberos=true'
|
||||
'use_pulseaudio=true'
|
||||
'use_sysroot=false'
|
||||
'enable_hangout_services_extension=true'
|
||||
'enable_widevine=true'
|
||||
'enable_nacl=false'
|
||||
'enable_nacl_nonsfi=false'
|
||||
"google_api_key=\"${_google_api_key}\""
|
||||
"google_default_client_id=\"${_google_default_client_id}\""
|
||||
"google_default_client_secret=\"${_google_default_client_secret}\""
|
||||
|
@ -167,7 +160,7 @@ build() {
|
|||
package() {
|
||||
cd "$srcdir/chromium-launcher-$_launcher_ver"
|
||||
|
||||
make PREFIX=/usr DESTDIR="$pkgdir" install-strip
|
||||
make PREFIX=/usr DESTDIR="$pkgdir" install
|
||||
install -Dm644 LICENSE \
|
||||
"$pkgdir/usr/share/licenses/chromium/LICENSE.launcher"
|
||||
|
||||
|
@ -181,9 +174,10 @@ package() {
|
|||
install -Dm4755 out/Release/chrome_sandbox \
|
||||
"$pkgdir/usr/lib/chromium/chrome-sandbox"
|
||||
|
||||
cp -a out/Release/{*.pak,*.bin,chromedriver,libwidevinecdmadapter.so} \
|
||||
cp -a \
|
||||
out/Release/{chrome_{100,200}_percent,resources}.pak \
|
||||
out/Release/{*.bin,chromedriver,libwidevinecdmadapter.so} \
|
||||
out/Release/locales \
|
||||
out/Release/gen/content/content_resources.pak \
|
||||
"$pkgdir/usr/lib/chromium/"
|
||||
|
||||
ln -s /usr/lib/chromium/chromedriver "$pkgdir/usr/bin/chromedriver"
|
||||
|
|
13
extra/chromium/chromium-gn-bootstrap-r2.patch
Normal file
13
extra/chromium/chromium-gn-bootstrap-r2.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
Index: tools/gn/bootstrap/bootstrap.py
|
||||
diff --git a/tools/gn/bootstrap/bootstrap.py b/tools/gn/bootstrap/bootstrap.py
|
||||
index 38cfb117d29c3895291379f00d8dc8c8b0727474..679170e610f8292bcbeb76508fd247d322a69c79 100755
|
||||
--- a/tools/gn/bootstrap/bootstrap.py
|
||||
+++ b/tools/gn/bootstrap/bootstrap.py
|
||||
@@ -385,6 +385,7 @@ def write_gn_ninja(path, root_gen_dir, options):
|
||||
'base/base_switches.cc',
|
||||
'base/build_time.cc',
|
||||
'base/callback_internal.cc',
|
||||
+ 'base/callback_helpers.cc',
|
||||
'base/command_line.cc',
|
||||
'base/debug/activity_tracker.cc',
|
||||
'base/debug/alias.cc',
|
Loading…
Reference in a new issue