mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
removed extra/net-snmp
This commit is contained in:
parent
4ac3d08163
commit
a8e0191141
5 changed files with 0 additions and 231 deletions
|
@ -1,65 +0,0 @@
|
|||
# $Id$
|
||||
# Maintainer: Felix Yan <felixonmars@gmail.com>
|
||||
# Contributor: Dale Blount <dale@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch for pci issue: ifmib.patch (http://sourceforge.net/p/net-snmp/bugs/2449/)
|
||||
|
||||
pkgname=net-snmp
|
||||
pkgver=5.7.2.1
|
||||
pkgrel=3
|
||||
pkgdesc="A suite of applications used to implement SNMP v1, SNMP v2c and SNMP v3 using both IPv4 and IPv6"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.net-snmp.org/"
|
||||
license=('BSD')
|
||||
depends=('openssl' 'libnl' 'pciutils')
|
||||
makedepends=('python2-setuptools')
|
||||
optdepends=('perl-term-readkey: for snmpcheck application'
|
||||
'perl-tk: for snmpcheck and tkmib applications'
|
||||
'python2: for the python modules')
|
||||
options=('!emptydirs' '!makeflags')
|
||||
source=(http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz{,.asc}
|
||||
snmpd.service snmptrapd.service libnl32.patch ifmib.patch)
|
||||
sha1sums=('815d4e5520a1ed96a27def33e7534b4190599f0f'
|
||||
'SKIP'
|
||||
'84e32c54d32e6b608747054e04a3ddfe6d6638cc'
|
||||
'0244e91c7baa0abebfb5c0560e8ce04c966c5992'
|
||||
'74a9848b95f63378eb1753fc309d2b74de5afb0f'
|
||||
'405dbbb4df02eb5ee3531c4566cfe2ae12fa04b5')
|
||||
|
||||
prepare() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
#make PERL_ARCHLIB=/usr/lib/perl5/core_perl PERL_INC=/usr/lib/perl5/core_perl/CORE distclean
|
||||
|
||||
# http://sourceforge.net/tracker/index.php?func=detail&aid=3250304&group_id=12694&atid=112694
|
||||
patch -Np1 -i "$srcdir/libnl32.patch"
|
||||
patch -Np1 -i "$srcdir/ifmib.patch"
|
||||
|
||||
autoreconf -f -i
|
||||
}
|
||||
|
||||
build() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
PYTHONPROG=/usr/bin/python2 ./configure --prefix=/usr \
|
||||
--sysconfdir=/etc --sbindir=/usr/bin \
|
||||
--mandir=/usr/share/man \
|
||||
--enable-ucd-snmp-compatibility \
|
||||
--enable-ipv6 \
|
||||
--with-python-modules \
|
||||
--with-default-snmp-version="3" \
|
||||
--with-sys-contact="root@localhost" \
|
||||
--with-sys-location="Unknown" \
|
||||
--with-logfile="/var/log/snmpd.log" \
|
||||
--with-mib-modules="host misc/ipfwacc ucd-snmp/diskio tunnel ucd-snmp/dlmod" \
|
||||
--with-persistent-directory="/var/net-snmp"
|
||||
make NETSNMP_DONT_CHECK_VERSION=1
|
||||
}
|
||||
|
||||
package() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
sed -i -e "s:install --basedir=\$\$dir:install --basedir=\$\$dir --root=${pkgdir}:" Makefile
|
||||
make DESTDIR="${pkgdir}" INSTALL_PREFIX="${pkgdir}" INSTALLDIRS=vendor install
|
||||
install -D -m644 "${srcdir}/snmpd.service" "${pkgdir}/usr/lib/systemd/system/snmpd.service"
|
||||
install -D -m644 "${srcdir}/snmptrapd.service" "${pkgdir}/usr/lib/systemd/system/snmptrapd.service"
|
||||
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
|
||||
}
|
|
@ -1,62 +0,0 @@
|
|||
diff --git a/agent/mibgroup/if-mib/data_access/interface_linux.c b/agent/mibgroup/if-mib/data_access/interface_linux.c
|
||||
index 3419811..d6eb91a 100644
|
||||
--- a/agent/mibgroup/if-mib/data_access/interface_linux.c
|
||||
+++ b/agent/mibgroup/if-mib/data_access/interface_linux.c
|
||||
@@ -18,7 +18,31 @@ netsnmp_feature_require(interface_ioctl_flags_set)
|
||||
|
||||
#ifdef HAVE_PCI_LOOKUP_NAME
|
||||
#include <pci/pci.h>
|
||||
+#include <setjmp.h>
|
||||
static struct pci_access *pci_access;
|
||||
+
|
||||
+/* Avoid letting libpci call exit(1) when no PCI bus is available. */
|
||||
+static int do_longjmp =0;
|
||||
+static jmp_buf err_buf;
|
||||
+static void
|
||||
+netsnmp_pci_error(char *msg, ...)
|
||||
+{
|
||||
+ va_list args;
|
||||
+ char *buf;
|
||||
+ int buflen;
|
||||
+
|
||||
+ va_start(args, msg);
|
||||
+ buflen = strlen("pcilib: ")+strlen(msg)+2;
|
||||
+ buf = malloc(buflen);
|
||||
+ snprintf(buf, buflen, "pcilib: %s\n", msg);
|
||||
+ snmp_vlog(LOG_ERR, buf, args);
|
||||
+ free(buf);
|
||||
+ va_end(args);
|
||||
+ if (do_longjmp)
|
||||
+ longjmp(err_buf, 1);
|
||||
+ else
|
||||
+ exit(1);
|
||||
+}
|
||||
#endif
|
||||
|
||||
#ifdef HAVE_LINUX_ETHTOOL_H
|
||||
@@ -147,10 +171,22 @@ netsnmp_arch_interface_init(void)
|
||||
|
||||
#ifdef HAVE_PCI_LOOKUP_NAME
|
||||
pci_access = pci_alloc();
|
||||
- if (pci_access)
|
||||
+ if (!pci_access) {
|
||||
+ snmp_log(LOG_ERR, "pcilib: pci_alloc failed\n");
|
||||
+ return;
|
||||
+ }
|
||||
+
|
||||
+ pci_access->error = netsnmp_pci_error;
|
||||
+
|
||||
+ do_longjmp = 1;
|
||||
+ if (setjmp(err_buf)) {
|
||||
+ pci_cleanup(pci_access);
|
||||
+ snmp_log(LOG_ERR, "pcilib: pci_init failed\n");
|
||||
+ pci_access = NULL;
|
||||
+ }
|
||||
+ else if (pci_access)
|
||||
pci_init(pci_access);
|
||||
- else
|
||||
- snmp_log(LOG_ERR, "Unable to create pci access method\n");
|
||||
+ do_longjmp = 0;
|
||||
#endif
|
||||
}
|
||||
|
|
@ -1,80 +0,0 @@
|
|||
diff -u -r net-snmp-5.7.1/agent/mibgroup/mibII/tcpTable.c net-snmp-5.7.1-libnl32/agent/mibgroup/mibII/tcpTable.c
|
||||
--- net-snmp-5.7.1/agent/mibgroup/mibII/tcpTable.c 2011-09-28 06:53:47.000000000 +0200
|
||||
+++ net-snmp-5.7.1-libnl32/agent/mibgroup/mibII/tcpTable.c 2012-02-09 20:02:49.136022132 +0100
|
||||
@@ -566,8 +566,9 @@
|
||||
static int
|
||||
tcpTable_load_netlink(void)
|
||||
{
|
||||
+ int err;
|
||||
/* TODO: perhaps use permanent nl handle? */
|
||||
- struct nl_handle *nl = nl_handle_alloc();
|
||||
+ struct nl_sock *nl = nl_socket_alloc();
|
||||
|
||||
if (nl == NULL) {
|
||||
DEBUGMSGTL(("mibII/tcpTable", "Failed to allocate netlink handle\n"));
|
||||
@@ -575,10 +576,10 @@
|
||||
return -1;
|
||||
}
|
||||
|
||||
- if (nl_connect(nl, NETLINK_INET_DIAG) < 0) {
|
||||
- DEBUGMSGTL(("mibII/tcpTable", "Failed to connect to netlink: %s\n", nl_geterror()));
|
||||
- snmp_log(LOG_ERR, "snmpd: Couldn't connect to netlink: %s\n", nl_geterror());
|
||||
- nl_handle_destroy(nl);
|
||||
+ if ((err = nl_connect(nl, NETLINK_INET_DIAG)) < 0) {
|
||||
+ DEBUGMSGTL(("mibII/tcpTable", "Failed to connect to netlink: %s\n", nl_geterror(err)));
|
||||
+ snmp_log(LOG_ERR, "snmpd: Couldn't connect to netlink: %s\n", nl_geterror(err));
|
||||
+ nl_socket_free(nl);
|
||||
return -1;
|
||||
}
|
||||
|
||||
@@ -590,10 +591,10 @@
|
||||
struct nl_msg *nm = nlmsg_alloc_simple(TCPDIAG_GETSOCK, NLM_F_ROOT|NLM_F_MATCH|NLM_F_REQUEST);
|
||||
nlmsg_append(nm, &req, sizeof(struct inet_diag_req), 0);
|
||||
|
||||
- if (nl_send_auto_complete(nl, nm) < 0) {
|
||||
- DEBUGMSGTL(("mibII/tcpTable", "nl_send_autocomplete(): %s\n", nl_geterror()));
|
||||
- snmp_log(LOG_ERR, "snmpd: nl_send_autocomplete(): %s\n", nl_geterror());
|
||||
- nl_handle_destroy(nl);
|
||||
+ if ((err = nl_send_auto_complete(nl, nm)) < 0) {
|
||||
+ DEBUGMSGTL(("mibII/tcpTable", "nl_send_autocomplete(): %s\n", nl_geterror(err)));
|
||||
+ snmp_log(LOG_ERR, "snmpd: nl_send_autocomplete(): %s\n", nl_geterror(err));
|
||||
+ nl_socket_free(nl);
|
||||
return -1;
|
||||
}
|
||||
nlmsg_free(nm);
|
||||
@@ -604,9 +605,9 @@
|
||||
|
||||
while (running) {
|
||||
if ((len = nl_recv(nl, &peer, &buf, NULL)) <= 0) {
|
||||
- DEBUGMSGTL(("mibII/tcpTable", "nl_recv(): %s\n", nl_geterror()));
|
||||
- snmp_log(LOG_ERR, "snmpd: nl_recv(): %s\n", nl_geterror());
|
||||
- nl_handle_destroy(nl);
|
||||
+ DEBUGMSGTL(("mibII/tcpTable", "nl_recv(): %s\n", nl_geterror(len)));
|
||||
+ snmp_log(LOG_ERR, "snmpd: nl_recv(): %s\n", nl_geterror(len));
|
||||
+ nl_socket_free(nl);
|
||||
return -1;
|
||||
}
|
||||
|
||||
@@ -655,7 +656,7 @@
|
||||
free(buf);
|
||||
}
|
||||
|
||||
- nl_handle_destroy(nl);
|
||||
+ nl_socket_free(nl);
|
||||
|
||||
if (tcp_head) {
|
||||
DEBUGMSGTL(("mibII/tcpTable", "Loaded TCP Table using netlink\n"));
|
||||
diff -u -r net-snmp-5.7.1/configure.d/config_os_libs2 net-snmp-5.7.1-libnl32/configure.d/config_os_libs2
|
||||
--- net-snmp-5.7.1/configure.d/config_os_libs2 2011-09-28 06:53:47.000000000 +0200
|
||||
+++ net-snmp-5.7.1-libnl32/configure.d/config_os_libs2 2012-02-09 20:10:44.282165275 +0100
|
||||
@@ -224,8 +224,9 @@
|
||||
if test "x$with_nl" != "xno"; then
|
||||
case $target_os in
|
||||
linux*) # Check for libnl (linux)
|
||||
+ CPPFLAGS="$CPPFLAGS $(pkg-config --cflags-only-I libnl-3.0)"
|
||||
NETSNMP_SEARCH_LIBS(
|
||||
- nl_connect, nl,
|
||||
+ nl_connect, nl-3,
|
||||
[AC_CHECK_HEADERS(netlink/netlink.h)],,, LMIBLIBS)
|
||||
;;
|
||||
esac
|
|
@ -1,12 +0,0 @@
|
|||
[Unit]
|
||||
Description=Simple Network Management Protocol (SNMP) Daemon
|
||||
After=syslog.target network.target
|
||||
|
||||
[Service]
|
||||
Type=forking
|
||||
PIDFile=/run/snmpd.pid
|
||||
ExecStart=/usr/bin/snmpd -p /run/snmpd.pid
|
||||
ExecReload=/bin/kill -HUP $MAINPID
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
|
@ -1,12 +0,0 @@
|
|||
[Unit]
|
||||
Description=Simple Network Management Protocol (SNMP) TRAP Daemon
|
||||
After=syslog.target network.target
|
||||
|
||||
[Service]
|
||||
Type=forking
|
||||
PIDFile=/run/snmptrapd.pid
|
||||
ExecStart=/usr/bin/snmptrapd -p /run/snmptrapd.pid
|
||||
ExecReload=/bin/kill -HUP $MAINPID
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
Loading…
Reference in a new issue