core/linux-chromebook to 20130731-1

This commit is contained in:
Kevin Mihelich 2013-08-01 01:34:36 +00:00
parent 4846980899
commit a8f28c4cac
3 changed files with 5 additions and 23 deletions

View file

@ -5,7 +5,7 @@ buildarch=4
pkgbase=linux-chromebook
pkgname=('linux-chromebook' 'linux-headers-chromebook')
pkgver=20130709
pkgver=20130731
_kernelname=${pkgname#linux}
_basever=3.4
pkgrel=1
@ -14,11 +14,9 @@ arch=('armv7h')
url="http://git.chromium.org/gitweb/?p=chromiumos/third_party/kernel.git;a=summary"
license=('GPL2')
makedepends=('uboot-mkimage' 'dtc' 'git')
source=('change-default-console-loglevel.patch'
'config'
'kernel.its')
md5sums=('b92685a88e9784b3b7c609894ee8b5da'
'3e41b780af909d05209ed79810d29359'
source=('config'
'kernel.its')
md5sums=('9ef2273a0befbc005260ebbaf8b912f7'
'1ee7e0f62516ba3af19022c25636011c')
_gitroot='https://git.chromium.org/git/chromiumos/third_party/kernel.git'
@ -41,11 +39,6 @@ build() {
cd "$srcdir/${_gitname}"
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -Np1 -i "${srcdir}/change-default-console-loglevel.patch"
# Kernel configuration
cp "${srcdir}/config" .config

View file

@ -1,12 +0,0 @@
diff -upr chromeos-3.4.orig/kernel/printk.c chromeos-3.4/kernel/printk.c
--- chromeos-3.4.orig/kernel/printk.c 2013-02-17 20:37:48.018383118 -0500
+++ chromeos-3.4/kernel/printk.c 2013-02-17 20:38:43.679214839 -0500
@@ -62,7 +62,7 @@ void asmlinkage __attribute__((weak)) ea
/* We show everything that is MORE important than this.. */
#define MINIMUM_CONSOLE_LOGLEVEL 1 /* Minimum loglevel we let people use */
-#define DEFAULT_CONSOLE_LOGLEVEL 7 /* anything MORE serious than KERN_DEBUG */
+#define DEFAULT_CONSOLE_LOGLEVEL 4 /* anything MORE serious than KERN_DEBUG */
DECLARE_WAIT_QUEUE_HEAD(log_wait);

View file

@ -2811,6 +2811,7 @@ CONFIG_USB_EHCI_HCD=y
CONFIG_USB_EHCI_ROOT_HUB_TT=y
CONFIG_USB_EHCI_TT_NEWSCHED=y
CONFIG_USB_EHCI_S5P=y
# CONFIG_USB_EHCI_S5P_HSIC_RESET is not set
# CONFIG_USB_OXU210HP_HCD is not set
# CONFIG_USB_ISP116X_HCD is not set
# CONFIG_USB_ISP1760_HCD is not set