community/sshfs to 3.3.0-3: patch for meson

This commit is contained in:
Jason Plum 2017-09-25 13:04:02 -04:00
parent fc62ba346f
commit a909fd6bef
2 changed files with 26 additions and 6 deletions

View file

@ -0,0 +1,12 @@
diff -ura sshfs-3.3.0.orig/meson.build sshfs-3.3.0.new/meson.build
--- sshfs-3.3.0.orig/meson.build 2017-09-20 14:08:27.000000000 -0300
+++ sshfs-3.3.0.new/meson.build 2017-09-25 11:19:19.946623793 -0300
@@ -58,7 +58,7 @@
if rst2man.found()
custom_target('manpages', input: [ 'sshfs.rst' ], output: [ 'sshfs.1' ],
command: [rst2man, '@INPUT@', '@OUTPUT@'], install: true,
- install_dir: join_paths(get_option('mandir'), '1'))
+ install_dir: join_paths(get_option('mandir'), 'man1'))
else
message('rst2man not found, not building manual page.')
endif

View file

@ -8,25 +8,33 @@
pkgname=sshfs
pkgver=3.3.0
pkgrel=2
pkgrel=3
pkgdesc="FUSE client based on the SSH File Transfer Protocol"
arch=(x86_64 i686)
url="http://github.com/libfuse/sshfs"
license=(GPL)
depends=(fuse3 glib2 openssh)
makedepends=('meson' 'python-docutils')
source=(https://github.com/libfuse/sshfs/releases/download/sshfs-$pkgver/sshfs-$pkgver.tar.xz{,.asc})
source=(https://github.com/libfuse/sshfs/releases/download/$pkgname-$pkgver/sshfs-$pkgver.tar.xz{,.asc}
001-sshfs-3.3.0-meson.build.patch)
sha256sums=('9ddfcc2564fafe002706b093b6295afbcb2cc0a3bc52bc805cc5361cb69ca51d'
'SKIP')
'SKIP'
'da928d31291ad86582ab616ea91619c345513dec00f6aafb5bac8f2929159e6b')
validpgpkeys=('ED31791B2C5C1613AF388B8AD113FCAC3C4E599F') # Nikolaus Rath <Nikolaus@rath.org>
build() {
prepare() {
cd $pkgname-$pkgver
[[ $CARCH == 'i686' || $CARCH == 'arm' || $CARCH == 'armv6h' || $CARCH == 'armv7h' ]] && export CFLAGS+=" -D_FILE_OFFSET_BITS=64"
# patch meson.build
patch -p1 < ../001-sshfs-3.3.0-meson.build.patch
[[ $CARCH == 'i686' ]] && export CFLAGS+=" -D_FILE_OFFSET_BITS=64"
rm -rf build
meson setup --prefix=/usr --sbindir=bin . build
cd build
}
build() {
cd $pkgname-$pkgver/build
ninja
}