core/linux-espressobin to 5.8.9-2

This commit is contained in:
Kevin Mihelich 2020-09-14 22:02:31 +00:00
parent 864e22c35b
commit a91f533d91
3 changed files with 60 additions and 6 deletions

View file

@ -1,7 +1,7 @@
From 5a06abc2198fc2ad6b25a4b24f029d454cf4b642 Mon Sep 17 00:00:00 2001
From c998c1913b06f73e103c10e7992713cac08986a1 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 4 Jul 2017 19:25:28 -0600
Subject: [PATCH] arm64: dts: marvell: armada37xx: Add eth0 alias
Subject: [PATCH 1/2] arm64: dts: marvell: armada37xx: Add eth0 alias
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
@ -9,7 +9,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 1 insertion(+)
diff --git a/arch/arm64/boot/dts/marvell/armada-37xx.dtsi b/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
index 7909c146eabf..745ca5ff76da 100644
index 2bbc69b4dc99..49e42111270b 100644
--- a/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
+++ b/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
@@ -18,6 +18,7 @@ / {
@ -21,5 +21,5 @@ index 7909c146eabf..745ca5ff76da 100644
serial1 = &uart1;
};
--
2.26.1
2.27.0

View file

@ -0,0 +1,51 @@
From 6d6724487df91f690428142cee2d2e11e09cf749 Mon Sep 17 00:00:00 2001
From: Jessica Yu <jeyu@kernel.org>
Date: Tue, 1 Sep 2020 18:00:16 +0200
Subject: [PATCH 2/2] arm64/module: set trampoline section flags regardless of
CONFIG_DYNAMIC_FTRACE
In the arm64 module linker script, the section .text.ftrace_trampoline
is specified unconditionally regardless of whether CONFIG_DYNAMIC_FTRACE
is enabled (this is simply due to the limitation that module linker
scripts are not preprocessed like the vmlinux one).
Normally, for .plt and .text.ftrace_trampoline, the section flags
present in the module binary wouldn't matter since module_frob_arch_sections()
would assign them manually anyway. However, the arm64 module loader only
sets the section flags for .text.ftrace_trampoline when CONFIG_DYNAMIC_FTRACE=y.
That's only become problematic recently due to a recent change in
binutils-2.35, where the .text.ftrace_trampoline section (along with the
.plt section) is now marked writable and executable (WAX).
We no longer allow writable and executable sections to be loaded due to
commit 5c3a7db0c7ec ("module: Harden STRICT_MODULE_RWX"), so this is
causing all modules linked with binutils-2.35 to be rejected under arm64.
Drop the IS_ENABLED(CONFIG_DYNAMIC_FTRACE) check in module_frob_arch_sections()
so that the section flags for .text.ftrace_trampoline get properly set to
SHF_EXECINSTR|SHF_ALLOC, without SHF_WRITE.
Link: http://lore.kernel.org/r/20200831094651.GA16385@linux-8ccs
Acked-by: Will Deacon <will@kernel.org>
Signed-off-by: Jessica Yu <jeyu@kernel.org>
Acked-by: Ard Biesheuvel <ardb@kernel.org>
---
arch/arm64/kernel/module-plts.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/arch/arm64/kernel/module-plts.c b/arch/arm64/kernel/module-plts.c
index 65b08a74aec6..37c0b51a7b7b 100644
--- a/arch/arm64/kernel/module-plts.c
+++ b/arch/arm64/kernel/module-plts.c
@@ -271,8 +271,7 @@ int module_frob_arch_sections(Elf_Ehdr *ehdr, Elf_Shdr *sechdrs,
mod->arch.core.plt_shndx = i;
else if (!strcmp(secstrings + sechdrs[i].sh_name, ".init.plt"))
mod->arch.init.plt_shndx = i;
- else if (IS_ENABLED(CONFIG_DYNAMIC_FTRACE) &&
- !strcmp(secstrings + sechdrs[i].sh_name,
+ else if (!strcmp(secstrings + sechdrs[i].sh_name,
".text.ftrace_trampoline"))
tramp = sechdrs + i;
else if (sechdrs[i].sh_type == SHT_SYMTAB)
--
2.27.0

View file

@ -8,7 +8,7 @@ _srcname=linux-5.8
_kernelname=${pkgbase#linux}
_desc="Globalscale ESPRESSOBin"
pkgver=5.8.9
pkgrel=1
pkgrel=2
arch=('aarch64')
url="http://www.kernel.org/"
license=('GPL2')
@ -17,6 +17,7 @@ options=('!strip')
source=("http://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
"http://www.kernel.org/pub/linux/kernel/v5.x/patch-${pkgver}.xz"
'0001-arm64-dts-marvell-armada37xx-Add-eth0-alias.patch'
'0002-arm64-module-set-trampoline-section-flags-regardless.patch'
'config'
'linux.preset'
'60-linux.hook'
@ -24,7 +25,8 @@ source=("http://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
'91-linux.hook')
md5sums=('0e5c4c15266218ef26c50fac0016095b'
'76f0d7bc98014e70f9d3dd56dca08bd4'
'2b57e90d0515f0558504e3f6f21fad1a'
'1760d29b04c22b5b10ec3bc6186a677c'
'e07212d9d33a300e811e2f162146b3e2'
'215c731ce2b9fd444e4aebe50a7185fe'
'86d4a35722b5410e3b29fc92dae15d4b'
'ce6c81ad1ad1f8b333fd6077d47abdaf'
@ -39,6 +41,7 @@ prepare() {
# ALARM patches
git apply ../0001-arm64-dts-marvell-armada37xx-Add-eth0-alias.patch
git apply ../0002-arm64-module-set-trampoline-section-flags-regardless.patch
cat "${srcdir}/config" > ./.config