diff --git a/alarm/uboot-sunxi/PKGBUILD b/alarm/uboot-sunxi/PKGBUILD
index 057343929..3805e3992 100644
--- a/alarm/uboot-sunxi/PKGBUILD
+++ b/alarm/uboot-sunxi/PKGBUILD
@@ -4,7 +4,7 @@
buildarch=4
pkgbase=uboot-sunxi
-pkgname=('uboot-cubieboard2' 'uboot-cubietruck')
+pkgname=('uboot-cubieboard2' 'uboot-cubietruck' 'uboot-iteaduino_plus_a10' 'uboot-iteaduino_plus_a20')
pkgver=2014.01
pkgrel=4
arch=('armv7h')
@@ -12,22 +12,22 @@ url="https://github.com/linux-sunxi/u-boot-sunxi/tree/sunxi-current"
license=('GPL')
makedepends=('sunxi-tools')
backup=(boot/uEnv.txt)
-_commit=660aa6fd9e1c25baabfcf4dfce42381547f5f59b
+_commit=765936d2c8ebf048b9c147fc981beccd115c6158
source=("https://github.com/linux-sunxi/u-boot-sunxi/archive/${_commit}.tar.gz"
'alarm.patch'
'cubieboard2.fex' 'cubieboard2.env'
'cubietruck.fex' 'cubietruck.env'
'iteaduino_plus_a10.fex' 'iteaduino_plus_a10.env'
'iteaduino_plus_a20.fex' 'iteaduino_plus_a20.env' )
-md5sums=('019e2a420fa9d9a5e24aaf9cd8de2104'
- 'f2f60fca0d93ef62c6a95c4f3254a829'
+md5sums=('8e4f2a2c1384f31eca5d3864b86e8351'
+ 'd14a621663c56d37251a3d42d1d10236'
'36c04988cecd53151f3f5ff5c48d76a9'
'd41d8cd98f00b204e9800998ecf8427e'
'c898ab1b57f474d620f5704b2a53d87c'
'd41d8cd98f00b204e9800998ecf8427e'
- 'aa401a14c409347842040592d58e7f80'
+ '1bd3355ad6c6c6976c664223958db3f4'
'd41d8cd98f00b204e9800998ecf8427e'
- 'f68d14c13b934a66a3f951bc3bd59f3b'
+ '4b85ce18f33c9b4a6338fa973df44f54'
'd41d8cd98f00b204e9800998ecf8427e')
prepare() {
@@ -42,10 +42,11 @@ build() {
unset CXXFLAGS
unset LDFLAGS
- for i in Cubieboard2 Cubietruck; do
+ for i in Cubieboard2 Cubietruck Iteaduino_Plus_A10 Iteaduino_Plus_A20; do
mkdir ../bin_${i}
make distclean
- make ${i}
+ make ${i}_config
+ make
mv u-boot-sunxi-with-spl.bin ../bin_${i}
done
}
@@ -80,7 +81,7 @@ package_uboot-iteaduino_plus_a10() {
conflicts=('uboot-cubieboard2' 'uboot-cubietruck' 'uboot-iteaduino_plus_a20')
mkdir -p "${pkgdir}"/boot
- cp bin_iteaduino_plus_a10/u-boot-sunxi-with-spl.bin "${pkgdir}"/boot
+ cp bin_Iteaduino_Plus_A10/u-boot-sunxi-with-spl.bin "${pkgdir}"/boot
fex2bin iteaduino_plus_a10.fex "${pkgdir}"/boot/script.bin
cp iteaduino_plus_a10.env "${pkgdir}"/boot/uEnv.txt
@@ -92,7 +93,7 @@ package_uboot-iteaduino_plus_a20() {
conflicts=('uboot-cubieboard2' 'uboot-cubietruck' 'uboot-iteaduino_plus_a10')
mkdir -p "${pkgdir}"/boot
- cp bin_iteaduino_plus_a20/u-boot-sunxi-with-spl.bin "${pkgdir}"/boot
+ cp bin_Iteaduino_Plus_A20/u-boot-sunxi-with-spl.bin "${pkgdir}"/boot
fex2bin iteaduino_plus_a20.fex "${pkgdir}"/boot/script.bin
cp iteaduino_plus_a20.env "${pkgdir}"/boot/uEnv.txt
diff --git a/alarm/uboot-sunxi/alarm.patch b/alarm/uboot-sunxi/alarm.patch
index a359a870a..712f5748c 100644
--- a/alarm/uboot-sunxi/alarm.patch
+++ b/alarm/uboot-sunxi/alarm.patch
@@ -58,20 +58,3 @@ index a0c41ac..e9a94f6 100644
";then true; else "\
"false" \
";fi" \
-@@ -272,7 +262,7 @@
- "\0" \
- ""
-
--#define CONFIG_BOOTDELAY 3
-+#define CONFIG_BOOTDELAY 1
- #define CONFIG_SYS_BOOT_GET_CMDLINE
- #define CONFIG_AUTO_COMPLETE
-
-@@ -287,6 +277,7 @@
- #define CONFIG_FAT_WRITE /* enable write access */
- #define CONFIG_CMD_EXT2 /* with this we can access ext2 bootfs */
- #define CONFIG_CMD_EXT4 /* with this we can access ext4 bootfs */
-+#define CONFIG_CMD_FS_GENERIC
-
- #define CONFIG_SPL_FRAMEWORK
- #define CONFIG_SPL_LIBCOMMON_SUPPORT
diff --git a/alarm/uboot-sunxi/iteaduino_plus_a10.fex b/alarm/uboot-sunxi/iteaduino_plus_a10.fex
index c20c94aa5..2abd8c011 100644
--- a/alarm/uboot-sunxi/iteaduino_plus_a10.fex
+++ b/alarm/uboot-sunxi/iteaduino_plus_a10.fex
@@ -1,1448 +1,913 @@
-
-
-
-
-
-
-
-
-
-
-
-
- sunxi-boards/sys_config/a10/iteaduino_plus_a10.fex at master · linux-sunxi/sunxi-boards · GitHub
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
- Skip to content
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
- Something went wrong with that request. Please try again.
-
-
-
-
-
-
-
-
-
-
+[product]
+version = "1.0"
+machine = "A10-EVB-V1.2"
+
+[target]
+boot_clock = 1008
+dcdc2_vol = 1400
+dcdc3_vol = 1250
+ldo2_vol = 3000
+ldo3_vol = 2800
+ldo4_vol = 2800
+pll4_freq = 960
+pll6_freq = 960
+power_start = 0
+storage_type = 0
+
+[card_boot]
+logical_start = 40960
+sprite_gpio0 =
+
+[card_boot0_para]
+card_ctrl = 0
+card_high_speed = 1
+card_line = 4
+sdc_d1 = port:PF00<2><1>
+sdc_d0 = port:PF01<2><1>
+sdc_clk = port:PF02<2><1>
+sdc_cmd = port:PF03<2><1>
+sdc_d3 = port:PF04<2><1>
+sdc_d2 = port:PF05<2><1>
+
+[card_boot2_para]
+card_ctrl = 2
+card_high_speed = 1
+card_line = 4
+sdc_cmd = port:PC06<3><1>
+sdc_clk = port:PC07<3><1>
+sdc_d0 = port:PC08<3><1>
+sdc_d1 = port:PC09<3><1>
+sdc_d2 = port:PC10<3><1>
+sdc_d3 = port:PC11<3><1>
+
+[twi_para]
+twi_port = 0
+twi_scl = port:PB00<2>
+twi_sda = port:PB01<2>
+
+[uart_para]
+uart_debug_port = 0
+uart_debug_tx = port:PB22<2><1>
+uart_debug_rx = port:PB23<2><1>
+
+[uart_force_debug]
+uart_debug_port = 0
+uart_debug_tx = port:PF02<4>
+uart_debug_rx = port:PF04<4>
+
+[jtag_para]
+jtag_enable = 1
+jtag_ms = port:PB14<3>
+jtag_ck = port:PB15<3>
+jtag_do = port:PB16<3>
+jtag_di = port:PB17<3>
+
+[dram_para]
+dram_baseaddr = 0x40000000
+dram_clk = 480
+dram_type = 3
+dram_rank_num = 1
+dram_chip_density = 4096
+dram_io_width = 16
+dram_bus_width = 32
+dram_cas = 6
+dram_zq = 0x7b
+dram_odt_en = 0
+dram_size = 1024
+dram_tpr0 = 0x30926692
+dram_tpr1 = 0x1090
+dram_tpr2 = 0x1a0c8
+dram_tpr3 = 0x0
+dram_tpr4 = 0x0
+dram_tpr5 = 0x0
+dram_emr1 = 0x0
+dram_emr2 = 0x0
+dram_emr3 = 0x0
+
+[mali_para]
+mali_used = 1
+mali_clkdiv = 3
+
+[g2d_para]
+g2d_used = 1
+g2d_size = 0x1000000
+
+[emac_para]
+emac_used = 1
+emac_rxd3 = port:PA00<2>
+emac_rxd2 = port:PA01<2>
+emac_rxd1 = port:PA02<2>
+emac_rxd0 = port:PA03<2>
+emac_txd3 = port:PA04<2>
+emac_txd2 = port:PA05<2>
+emac_txd1 = port:PA06<2>
+emac_txd0 = port:PA07<2>
+emac_rxclk = port:PA08<2>
+emac_rxerr = port:PA09<2>
+emac_rxdV = port:PA10<2>
+emac_mdc = port:PA11<2>
+emac_mdio = port:PA12<2>
+emac_txen = port:PA13<2>
+emac_txclk = port:PA14<2>
+emac_crs = port:PA15<2>
+emac_col = port:PA16<2>
+emac_reset = port:PA17<1>
+
+[twi0_para]
+twi0_used = 1
+twi0_scl = port:PB00<2>
+twi0_sda = port:PB01<2>
+
+[twi1_para]
+twi1_used = 1
+twi1_scl = port:PB18<2>
+twi1_sda = port:PB19<2>
+
+[twi2_para]
+twi2_used = 1
+twi2_scl = port:PB20<2>
+twi2_sda = port:PB21<2>
+
+[uart_para0]
+uart_used = 1
+uart_port = 0
+uart_type = 2
+uart_tx = port:PB22<2><1>
+uart_rx = port:PB23<2><1>
+
+[uart_para1]
+uart_used = 0
+uart_port = 1
+uart_type = 8
+uart_tx = port:PA10<4><1>
+uart_rx = port:PA11<4><1>
+uart_rts = port:PA12<4><1>
+uart_cts = port:PA13<4><1>
+uart_dtr = port:PA14<4><1>
+uart_dsr = port:PA15<4><1>
+uart_dcd = port:PA16<4><1>
+uart_ring = port:PA17<4><1>
+
+[uart_para2]
+uart_used = 1
+uart_port = 2
+uart_type = 4
+uart_tx = port:PI18<3><1>
+uart_rx = port:PI19<3><1>
+uart_rts = port:PI16<3><1>
+uart_cts = port:PI17<3><1>
+
+[uart_para3]
+uart_used = 1
+uart_port = 3
+uart_type = 4
+uart_tx = port:PG06<4><1>
+uart_rx = port:PG07<4><1>
+uart_rts = port:PG08<4><1>
+uart_cts = port:PG09<4><1>
+
+[uart_para4]
+uart_used = 1
+uart_port = 4
+uart_type = 2
+uart_tx = port:PG10<4><1>
+uart_rx = port:PG11<4><1>
+
+[uart_para5]
+uart_used = 0
+uart_port = 5
+uart_type = 2
+uart_tx = port:PI10<3><1>
+uart_rx = port:PI11<3><1>
+
+[uart_para6]
+uart_used = 0
+uart_port = 6
+uart_type = 2
+uart_tx = port:PI12<3><1>
+uart_rx = port:PI13<3><1>
+
+[uart_para7]
+uart_used = 1
+uart_port = 7
+uart_type = 2
+uart_tx = port:PI20<3><1>
+uart_rx = port:PI21<3><1>
+
+[spi0_para]
+spi_used = 1
+spi_cs_bitmap = 1
+spi_cs0 = port:PI10<2>
+spi_sclk = port:PI11<2>
+spi_mosi = port:PI12<2>
+spi_miso = port:PI13<2>
+
+[spi1_para]
+spi_used = 0
+spi_cs_bitmap = 1
+spi_cs0 = port:PA00<4>
+spi_sclk = port:PA01<4>
+spi_mosi = port:PA02<4>
+spi_miso = port:PA03<4>
+
+[spi2_para]
+spi_used = 0
+spi_cs_bitmap = 1
+spi_cs0 = port:PB14<2>
+spi_sclk = port:PB15<2>
+spi_mosi = port:PB16<2>
+spi_miso = port:PB17<2>
+spi_cs0 = port:PC19<3>
+spi_sclk = port:PC20<3>
+spi_mosi = port:PC21<3>
+spi_miso = port:PC22<3>
+
+[spi3_para]
+spi_used = 0
+spi_cs_bitmap = 1
+spi_cs0 = port:PA05<3>
+spi_sclk = port:PI06<3>
+spi_mosi = port:PI07<3>
+spi_miso = port:PI08<3>
+spi_cs1 = port:PA09<3>
+
+[spi_devices]
+spi_dev_num = 1
+
+[spi_board0]
+modalias = "spidev"
+max_speed_hz = 12000000
+bus_num = 0
+chip_select = 0
+mode = 3
+full_duplex = 1
+manual_cs = 0
+
+[rtp_para]
+rtp_used = 1
+rtp_screen_size = 7
+rtp_regidity_level = 5
+rtp_press_threshold_enable = 1
+rtp_press_threshold = 0x1f40
+rtp_sensitive_level = 0xf
+rtp_exchange_x_y_flag = 0
+
+[ctp_para]
+ctp_used = 0
+ctp_name = "ft5x_ts"
+ctp_twi_id = 2
+ctp_twi_addr = 0x70
+ctp_screen_max_x = 800
+ctp_screen_max_y = 480
+ctp_revert_x_flag = 0
+ctp_revert_y_flag = 0
+ctp_exchange_x_y_flag = 0
+ctp_int_port = port:PH21<6>
+ctp_wakeup = port:PB13<1><1>
+ctp_io_port = port:PH21<0>
+
+[tkey_para]
+tkey_used = 0
+tkey_name = "hv_keypad"
+tkey_twi_id = 2
+tkey_twi_addr = 0x62
+tkey_int = port:PI13<6>
+
+[motor_para]
+motor_used = 0
+motor_shake = port:PB03<1><1>
+
+[nand_para]
+nand_used = 1
+nand_we = port:PC00<2>