mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
core/openssl(-cryptodev): fix to get rid of ia32 crap
This commit is contained in:
parent
b9340d5682
commit
a997c5238b
4 changed files with 38 additions and 8 deletions
|
@ -27,15 +27,15 @@ backup=('etc/ssl/openssl.cnf')
|
|||
conflicts=('openssl')
|
||||
provides=("openssl=${pkgver}")
|
||||
source=("https://www.openssl.org/source/${pkgname}-${_ver}.tar.gz"
|
||||
"https://www.openssl.org/source/${pkgname}-${_ver}.tar.gz.asc"
|
||||
'fix-manpages.patch'
|
||||
'no-rpath.patch'
|
||||
'ca-dir.patch')
|
||||
'ca-dir.patch'
|
||||
'alarm.patch')
|
||||
md5sums=('a0104320c0997cd33e18b8ea798609d1'
|
||||
'df6d2432d3ff03f72fa6744d6f1a7f34'
|
||||
'5bbc0655bda2af95bc8eb568963ce8ba'
|
||||
'dc78d3d06baffc16217519242ce92478'
|
||||
'3bf51be3a1bbd262be46dc619f92aa90')
|
||||
'3bf51be3a1bbd262be46dc619f92aa90'
|
||||
'5c6b1cb3fc9bb0a3e5da0a973df76b33')
|
||||
|
||||
build() {
|
||||
cd $srcdir/$_pkgname-$_ver
|
||||
|
@ -55,6 +55,8 @@ build() {
|
|||
patch -p0 -i $srcdir/no-rpath.patch
|
||||
# set ca dir to /etc/ssl by default
|
||||
patch -p0 -i $srcdir/ca-dir.patch
|
||||
# get rid of ia32 crap
|
||||
patch -p1 -i $srcdir/alarm.patch
|
||||
# mark stack as non-executable: http://bugs.archlinux.org/task/12434
|
||||
./Configure --prefix=/usr --openssldir=/etc/ssl --libdir=lib \
|
||||
-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS -DHASH_MAX_LEN=64 \
|
||||
|
|
13
core/openssl-cryptodev/alarm.patch
Normal file
13
core/openssl-cryptodev/alarm.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff -urN a/crypto/evp/e_rc4_hmac_md5.c b/crypto/evp/e_rc4_hmac_md5.c
|
||||
--- a/crypto/evp/e_rc4_hmac_md5.c 2012-04-18 11:51:33.000000000 -0600
|
||||
+++ b/crypto/evp/e_rc4_hmac_md5.c 2012-04-19 12:10:44.435615332 -0600
|
||||
@@ -289,8 +289,7 @@
|
||||
|
||||
const EVP_CIPHER *EVP_rc4_hmac_md5(void)
|
||||
{
|
||||
- extern unsigned int OPENSSL_ia32cap_P[];
|
||||
/* RC4_CHAR flag ------------vvvvv */
|
||||
- return(OPENSSL_ia32cap_P[0]&(1<<20) ? NULL : &r4_hmac_md5_cipher);
|
||||
+ return(&r4_hmac_md5_cipher);
|
||||
}
|
||||
#endif
|
|
@ -21,15 +21,15 @@ optdepends=('ca-certificates')
|
|||
options=('!makeflags')
|
||||
backup=('etc/ssl/openssl.cnf')
|
||||
source=("https://www.openssl.org/source/${pkgname}-${_ver}.tar.gz"
|
||||
"https://www.openssl.org/source/${pkgname}-${_ver}.tar.gz.asc"
|
||||
'fix-manpages.patch'
|
||||
'no-rpath.patch'
|
||||
'ca-dir.patch')
|
||||
'ca-dir.patch'
|
||||
'alarm.patch')
|
||||
md5sums=('a0104320c0997cd33e18b8ea798609d1'
|
||||
'df6d2432d3ff03f72fa6744d6f1a7f34'
|
||||
'5bbc0655bda2af95bc8eb568963ce8ba'
|
||||
'dc78d3d06baffc16217519242ce92478'
|
||||
'3bf51be3a1bbd262be46dc619f92aa90')
|
||||
'3bf51be3a1bbd262be46dc619f92aa90'
|
||||
'5c6b1cb3fc9bb0a3e5da0a973df76b33')
|
||||
|
||||
build() {
|
||||
cd $srcdir/$pkgname-$_ver
|
||||
|
@ -49,6 +49,8 @@ build() {
|
|||
patch -p0 -i $srcdir/no-rpath.patch
|
||||
# set ca dir to /etc/ssl by default
|
||||
patch -p0 -i $srcdir/ca-dir.patch
|
||||
# get rid of ia32 crap
|
||||
patch -p1 -i $srcdir/alarm.patch
|
||||
# mark stack as non-executable: http://bugs.archlinux.org/task/12434
|
||||
./Configure --prefix=/usr --openssldir=/etc/ssl --libdir=lib \
|
||||
shared zlib enable-md2 \
|
||||
|
|
13
core/openssl/alarm.patch
Normal file
13
core/openssl/alarm.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff -urN a/crypto/evp/e_rc4_hmac_md5.c b/crypto/evp/e_rc4_hmac_md5.c
|
||||
--- a/crypto/evp/e_rc4_hmac_md5.c 2012-04-18 11:51:33.000000000 -0600
|
||||
+++ b/crypto/evp/e_rc4_hmac_md5.c 2012-04-19 12:10:44.435615332 -0600
|
||||
@@ -289,8 +289,7 @@
|
||||
|
||||
const EVP_CIPHER *EVP_rc4_hmac_md5(void)
|
||||
{
|
||||
- extern unsigned int OPENSSL_ia32cap_P[];
|
||||
/* RC4_CHAR flag ------------vvvvv */
|
||||
- return(OPENSSL_ia32cap_P[0]&(1<<20) ? NULL : &r4_hmac_md5_cipher);
|
||||
+ return(&r4_hmac_md5_cipher);
|
||||
}
|
||||
#endif
|
Loading…
Reference in a new issue