added extra/scribus 1.4.2-2

This commit is contained in:
Kevin Mihelich 2013-06-06 21:07:22 +00:00
parent 725561096b
commit a9dfed0ebd
3 changed files with 82 additions and 0 deletions

59
extra/scribus/PKGBUILD Normal file
View file

@ -0,0 +1,59 @@
# $Id: PKGBUILD 178994 2013-03-01 10:25:10Z andrea $
# Contributor: Ronald van Haren <ronald.archlinux.org>
# Contributor: tobias <tobias@archlinux.org>
# Contributor: Ben <ben@benmazer.net>
# Maintainer: Daniel J Griffiths <ghost1227@archlinux.us>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch for qreal on ARM
pkgname=scribus
pkgver=1.4.2
pkgrel=2
pkgdesc="A desktop publishing program"
arch=('i686' 'x86_64')
url="http://www.scribus.net"
license=('GPL')
install=scribus.install
depends=('libcups>=1.3.11' 'lcms2' 'qt4' 'ghostscript>=8.70' \
'libart-lgpl>=2.3.20' 'python2' 'libxml2>=2.7.3' 'cairo' \
'desktop-file-utils' 'shared-mime-info' \
'hyphen' 'aspell' 'boost-libs')
makedepends=('cmake' 'boost' 'mesa')
options=(!libtool)
source=(http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.xz
arm.patch)
sha1sums=('6e67e98fa315a2890d9cbb12eed49ecebb7f11cb'
'efb1fbf23b29527397f5fd7fe999bbeef50e5129')
build() {
cd "${srcdir}/scribus-${pkgver}"
patch -p1 -i ../arm.patch
cd "${srcdir}"
sed -i -e 's|#!/usr/bin/python|#!/usr/bin/python2|' \
-e 's|#!/usr/bin/env python|#!/usr/bin/env python2|' \
scribus-${pkgver}/scribus/plugins/scriptplugin/{samples,scripts}/*
mkdir build
cd build
cmake ../scribus-${pkgver} \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_SKIP_RPATH=ON \
-DWANT_CAIRO=1 \
-DLIB_SUFFIX=""
make
}
package() {
cd "${srcdir}/build"
make DESTDIR="${pkgdir}" install
# fix icon path in .desktop file
sed -i 's|Icon=scribus|Icon=/usr/share/scribus/icons/scribus.png|' \
"${srcdir}/scribus-${pkgver}/scribus.desktop"
install -Dm644 "${srcdir}/scribus-${pkgver}/scribus.desktop" \
"${pkgdir}/usr/share/applications/scribus.desktop"
}

12
extra/scribus/arm.patch Normal file
View file

@ -0,0 +1,12 @@
diff -urN a/scribus/scribus.cpp b/scribus/scribus.cpp
--- a/scribus/scribus.cpp 2012-12-31 02:23:05.000000000 -0700
+++ b/scribus/scribus.cpp 2013-06-06 14:46:51.107008231 -0600
@@ -6688,7 +6688,7 @@
if (mode == modeDrawShapes)
{
doc->SubMode = modeToolBar->SubMode;
- doc->ShapeValues = modeToolBar->ShapeVals;
+ doc->ShapeValues = (double*)modeToolBar->ShapeVals;
doc->ValCount = modeToolBar->ValCount;
propertiesPalette->SCustom->setIcon(propertiesPalette->SCustom->getIconPixmap(doc->SubMode));
}

View file

@ -0,0 +1,11 @@
post_install() {
update-mime-database usr/share/mime &> /dev/null
update-desktop-database -q
}
post_upgrade() {
post_install $1
}
post_remove() {
post_install $1
}