mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
community/rust to 1.26.0-1
This commit is contained in:
parent
ffb5d3dcb1
commit
a9fa29e3c2
3 changed files with 11 additions and 41 deletions
|
@ -1,32 +0,0 @@
|
||||||
From 5dbc650a60ddb230f59e5a18ffd298b033566945 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Johannes=20L=C3=B6thberg?= <johannes@kyriasis.com>
|
|
||||||
Date: Thu, 20 Jul 2017 23:07:01 +0200
|
|
||||||
Subject: [PATCH] librustc_llvm/build: Force link against libffi
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
`llvm-config --libs` doesn't output libffi in many cases. Fixing it
|
|
||||||
turned out to take quite a bit of effort, so force libffi linking in
|
|
||||||
here for now.
|
|
||||||
|
|
||||||
Signed-off-by: Johannes Löthberg <johannes@kyriasis.com>
|
|
||||||
---
|
|
||||||
src/librustc_llvm/build.rs | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/src/librustc_llvm/build.rs b/src/librustc_llvm/build.rs
|
|
||||||
index 3f0f536960..7dc0c40c9d 100644
|
|
||||||
--- a/src/librustc_llvm/build.rs
|
|
||||||
+++ b/src/librustc_llvm/build.rs
|
|
||||||
@@ -220,6 +220,7 @@ fn main() {
|
|
||||||
};
|
|
||||||
println!("cargo:rustc-link-lib={}={}", kind, name);
|
|
||||||
}
|
|
||||||
+ println!("cargo:rustc-link-lib=dylib=ffi");
|
|
||||||
|
|
||||||
// LLVM ldflags
|
|
||||||
//
|
|
||||||
--
|
|
||||||
2.13.3
|
|
||||||
|
|
|
@ -13,7 +13,7 @@ highmem=1
|
||||||
|
|
||||||
pkgname=('rust' 'rust-docs')
|
pkgname=('rust' 'rust-docs')
|
||||||
epoch=1
|
epoch=1
|
||||||
pkgver=1.25.0
|
pkgver=1.26.0
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
|
|
||||||
pkgdesc='Systems programming language focused on safety, speed and concurrency'
|
pkgdesc='Systems programming language focused on safety, speed and concurrency'
|
||||||
|
@ -21,22 +21,22 @@ url='https://www.rust-lang.org/'
|
||||||
arch=('x86_64')
|
arch=('x86_64')
|
||||||
license=('MIT' 'Apache')
|
license=('MIT' 'Apache')
|
||||||
|
|
||||||
makedepends=('rust' 'libffi' 'perl' 'python2' 'curl' 'cmake')
|
makedepends=('rust' 'libffi' 'perl' 'python2' 'curl' 'cmake' 'ninja')
|
||||||
|
|
||||||
options=('!emptydirs')
|
options=('!emptydirs')
|
||||||
|
|
||||||
source=("https://static.rust-lang.org/dist/rustc-$pkgver-src.tar.gz"{,.asc}
|
source=("https://static.rust-lang.org/dist/rustc-$pkgver-src.tar.gz"{,.asc}
|
||||||
bootstrap-config.toml)
|
config.toml)
|
||||||
|
|
||||||
sha256sums=('eef63a0aeea5147930a366aee78cbde248bb6e5c6868801bdf34849152965d2d'
|
sha256sums=('4fb09bc4e233b71dcbe08a37a3f38cabc32219745ec6a628b18a55a1232281dd'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'8e30fcd8633e1900056ecbcc7267fea23e8e08889460239c614d4dcd796ce4f3')
|
'c0988fa7cb0dd3686379df9e0c45104895b69519a258f8a4ae56bd6af1670639')
|
||||||
validpgpkeys=('108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE') # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
|
validpgpkeys=('108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE') # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd "rustc-$pkgver-src"
|
cd "rustc-$pkgver-src"
|
||||||
|
|
||||||
cp "$srcdir"/bootstrap-config.toml config.toml
|
cp "$srcdir"/config.toml config.toml
|
||||||
|
|
||||||
if [[ $CARCH == armv7h ]]; then
|
if [[ $CARCH == armv7h ]]; then
|
||||||
mkdir path
|
mkdir path
|
||||||
|
|
|
@ -1,11 +1,11 @@
|
||||||
|
[llvm]
|
||||||
|
ninja = true
|
||||||
|
|
||||||
[build]
|
[build]
|
||||||
cargo = "/usr/bin/cargo"
|
cargo = "/usr/bin/cargo"
|
||||||
rustc = "/usr/bin/rustc"
|
rustc = "/usr/bin/rustc"
|
||||||
python = "python2.7"
|
python = "python2.7"
|
||||||
extended = true
|
extended = true
|
||||||
# Verbosity level: 0 == not verbose, 1 == verbose, 2 == very verbose
|
|
||||||
verbose = 0
|
|
||||||
# Build the sanitizer runtimes
|
|
||||||
sanitizers = false
|
sanitizers = false
|
||||||
|
|
||||||
[install]
|
[install]
|
||||||
|
@ -20,3 +20,5 @@ debuginfo = true
|
||||||
debuginfo-lines = true
|
debuginfo-lines = true
|
||||||
|
|
||||||
channel = "stable"
|
channel = "stable"
|
||||||
|
|
||||||
|
rpath = false
|
Loading…
Reference in a new issue