community/polymake to 3.1-5

This commit is contained in:
Kevin Mihelich 2017-12-04 13:46:31 +00:00
parent 883de2edc5
commit aa0864e5cc
2 changed files with 22 additions and 5 deletions

View file

@ -9,19 +9,20 @@ highmem=1
pkgname=polymake
pkgver=3.1
pkgrel=4
pkgrel=5
pkgdesc="Open source software for research in polyhedral geometry"
arch=(i686 x86_64)
arch=(x86_64)
url="https://polymake.org/"
license=(GPL)
options=('!distcc')
depends=(mpfr perl-xml-writer perl-xml-libxml perl-xml-libxslt perl-term-readline-gnu perl-term-readkey)
makedepends=(normaliz cddlib lrs bliss-graphs ppl apache-ant boost singular)
makedepends=(normaliz cddlib lrs ppl apache-ant boost singular bliss-graphs)
optdepends=('singular: ideal library' 'ppl: polytope library' 'java-runtime: java module')
source=("https://polymake.org/lib/exe/fetch.php/download/polymake-$pkgver-minimal.tar.bz2"
'gcc7.patch')
gcc7.patch polymake-no-znow.patch)
sha256sums=('f751e3c34e5ee3a015a99d1151b357130f15878c0bcea82827a19a12009e7fc0'
'e93c6d16a13b2701c999ff076fd6510f024b130cd47db2f86f096864b52ae37c')
'e93c6d16a13b2701c999ff076fd6510f024b130cd47db2f86f096864b52ae37c'
'e56b49bfb60bdb2fc91d267efe09731f65d1f0a469322530bcc409b60fdb6578')
prepare() {
cd polymake-$pkgver
@ -30,11 +31,16 @@ prepare() {
sed -e 's|lrslib.h|lrslib/lrslib.h|g' -i bundled/lrs/apps/polytope/src/lrs_interface.cc \
-i bundled/sympol/external/sympol/sympol/raycomputationlrs.cpp
sed -e 's|<lrslib.h>|<lrslib/lrslib.h>|g' -e 's|\$lrs_path\/include|$lrs_path/include/lrslib|g' -i bundled/lrs/configure.pl
# Fix undefined symbols
patch -p1 -i ../polymake-no-znow.patch
}
build() {
cd polymake-$pkgver
LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
export LDFLAGS=${LDFLAGS/,-z,now} # Fix undefined symbols
export CFLAGS=${CFLAGS/-fno-plt}
export CXXFLAGS=${CXXFLAGS/-fno-plt}
./configure --prefix=/usr CXXOPT="-O1"
make -j2
}

View file

@ -0,0 +1,11 @@
--- polymake-3.1/support/configure.pl.orig 2017-12-03 09:21:44.528067697 +0000
+++ polymake-3.1/support/configure.pl 2017-12-03 09:25:17.258583093 +0000
@@ -450,6 +450,8 @@
$Libs =$vars{LIBS} || "";
$LDsharedFlags=$Config::Config{lddlflags};
+$LDsharedFlags =~ s/,-z,now//g;
$LDcallableFlags= $options{callable} eq ".none." ? "none" : "$LDsharedFlags $Config::Config{ldflags}";
+$LDcallableFlags =~ s/,-z,now//g;
print "checking C++ library ... ";