community/supercollider to 3.8.0-3

This commit is contained in:
Kevin Mihelich 2017-12-24 22:26:34 +00:00
parent b28e3ab6c6
commit aa0b452497
4 changed files with 58 additions and 32 deletions

View file

@ -1,5 +1,6 @@
# $Id$
# Maintainer : speps <speps at aur dot archlinux dot org>
# Maintainer: David Runge <dave@sleepmap.de>
# Contributor: speps <speps at aur dot archlinux dot org>
# Contributor: osc <farid at archlinux-br.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
@ -8,41 +9,49 @@
_name=SuperCollider
pkgname=supercollider
pkgver=3.8.0
pkgrel=2
pkgrel=3
pkgdesc="An environment and programming language for real time audio synthesis and algorithmic composition"
arch=('i686' 'x86_64')
url="http://supercollider.sourceforge.net/"
arch=('x86_64')
url="https://supercollider.github.io"
license=('GPL3')
depends=('jack' 'fftw' 'cwiid' 'qt5-webkit')
makedepends=('cmake' 'ruby' 'vim' 'emacs' 'qt5-tools' 'boost')
depends=('boost-libs' 'fftw' 'jack' 'qt5-webkit')
makedepends=('boost' 'cmake' 'emacs' 'qt5-tools')
optdepends=('emacs: emacs interface'
'gedit: gedit interface'
'vim: vim interface'
'ruby: vim support')
source=("https://github.com/supercollider/supercollider/releases/download/Version-$pkgver/SuperCollider-$pkgver-Source-linux.tar.bz2"
supercollider-cxxflags.patch)
md5sums=('f9c077e92707ae187c5f10cfddccf291'
'4f62489286fe8008d6013fc59047c20b')
'gedit: gedit interface')
source=("https://github.com/${pkgname}/${pkgname}/releases/download/Version-${pkgver}/${_name}-${pkgver}-Source-linux.tar.bz2"
"gcc7-bind-functional.patch")
install="${pkgname}.install"
sha512sums=('305898067cb323682ca3dc65b3f093658192dbad228632d928f2fbd4a635c651f49e2e4f32c338997aafd48a22b739cd80de4296f747c3f1810ddede0aff283a'
'7b702d2bfdd18d8201d7ff5e5d2680f1137078c48e59ac15abf96d601b9eaabf8c612527a61d7987661edb73e483f91711cc80de3091b3027a21fd19cb6f8029')
prepare() {
cd $_name-Source
# Fix CXXFLAGS
patch -p1 -i ../supercollider-cxxflags.patch
cd "${_name}-Source"
# fix the use of std::bind for gcc7
# https://github.com/supercollider/supercollider/pull/3015
# https://github.com/supercollider/supercollider/pull/3029
patch -Np0 -i "../gcc7-bind-functional.patch"
# requires out-of-tree build
[ -d bld ] || mkdir bld && cd bld
}
build() {
cd "$srcdir/$_name-Source"
[ -d b ] || mkdir b && cd b
cd "${_name}-Source/bld"
cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DLIBSCSYNTH=ON \
-DCMAKE_CXX_FLAGS="$CXXFLAGS -DBOOST_MATH_DISABLE_FLOAT128" \
-DSC_VIM=OFF \
-DSYSTEM_BOOST=ON \
-DSSE=OFF -DSSE2=OFF -DSUPERNOVA=OFF -DNOVA_SIMD=ON -DNATIVE=OFF \
-DCMAKE_C_FLAGS="${CFLAGS}"
make
}
package() {
cd "$srcdir/$_name-Source/b"
make DESTDIR="$pkgdir/" install
cd "${_name}-Source/bld"
make DESTDIR="${pkgdir}" install
cd ..
install -Dm644 AUTHORS ${pkgdir}/usr/share/doc/${pkgname}/AUTHORS
install -Dm644 CHANGELOG.md ${pkgdir}/usr/share/doc/${pkgname}/CHANGELOG.md
install -Dm644 README.md ${pkgdir}/usr/share/doc/${pkgname}/README.md
install -Dm644 README_LINUX.md ${pkgdir}/usr/share/doc/${pkgname}/README_LINUX.md
}

View file

@ -0,0 +1,20 @@
--- server/plugins/DiskIO_UGens.cpp 2016-08-22 10:12:21.000000000 +0200
+++ server/plugins/DiskIO_UGens.cpp.fix 2017-12-06 23:45:39.043242894 +0100
@@ -27,6 +27,7 @@
#include <sndfile.h>
#include <atomic>
+#include <functional>
#include <new>
#include <SC_Lock.h>
--- lang/LangPrimSource/PyrSerialPrim.cpp 2016-08-22 10:12:21.000000000 +0200
+++ lang/LangPrimSource/PyrSerialPrim.cpp.fix 2017-12-07 00:06:12.756776492 +0100
@@ -27,6 +27,7 @@
#include <errno.h>
#include <fcntl.h>
+#include <functional>
#include <stdint.h>
#include <stdio.h>
#include <stdlib.h>

View file

@ -1,11 +0,0 @@
--- SuperCollider-Source/CMakeLists.txt.orig 2016-10-23 10:21:32.322819928 +0000
+++ SuperCollider-Source/CMakeLists.txt 2016-10-23 10:21:52.259731856 +0000
@@ -240,7 +240,7 @@
if (CMAKE_COMPILER_IS_GNUCXX OR CMAKE_COMPILER_IS_CLANG)
if (SSE)
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -msse")
- set(CMAKE_CXX_FLAGS "${CMAKE_C_FLAGS} -msse")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -msse")
if(NOT APPLE AND NOT CMAKE_COMPILER_IS_CLANG)
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mfpmath=sse")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mfpmath=sse")

View file

@ -0,0 +1,8 @@
post_install () {
echo "The vim plugin 'SCVim' is now developed separately: https://github.com/supercollider/scvim"
echo "Until a package is provided, please use the install methods mentioned in the link."
}
post_upgrade () {
post_install
}